summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-12-14 09:00:46 +0000
committerMark Wright <gienah@gentoo.org>2014-12-14 09:00:46 +0000
commit0e481bab63a129a86e2b967d87e2663f359017e9 (patch)
treea1685c83c3b18ce15715d19385d305112dce8edf /dev-haskell
parentBump resource-pool to 0.2.3.1 (diff)
downloadgentoo-2-0e481bab63a129a86e2b967d87e2663f359017e9.tar.gz
gentoo-2-0e481bab63a129a86e2b967d87e2663f359017e9.tar.bz2
gentoo-2-0e481bab63a129a86e2b967d87e2663f359017e9.zip
Bump haxml to 1.25
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/haxml/ChangeLog8
-rw-r--r--dev-haskell/haxml/files/haxml-1.25-haddock.patch26
-rw-r--r--dev-haskell/haxml/haxml-1.25.ebuild33
3 files changed, 66 insertions, 1 deletions
diff --git a/dev-haskell/haxml/ChangeLog b/dev-haskell/haxml/ChangeLog
index 7de1db5e4c50..4afaaeeff456 100644
--- a/dev-haskell/haxml/ChangeLog
+++ b/dev-haskell/haxml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/haxml
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haxml/ChangeLog,v 1.38 2014/07/02 10:05:36 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haxml/ChangeLog,v 1.39 2014/12/14 09:00:46 gienah Exp $
+
+*haxml-1.25 (14 Dec 2014)
+
+ 14 Dec 2014; Mark Wright <gienah@gentoo.org> +files/haxml-1.25-haddock.patch,
+ +haxml-1.25.ebuild:
+ Bump haxml to 1.25
*haxml-1.24.1 (02 Jul 2014)
diff --git a/dev-haskell/haxml/files/haxml-1.25-haddock.patch b/dev-haskell/haxml/files/haxml-1.25-haddock.patch
new file mode 100644
index 000000000000..fbfdaf878c34
--- /dev/null
+++ b/dev-haskell/haxml/files/haxml-1.25-haddock.patch
@@ -0,0 +1,26 @@
+--- HaXml-1.25-orig/src/Text/XML/HaXml/Schema/TypeConversion.hs 2014-10-29 02:53:24.000000000 +1100
++++ HaXml-1.25/src/Text/XML/HaXml/Schema/TypeConversion.hs 2014-12-08 13:32:58.799433615 +1100
+@@ -38,7 +38,7 @@
+ Just (Right
+ (ComplexType
+ {complex_name=Just t'}))
+- {-| t==t'-}
++ {- | t==t' -}
+ -> (e:)
+ _ -> id
+ _ -> id
+@@ -75,10 +75,10 @@
+ renameSimple n s@UnionOf{} = s{ simple_name = Just n }
+
+
+--- * For now, rather than walk the tree, giving typenames to nodes that were
+--- previously locally-typed, we will instead assume in the pretty-printer
+--- that it can always replace a missing typename with the element name, and
+--- have it resolve to something sensible.
++ -- * For now, rather than walk the tree, giving typenames to nodes that were
++ -- previously locally-typed, we will instead assume in the pretty-printer
++ -- that it can always replace a missing typename with the element name, and
++ -- have it resolve to something sensible.
+ renameLocals :: SchemaItem -> SchemaItem
+ renameLocals s = s
+ -- renameLocals (SchemaElement e)
diff --git a/dev-haskell/haxml/haxml-1.25.ebuild b/dev-haskell/haxml/haxml-1.25.ebuild
new file mode 100644
index 000000000000..93fc326dd503
--- /dev/null
+++ b/dev-haskell/haxml/haxml-1.25.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haxml/haxml-1.25.ebuild,v 1.1 2014/12/14 09:00:46 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+MY_PN="HaXml"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Utilities for manipulating XML documents"
+HOMEPAGE="http://projects.haskell.org/HaXml/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/polyparse-1.10:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+PATCHES=("${FILESDIR}"/${PN}-1.25-haddock.patch)
+
+S="${WORKDIR}/${MY_P}"