summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-04-23 13:38:15 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-04-23 13:38:15 +0000
commit153bb327f75229cdaeb65d409a585f5cf598a079 (patch)
treef639e3736d9dfa5bd23ebfddb65fa457cfafec92 /dev-haskell
parentVersion bumps to 1.10.0 and 1.10.1 (diff)
downloadgentoo-2-153bb327f75229cdaeb65d409a585f5cf598a079.tar.gz
gentoo-2-153bb327f75229cdaeb65d409a585f5cf598a079.tar.bz2
gentoo-2-153bb327f75229cdaeb65d409a585f5cf598a079.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/http/ChangeLog10
-rw-r--r--dev-haskell/http/http-2006.7.7.ebuild7
-rw-r--r--dev-haskell/http/http-3001.0.0.ebuild7
-rw-r--r--dev-haskell/http/http-4000.1.1.ebuild31
-rw-r--r--dev-haskell/http/metadata.xml14
5 files changed, 57 insertions, 12 deletions
diff --git a/dev-haskell/http/ChangeLog b/dev-haskell/http/ChangeLog
index 620e59747616..4326a67b198c 100644
--- a/dev-haskell/http/ChangeLog
+++ b/dev-haskell/http/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/http
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/ChangeLog,v 1.16 2010/11/20 23:38:29 slyfox Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/ChangeLog,v 1.17 2011/04/23 13:38:15 slyfox Exp $
+
+*http-4000.1.1 (23 Apr 2011)
+
+ 23 Apr 2011; Sergei Trofimovich <slyfox@gentoo.org> http-2006.7.7.ebuild,
+ http-3001.0.0.ebuild, +http-4000.1.1.ebuild, metadata.xml:
+ Version bump.
20 Nov 2010; Sergei Trofimovich <slyfox@gentoo.org> http-4000.0.8.ebuild:
Marked ~x86-fbsd (bug #227677).
diff --git a/dev-haskell/http/http-2006.7.7.ebuild b/dev-haskell/http/http-2006.7.7.ebuild
index bbb9f36fa67a..e6b162d77eea 100644
--- a/dev-haskell/http/http-2006.7.7.ebuild
+++ b/dev-haskell/http/http-2006.7.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/http-2006.7.7.ebuild,v 1.5 2007/12/20 13:28:19 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/http-2006.7.7.ebuild,v 1.6 2011/04/23 13:38:15 slyfox Exp $
CABAL_FEATURES="lib profile haddock"
inherit base versionator eutils haskell-cabal
@@ -21,9 +21,10 @@ SLOT="0"
KEYWORDS="~amd64 ~sparc ~x86"
IUSE=""
-DEPEND=">=dev-lang/ghc-6.4
+RDEPEND=">=dev-lang/ghc-6.4
<dev-lang/ghc-6.8
>=dev-haskell/network-1.0"
+DEPEND="${RDEPEND}"
S="${WORKDIR}/${PN}-${MY_PV}"
diff --git a/dev-haskell/http/http-3001.0.0.ebuild b/dev-haskell/http/http-3001.0.0.ebuild
index f6530b24f9b9..372e26303afe 100644
--- a/dev-haskell/http/http-3001.0.0.ebuild
+++ b/dev-haskell/http/http-3001.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/http-3001.0.0.ebuild,v 1.4 2010/07/01 19:57:11 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/http-3001.0.0.ebuild,v 1.5 2011/04/23 13:38:15 slyfox Exp $
CABAL_FEATURES="profile haddock lib"
CABAL_MIN_VERSION=1.2
@@ -18,7 +18,8 @@ SLOT="0"
KEYWORDS="~amd64 ~sparc ~x86"
IUSE=""
-DEPEND=">=dev-lang/ghc-6.4.2
+RDEPEND=">=dev-lang/ghc-6.4.2
dev-haskell/network"
+DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/http/http-4000.1.1.ebuild b/dev-haskell/http/http-4000.1.1.ebuild
new file mode 100644
index 000000000000..aee795321813
--- /dev/null
+++ b/dev-haskell/http/http-4000.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/http-4000.1.1.ebuild,v 1.1 2011/04/23 13:38:15 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+CABAL_FEATURES="lib profile haddock hscolour"
+inherit haskell-cabal
+
+MY_PN="HTTP"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A library for client-side HTTP"
+HOMEPAGE="http://projects.haskell.org/http/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl
+ dev-haskell/network
+ dev-haskell/parsec
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/http/metadata.xml b/dev-haskell/http/metadata.xml
index dde98cf80b95..c234199cc9a3 100644
--- a/dev-haskell/http/metadata.xml
+++ b/dev-haskell/http/metadata.xml
@@ -1,8 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>haskell</herd>
- <maintainer>
- <email>haskell@gentoo.org</email>
- </maintainer>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ The HTTP package supports client-side web programming in Haskell. It lets you set up
+ HTTP connections, transmitting requests and processing the responses coming back, all
+ from within the comforts of Haskell. It's dependent on the network package to operate,
+ but other than that, the implementation is all written in Haskell.
+ </longdescription>
</pkgmetadata>