summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-10-20 02:20:19 +0000
committerMark Wright <gienah@gentoo.org>2013-10-20 02:20:19 +0000
commit24ced07aeae7a8d80f8a0c1f3e18cd16d87b99b0 (patch)
treeb0b97530b7c0a990227d57e8eb5db7adb3f235c6 /dev-haskell
parentBeta channel bump. (diff)
downloadgentoo-2-24ced07aeae7a8d80f8a0c1f3e18cd16d87b99b0.tar.gz
gentoo-2-24ced07aeae7a8d80f8a0c1f3e18cd16d87b99b0.tar.bz2
gentoo-2-24ced07aeae7a8d80f8a0c1f3e18cd16d87b99b0.zip
Patch httpd-shed to fix Ambiguous occurrence 'sClose' with recent network versions
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/httpd-shed/ChangeLog11
-rw-r--r--dev-haskell/httpd-shed/files/httpd-shed-0.4-network.patch21
-rw-r--r--dev-haskell/httpd-shed/httpd-shed-0.4-r1.ebuild28
3 files changed, 58 insertions, 2 deletions
diff --git a/dev-haskell/httpd-shed/ChangeLog b/dev-haskell/httpd-shed/ChangeLog
index 16bb59fbb2ea..8c3776bc78e5 100644
--- a/dev-haskell/httpd-shed/ChangeLog
+++ b/dev-haskell/httpd-shed/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-haskell/httpd-shed
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/httpd-shed/ChangeLog,v 1.7 2012/12/10 21:53:13 slyfox Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/httpd-shed/ChangeLog,v 1.8 2013/10/20 02:20:19 gienah Exp $
+
+*httpd-shed-0.4-r1 (20 Oct 2013)
+
+ 20 Oct 2013; Mark Wright <gienah@gentoo.org>
+ +files/httpd-shed-0.4-network.patch, +httpd-shed-0.4-r1.ebuild:
+ Patch httpd-shed to fix Ambiguous occurrence 'sClose' with recent network
+ versions
10 Dec 2012; Sergei Trofimovich <slyfox@gentoo.org> httpd-shed-0.4.ebuild:
stable on alpha/ia64/sparc (bug #421351)
diff --git a/dev-haskell/httpd-shed/files/httpd-shed-0.4-network.patch b/dev-haskell/httpd-shed/files/httpd-shed-0.4-network.patch
new file mode 100644
index 000000000000..ca5a113b7014
--- /dev/null
+++ b/dev-haskell/httpd-shed/files/httpd-shed-0.4-network.patch
@@ -0,0 +1,21 @@
+[1 of 1] Compiling Network.Shed.Httpd ( Network/Shed/Httpd.hs, dist/build/Network/Shed/Httpd.o )
+
+Network/Shed/Httpd.hs:142:24:
+ Ambiguous occurrence `sClose'
+ It could refer to either `N.sClose',
+ imported from `Network' at Network/Shed/Httpd.hs:38:1-14
+ or `Network.Socket.sClose',
+ imported from `Network.Socket' at Network/Shed/Httpd.hs:48:1-21
+diff --git a/Network/Shed/Httpd.hs b/Network/Shed/Httpd.hs
+index 9dbc2a2..f4f7d5e 100644
+--- a/Network/Shed/Httpd.hs
++++ b/Network/Shed/Httpd.hs
+@@ -139,7 +139,7 @@ initServerMain processBody sockAddr callOut = do
+ hClose h
+ _ -> hClose h
+ return ()
+- ) `finally` sClose sock
++ ) `finally` N.sClose sock
+ where
+ loopIO m = do m
+ loopIO m
diff --git a/dev-haskell/httpd-shed/httpd-shed-0.4-r1.ebuild b/dev-haskell/httpd-shed/httpd-shed-0.4-r1.ebuild
new file mode 100644
index 000000000000..fcf2fc57e5e2
--- /dev/null
+++ b/dev-haskell/httpd-shed/httpd-shed-0.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/httpd-shed/httpd-shed-0.4-r1.ebuild,v 1.1 2013/10/20 02:20:19 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="A simple web-server with an interact style API"
+HOMEPAGE="http://hackage.haskell.org/package/httpd-shed"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="dev-haskell/network:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+PATCHES=("${FILESDIR}"/${P}-network.patch)