summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-01-13 11:57:38 +0000
committerMark Wright <gienah@gentoo.org>2013-01-13 11:57:38 +0000
commit24f89b0fb83a293a358fb48b30e2ad0b225fad4e (patch)
treef5e362d9de3dd2b3d154530ab5b91582a860d842 /dev-haskell
parentStable for x86, wrt bug #450170 (diff)
downloadgentoo-2-24f89b0fb83a293a358fb48b30e2ad0b225fad4e.tar.gz
gentoo-2-24f89b0fb83a293a358fb48b30e2ad0b225fad4e.tar.bz2
gentoo-2-24f89b0fb83a293a358fb48b30e2ad0b225fad4e.zip
Thanks to peanuts for reporting: unconditionally require x11-libs/wxGTK with opengl USE flag. Bump wxcore to 0.13.2.3.
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/wxcore/ChangeLog13
-rw-r--r--dev-haskell/wxcore/files/wxcore-0.13.2.3-ghc-7.6.patch (renamed from dev-haskell/wxcore/files/wxcore-0.13.2.1-ghc-7.6.patch)21
-rw-r--r--dev-haskell/wxcore/wxcore-0.13.2.3.ebuild (renamed from dev-haskell/wxcore/wxcore-0.13.2.1.ebuild)18
-rw-r--r--dev-haskell/wxcore/wxcore-0.90.0.3.ebuild15
4 files changed, 38 insertions, 29 deletions
diff --git a/dev-haskell/wxcore/ChangeLog b/dev-haskell/wxcore/ChangeLog
index b0e853c4922d..b0be879a6ec1 100644
--- a/dev-haskell/wxcore/ChangeLog
+++ b/dev-haskell/wxcore/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-haskell/wxcore
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxcore/ChangeLog,v 1.4 2012/12/27 02:58:09 gienah Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxcore/ChangeLog,v 1.5 2013/01/13 11:57:38 gienah Exp $
+
+*wxcore-0.13.2.3 (13 Jan 2013)
+
+ 13 Jan 2013; Mark Wright <gienah@gentoo.org>
+ +files/wxcore-0.13.2.3-ghc-7.6.patch, +wxcore-0.13.2.3.ebuild,
+ -files/wxcore-0.13.2.1-ghc-7.6.patch, -wxcore-0.13.2.1.ebuild,
+ wxcore-0.90.0.3.ebuild:
+ Thanks to peanuts for reporting: unconditionally require x11-libs/wxGTK with
+ opengl USE flag. Bump wxcore to 0.13.2.3.
*wxcore-0.90.0.3 (27 Dec 2012)
*wxcore-0.13.2.1 (27 Dec 2012)
diff --git a/dev-haskell/wxcore/files/wxcore-0.13.2.1-ghc-7.6.patch b/dev-haskell/wxcore/files/wxcore-0.13.2.3-ghc-7.6.patch
index efc2c7b97a2f..3d5adbea0904 100644
--- a/dev-haskell/wxcore/files/wxcore-0.13.2.1-ghc-7.6.patch
+++ b/dev-haskell/wxcore/files/wxcore-0.13.2.3-ghc-7.6.patch
@@ -1,23 +1,12 @@
---- wxcore-0.13.2.1-orig/wxcore.cabal 2012-02-07 18:27:09.000000000 +1100
-+++ wxcore-0.13.2.1/wxcore.cabal 2012-11-29 17:21:49.458155692 +1100
-@@ -209,7 +209,7 @@
- build-depends:
- array >= 0.2 && < 0.5,
- base >= 4 && < 5,
-- containers >= 0.2 && < 0.5
-+ containers >= 0.2 && < 0.6
- else
- build-depends:
- array >= 0.1 && < 0.3,
---- wxcore-0.13.2.1-orig/src/haskell/Graphics/UI/WXCore/Events.hs 2012-02-07 18:27:09.000000000 +1100
-+++ wxcore-0.13.2.1/src/haskell/Graphics/UI/WXCore/Events.hs 2012-11-29 17:21:49.458155692 +1100
+--- wxcore-0.13.2.3-orig/src/haskell/Graphics/UI/WXCore/Events.hs 2012-09-30 19:56:52.000000000 +1000
++++ wxcore-0.13.2.3/src/haskell/Graphics/UI/WXCore/Events.hs 2013-01-13 10:08:50.415293002 +1100
@@ -1,4 +1,4 @@
-{-# LANGUAGE ForeignFunctionInterface #-}
+{-# LANGUAGE CPP, ForeignFunctionInterface #-}
-----------------------------------------------------------------------------------------
{-| Module : Events
Copyright : (c) Daan Leijen 2003
-@@ -240,6 +240,9 @@
+@@ -241,6 +241,9 @@
import Foreign.Marshal.Alloc
import Foreign.Marshal.Array
import Foreign.Marshal.Utils
@@ -27,8 +16,8 @@
import Data.Char ( chr ) -- used in stc
import Data.Maybe ( fromMaybe, fromJust )
---- wxcore-0.13.2.1-orig/src/haskell/Graphics/UI/WXCore/WxcTypes.hs 2012-02-07 18:27:09.000000000 +1100
-+++ wxcore-0.13.2.1/src/haskell/Graphics/UI/WXCore/WxcTypes.hs 2012-11-29 17:42:22.477244493 +1100
+--- wxcore-0.13.2.3-orig/src/haskell/Graphics/UI/WXCore/WxcTypes.hs 2012-09-30 19:56:52.000000000 +1000
++++ wxcore-0.13.2.3/src/haskell/Graphics/UI/WXCore/WxcTypes.hs 2013-01-13 10:08:50.420293137 +1100
@@ -142,7 +142,12 @@
import Data.Int
diff --git a/dev-haskell/wxcore/wxcore-0.13.2.1.ebuild b/dev-haskell/wxcore/wxcore-0.13.2.3.ebuild
index ac9c2ca759d1..6941e02da136 100644
--- a/dev-haskell/wxcore/wxcore-0.13.2.1.ebuild
+++ b/dev-haskell/wxcore/wxcore-0.13.2.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxcore/wxcore-0.13.2.1.ebuild,v 1.1 2012/12/27 02:58:09 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxcore/wxcore-0.13.2.3.ebuild,v 1.1 2013/01/13 11:57:38 gienah Exp $
EAPI=5
@@ -16,17 +16,18 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="wxWinLL-3.1"
SLOT="${WX_GTK_VER}/${PV}"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="opengl"
+IUSE=""
RDEPEND="dev-haskell/parsec:=[profile?]
dev-haskell/stm:=[profile?]
>dev-haskell/wxdirect-0.12.1.2:${WX_GTK_VER}=[profile?]
- >=dev-lang/ghc-6.10.4:=
- x11-libs/wxGTK:${WX_GTK_VER}=[X,gstreamer,opengl?]"
+ <dev-haskell/wxdirect-0.90:${WX_GTK_VER}=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ x11-libs/wxGTK:${WX_GTK_VER}=[X,gstreamer,opengl]"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.2"
-PATCHES=("${FILESDIR}/${PN}-0.13.2.1-ghc-7.6.patch")
+PATCHES=("${FILESDIR}/${PN}-0.13.2.3-ghc-7.6.patch")
src_prepare() {
base_src_prepare
@@ -34,3 +35,8 @@ src_prepare() {
-i "${S}/Setup.hs" \
|| die "Could not change Setup.hs for wxdirect slot ${WX_GTK_VER}"
}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=splitbase
+}
diff --git a/dev-haskell/wxcore/wxcore-0.90.0.3.ebuild b/dev-haskell/wxcore/wxcore-0.90.0.3.ebuild
index 1160e775da6d..73bb26823ae9 100644
--- a/dev-haskell/wxcore/wxcore-0.90.0.3.ebuild
+++ b/dev-haskell/wxcore/wxcore-0.90.0.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxcore/wxcore-0.90.0.3.ebuild,v 1.1 2012/12/27 02:58:09 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxcore/wxcore-0.90.0.3.ebuild,v 1.2 2013/01/13 11:57:38 gienah Exp $
EAPI=5
@@ -16,13 +16,13 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="wxWinLL-3.1"
SLOT="${WX_GTK_VER}/${PV}"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="opengl"
+IUSE=""
RDEPEND="dev-haskell/parsec:=[profile?]
dev-haskell/stm:=[profile?]
- >=dev-haskell/wxc-0.90.0.4:${WX_GTK_VER}=[opengl,profile?]
+ >=dev-haskell/wxc-0.90.0.4:${WX_GTK_VER}=[profile?]
>=dev-haskell/wxdirect-0.90:${WX_GTK_VER}=[profile?]
- >=dev-lang/ghc-6.10.4:="
+ >=dev-lang/ghc-6.12.1:="
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.2"
@@ -34,3 +34,8 @@ src_prepare() {
-i "${S}/Setup.hs" \
|| die "Could not change Setup.hs for wxdirect slot ${WX_GTK_VER}"
}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=splitbase
+}