summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-05-10 12:06:40 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-05-10 12:06:40 +0000
commit260aec9f641904b90557b01fd9199b84eecac313 (patch)
treee290bb9f4698c5937b4aab81c19e3256307fd644 /dev-haskell
parentVersion bump. (diff)
downloadgentoo-2-260aec9f641904b90557b01fd9199b84eecac313.tar.gz
gentoo-2-260aec9f641904b90557b01fd9199b84eecac313.tar.bz2
gentoo-2-260aec9f641904b90557b01fd9199b84eecac313.zip
Version bump.
(Portage version: 2.2.10_p15/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/yaml/ChangeLog8
-rw-r--r--dev-haskell/yaml/yaml-0.8.4.1.ebuild46
-rw-r--r--dev-haskell/yaml/yaml-0.8.8.2.ebuild48
3 files changed, 55 insertions, 47 deletions
diff --git a/dev-haskell/yaml/ChangeLog b/dev-haskell/yaml/ChangeLog
index 6586ce290987..adf729b8559d 100644
--- a/dev-haskell/yaml/ChangeLog
+++ b/dev-haskell/yaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/yaml
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yaml/ChangeLog,v 1.7 2014/03/12 05:11:39 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yaml/ChangeLog,v 1.8 2014/05/10 12:06:40 slyfox Exp $
+
+*yaml-0.8.8.2 (10 May 2014)
+
+ 10 May 2014; Sergei Trofimovich <slyfox@gentoo.org> +yaml-0.8.8.2.ebuild,
+ -yaml-0.8.4.1.ebuild:
+ Version bump.
09 Mar 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org> yaml-0.8.5.2.ebuild:
x86 stable wrt bug #502706
diff --git a/dev-haskell/yaml/yaml-0.8.4.1.ebuild b/dev-haskell/yaml/yaml-0.8.4.1.ebuild
deleted file mode 100644
index baa9d21af048..000000000000
--- a/dev-haskell/yaml/yaml-0.8.4.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yaml/yaml-0.8.4.1.ebuild,v 1.3 2013/11/24 19:33:59 ago Exp $
-
-EAPI=5
-
-# ebuild generated by hackport 0.3.3.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Support for parsing and rendering YAML documents."
-HOMEPAGE="http://github.com/snoyberg/yaml/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="amd64 x86"
-IUSE="system-libyaml"
-
-RDEPEND=">=dev-haskell/aeson-0.5:=[profile?]
- dev-haskell/attoparsec:=[profile?]
- >=dev-haskell/conduit-0.5:=[profile?]
- <dev-haskell/conduit-1.1:=[profile?]
- >=dev-haskell/resourcet-0.3:=[profile?]
- <dev-haskell/resourcet-0.5:=[profile?]
- dev-haskell/text:=[profile?]
- >=dev-haskell/transformers-0.1:=[profile?]
- <dev-haskell/transformers-0.4:=[profile?]
- dev-haskell/unordered-containers:=[profile?]
- dev-haskell/vector:=[profile?]
- >=dev-lang/ghc-6.10.4:=
- system-libyaml? ( dev-libs/libyaml
- )"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- system-libyaml? ( virtual/pkgconfig
- )
- test? ( >=dev-haskell/hspec-1.3
- dev-haskell/hunit
- )"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag system-libyaml system-libyaml)
-}
diff --git a/dev-haskell/yaml/yaml-0.8.8.2.ebuild b/dev-haskell/yaml/yaml-0.8.8.2.ebuild
new file mode 100644
index 000000000000..3a7a5124ac73
--- /dev/null
+++ b/dev-haskell/yaml/yaml-0.8.8.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yaml/yaml-0.8.8.2.ebuild,v 1.1 2014/05/10 12:06:40 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Support for parsing and rendering YAML documents."
+HOMEPAGE="http://github.com/snoyberg/yaml/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="no-exe system-libyaml"
+
+RDEPEND=">=dev-haskell/aeson-0.5:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ >=dev-haskell/conduit-1.0.11:=[profile?] <dev-haskell/conduit-1.2:=[profile?]
+ >=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/transformers-0.1:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ system-libyaml? ( dev-libs/libyaml )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/aeson
+ dev-haskell/conduit
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hunit
+ dev-haskell/resourcet
+ >=dev-haskell/transformers-0.1 <dev-haskell/transformers-0.4 )
+ system-libyaml? ( virtual/pkgconfig )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag no-exe no-exe) \
+ $(cabal_flag system-libyaml system-libyaml)
+}