summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2010-03-28 17:31:50 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2010-03-28 17:31:50 +0000
commit4349611778f2ed07f721e4eece62ced62ff84fd2 (patch)
tree42bb44d2c80db0c134994c662994024e1f53280b /dev-haskell
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-4349611778f2ed07f721e4eece62ced62ff84fd2.tar.gz
gentoo-2-4349611778f2ed07f721e4eece62ced62ff84fd2.tar.bz2
gentoo-2-4349611778f2ed07f721e4eece62ced62ff84fd2.zip
Bump dev-haskell/hashed-storage, and enable the test suite!
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hashed-storage/ChangeLog10
-rw-r--r--dev-haskell/hashed-storage/hashed-storage-0.3.9.ebuild24
-rw-r--r--dev-haskell/hashed-storage/hashed-storage-0.4.10.ebuild41
3 files changed, 49 insertions, 26 deletions
diff --git a/dev-haskell/hashed-storage/ChangeLog b/dev-haskell/hashed-storage/ChangeLog
index d323fd2b255b..26acbc15552a 100644
--- a/dev-haskell/hashed-storage/ChangeLog
+++ b/dev-haskell/hashed-storage/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/hashed-storage
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashed-storage/ChangeLog,v 1.1 2009/12/13 12:01:24 kolmodin Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashed-storage/ChangeLog,v 1.2 2010/03/28 17:31:50 kolmodin Exp $
+
+*hashed-storage-0.4.10 (28 Mar 2010)
+
+ 28 Mar 2010; Lennart Kolmodin <kolmodin@gentoo.org>
+ -hashed-storage-0.3.9.ebuild, +hashed-storage-0.4.10.ebuild:
+ Bump version, and enabling the test suite!
*hashed-storage-0.3.9 (13 Dec 2009)
diff --git a/dev-haskell/hashed-storage/hashed-storage-0.3.9.ebuild b/dev-haskell/hashed-storage/hashed-storage-0.3.9.ebuild
deleted file mode 100644
index bfd1e22d831f..000000000000
--- a/dev-haskell/hashed-storage/hashed-storage-0.3.9.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashed-storage/hashed-storage-0.3.9.ebuild,v 1.1 2009/12/13 12:01:24 kolmodin Exp $
-
-CABAL_FEATURES="lib profile haddock"
-inherit haskell-cabal
-
-DESCRIPTION="Hashed file storage support code."
-HOMEPAGE="http://hackage.haskell.org/cgi-bin/hackage-scripts/package/hashed-storage"
-SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# not depending on extensible-exceptions forces us to depend on >=ghc-6.10
-RDEPEND=">=dev-lang/ghc-6.10
- dev-haskell/filepath
- =dev-haskell/mmap-0.4*
- dev-haskell/mtl
- dev-haskell/zlib"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/hashed-storage/hashed-storage-0.4.10.ebuild b/dev-haskell/hashed-storage/hashed-storage-0.4.10.ebuild
new file mode 100644
index 000000000000..0e96e7ead34c
--- /dev/null
+++ b/dev-haskell/hashed-storage/hashed-storage-0.4.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashed-storage/hashed-storage-0.4.10.ebuild,v 1.1 2010/03/28 17:31:50 kolmodin Exp $
+
+CABAL_FEATURES="bin lib profile haddock"
+inherit haskell-cabal
+
+DESCRIPTION="Hashed file storage support code."
+HOMEPAGE="http://hackage.haskell.org/cgi-bin/hackage-scripts/package/hashed-storage"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-lang/ghc-6.10
+ dev-haskell/binary
+ dev-haskell/dataenc
+ =dev-haskell/mmap-0.4*
+ dev-haskell/mtl
+ dev-haskell/zlib"
+DEPEND=">=dev-haskell/cabal-1.6
+ test? (
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2
+ dev-haskell/zip-archive
+ )
+ ${RDEPEND}"
+
+if use test; then
+ CABAL_CONFIGURE_FLAGS="--flags=test"
+fi
+
+src_install() {
+ cabal_src_install
+
+ rm "${D}/usr/bin/hashed-storage-test" 2> /dev/null
+ rmdir "${D}/usr/bin" 2> /dev/null # only if empty
+}