summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2005-01-19 10:35:11 +0000
committerAndres Loeh <kosmikus@gentoo.org>2005-01-19 10:35:11 +0000
commit5470bb42f6d785ea20f5fb0d3c4b821e74f146ac (patch)
tree4a46e7d05d28d163db39274ca09958c3186669b9 /dev-haskell
parentchange dep version (diff)
downloadgentoo-2-5470bb42f6d785ea20f5fb0d3c4b821e74f146ac.tar.gz
gentoo-2-5470bb42f6d785ea20f5fb0d3c4b821e74f146ac.tar.bz2
gentoo-2-5470bb42f6d785ea20f5fb0d3c4b821e74f146ac.zip
added happy-1.15
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/happy/ChangeLog7
-rw-r--r--dev-haskell/happy/Manifest6
-rw-r--r--dev-haskell/happy/files/digest-happy-1.151
-rw-r--r--dev-haskell/happy/happy-1.15.ebuild53
4 files changed, 64 insertions, 3 deletions
diff --git a/dev-haskell/happy/ChangeLog b/dev-haskell/happy/ChangeLog
index 4acfaa226944..da047daa0027 100644
--- a/dev-haskell/happy/ChangeLog
+++ b/dev-haskell/happy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/happy
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/ChangeLog,v 1.7 2005/01/01 18:04:41 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/ChangeLog,v 1.8 2005/01/19 10:35:11 kosmikus Exp $
+
+*happy-1.15 (19 Jan 2005)
+
+ 19 Jan 2005; Andres Loeh <kosmikus@gentoo.org> +happy-1.15.ebuild:
+ New happy release.
10 Nov 2004; Andres Loeh <kosmikus@gentoo.org> happy-1.14.ebuild:
Moved inherit to the correct position within the ebuild.
diff --git a/dev-haskell/happy/Manifest b/dev-haskell/happy/Manifest
index dd182dc65c2c..67e75267ebe8 100644
--- a/dev-haskell/happy/Manifest
+++ b/dev-haskell/happy/Manifest
@@ -1,5 +1,7 @@
-MD5 63da8b7578da86861ccec3f4ed18c5ac ChangeLog 1051
+MD5 1ba97b3e5257ddc64884d616f48dd918 happy-1.15.ebuild 662
MD5 fd5ca24eb88ac4a96353617f48830446 happy-1.14.ebuild 701
+MD5 63da8b7578da86861ccec3f4ed18c5ac ChangeLog 1051
MD5 a769ecfcd1cdd2d40986627df7dfb249 metadata.xml 224
-MD5 e4734e57e0ebad5144da11376e6aed02 files/digest-happy-1.14 66
MD5 ccdd754a8212bb8a0ad2fa759a297250 files/happy-1.14-gcc3.4.patch 1849
+MD5 e4734e57e0ebad5144da11376e6aed02 files/digest-happy-1.14 66
+MD5 eb8bc65651f73e615f61ffc31a95a7c6 files/digest-happy-1.15 66
diff --git a/dev-haskell/happy/files/digest-happy-1.15 b/dev-haskell/happy/files/digest-happy-1.15
new file mode 100644
index 000000000000..aee35e3b7d31
--- /dev/null
+++ b/dev-haskell/happy/files/digest-happy-1.15
@@ -0,0 +1 @@
+MD5 02ceb122b904fa4a4290e6ea1072d59e happy-1.15-src.tar.gz 510037
diff --git a/dev-haskell/happy/happy-1.15.ebuild b/dev-haskell/happy/happy-1.15.ebuild
new file mode 100644
index 000000000000..2afb4b5dd585
--- /dev/null
+++ b/dev-haskell/happy/happy-1.15.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.15.ebuild,v 1.1 2005/01/19 10:35:11 kosmikus Exp $
+
+inherit base eutils
+
+DESCRIPTION="A yacc-like parser generator for Haskell"
+HOMEPAGE="http://haskell.org/happy/"
+SRC_URI="http://haskell.cs.yale.edu/happy/dist/${PV}/${P}-src.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc java"
+
+DEPEND=">=virtual/ghc-5.04
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets
+ java? ( >=dev-java/fop-0.20.5 ) )"
+RDEPEND=""
+
+src_unpack() {
+ base_src_unpack
+}
+
+src_compile() {
+ econf || die "configure failed"
+ emake -j1 || die "make failed"
+ if use doc; then
+ emake -j1 html || die "make html failed"
+ if use java; then
+ emake -j1 ps || die "make ps failed"
+ fi
+ fi
+}
+
+src_install() {
+ local docways
+ if use doc; then
+ docways="html"
+ use java && docways="${docways} ps"
+ else
+ docways=""
+ fi
+ # the libdir0 setting is needed for amd64, and does not
+ # harm for other arches; einstall doesn't seem to work
+ make install install-docs XMLDocWays="${docways}" \
+ prefix="${D}/usr" \
+ datadir="${D}/usr/share/${P}" \
+ infodir="${D}/usr/share/info" \
+ mandir="${D}/usr/share/man" \
+ libdir0="${D}/usr/$(get_libdir)" \
+ || die "installation failed"
+}