summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-10-28 16:00:55 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-10-28 16:00:55 +0000
commit6222d005d4f414ab2658236652d48cdf4fc8e131 (patch)
tree35364a62700f03f1e7b31ebe3a907411bdb373b8 /dev-haskell
parentRemove old (diff)
downloadgentoo-2-6222d005d4f414ab2658236652d48cdf4fc8e131.tar.gz
gentoo-2-6222d005d4f414ab2658236652d48cdf4fc8e131.tar.bz2
gentoo-2-6222d005d4f414ab2658236652d48cdf4fc8e131.zip
Restricted tests (broken due to Cabal bug). Fixes bug #436604 by Olivier Huber.
(Portage version: 2.2.0_alpha142_p1/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/text/ChangeLog6
-rw-r--r--dev-haskell/text/text-0.11.2.3.ebuild31
2 files changed, 20 insertions, 17 deletions
diff --git a/dev-haskell/text/ChangeLog b/dev-haskell/text/ChangeLog
index 5122e51e4d4b..75f6691e2346 100644
--- a/dev-haskell/text/ChangeLog
+++ b/dev-haskell/text/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/text
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/text/ChangeLog,v 1.16 2012/09/25 14:16:31 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/text/ChangeLog,v 1.17 2012/10/28 16:00:55 slyfox Exp $
+
+ 28 Oct 2012; Sergei Trofimovich <slyfox@gentoo.org> text-0.11.2.3.ebuild:
+ Restricted tests (broken due to Cabal bug). Fixes bug #436604 by Olivier
+ Huber.
25 Sep 2012; Andreas Schuerch <nativemad@gentoo.org> text-0.11.2.2.ebuild:
x86 stable, see bug 421351
diff --git a/dev-haskell/text/text-0.11.2.3.ebuild b/dev-haskell/text/text-0.11.2.3.ebuild
index ba67533bfe8b..6dd763035a7a 100644
--- a/dev-haskell/text/text-0.11.2.3.ebuild
+++ b/dev-haskell/text/text-0.11.2.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/text/text-0.11.2.3.ebuild,v 1.1 2012/09/14 13:14:16 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/text/text-0.11.2.3.ebuild,v 1.2 2012/10/28 16:00:55 slyfox Exp $
-EAPI=4
+EAPI=5
-# ebuild generated by hackport 0.2.18.9999
+# ebuild generated by hackport 0.3.9999
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="An efficient packed Unicode text type."
@@ -14,27 +14,26 @@ HOMEPAGE="https://github.com/bos/text"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
-SLOT="0"
+SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
# tests fail to build:
# <command line>: cannot satisfy -package-id text-0.11.2.3-inplace:
# text-0.11.2.3-inplace is shadowed by package text-0.11.2.3-db61832d0c4660614c4ceff234ed4abb
# http://hackage.haskell.org/trac/hackage/ticket/807
-IUSE="test"
+RESTRICT="test"
-RDEPEND=">=dev-haskell/deepseq-1.1.0.0[profile?]
- >=dev-lang/ghc-6.10.1"
+RDEPEND=">=dev-haskell/deepseq-1.1.0.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
DEPEND="${RDEPEND}
- test? ( >=dev-haskell/hunit-1.2[profile?]
- >=dev-haskell/quickcheck-2.4[profile?]
- dev-haskell/random[profile?]
- >=dev-haskell/test-framework-0.4[profile?]
- >=dev-haskell/test-framework-hunit-0.2[profile?]
- >=dev-haskell/test-framework-quickcheck2-0.2[profile?]
+ test? ( >=dev-haskell/hunit-1.2
+ >=dev-haskell/quickcheck-2.4
+ dev-haskell/random
+ >=dev-haskell/test-framework-0.4
+ >=dev-haskell/test-framework-hunit-0.2
+ >=dev-haskell/test-framework-quickcheck2-0.2
)
>=dev-haskell/cabal-1.8"
src_configure() {
- # the tests need a utf-8 locale
- cabal_src_configure $(use test && use_enable test tests) #395351
+ haskell-cabal_src_configure --disable-tests # they fail to build
}