summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-02-21 21:57:05 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-02-21 21:57:05 +0000
commit7c6d64cc081d4c2e93b2f35a8aac55f49d03acea (patch)
tree55f4c051d389a28d6b7e64e7ab0651227e93f540 /dev-haskell
parentVersion bump. (diff)
downloadgentoo-2-7c6d64cc081d4c2e93b2f35a8aac55f49d03acea.tar.gz
gentoo-2-7c6d64cc081d4c2e93b2f35a8aac55f49d03acea.tar.bz2
gentoo-2-7c6d64cc081d4c2e93b2f35a8aac55f49d03acea.zip
Version bump.
(Portage version: 2.2.8_p51/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/sha/ChangeLog10
-rw-r--r--dev-haskell/sha/metadata.xml3
-rw-r--r--dev-haskell/sha/sha-1.6.4-r1.ebuild38
3 files changed, 49 insertions, 2 deletions
diff --git a/dev-haskell/sha/ChangeLog b/dev-haskell/sha/ChangeLog
index 92ed1988eb78..efe8911363ce 100644
--- a/dev-haskell/sha/ChangeLog
+++ b/dev-haskell/sha/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/sha
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/sha/ChangeLog,v 1.7 2013/07/21 17:26:40 ottxor Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/sha/ChangeLog,v 1.8 2014/02/21 21:57:05 slyfox Exp $
+
+*sha-1.6.4-r1 (21 Feb 2014)
+
+ 21 Feb 2014; Sergei Trofimovich <slyfox@gentoo.org> +sha-1.6.4-r1.ebuild,
+ metadata.xml:
+ Version bump.
21 Jul 2013; Christoph Junghans <ottxor@gentoo.org> sha-1.6.1.ebuild:
added ~amd64-linux (tested by me)
diff --git a/dev-haskell/sha/metadata.xml b/dev-haskell/sha/metadata.xml
index b3a30d785b5d..a291d71d2639 100644
--- a/dev-haskell/sha/metadata.xml
+++ b/dev-haskell/sha/metadata.xml
@@ -5,6 +5,9 @@
<maintainer>
<email>haskell@gentoo.org</email>
</maintainer>
+ <use>
+ <flag name="exe">Build a sha1 and a sha384 executable similar to 'md5sum'.</flag>
+ </use>
<longdescription>
This library implements the SHA suite of message digest functions,
according to NIST FIPS 180-2 (with the SHA-224 addendum), as well
diff --git a/dev-haskell/sha/sha-1.6.4-r1.ebuild b/dev-haskell/sha/sha-1.6.4-r1.ebuild
new file mode 100644
index 000000000000..48e9e9ab2430
--- /dev/null
+++ b/dev-haskell/sha/sha-1.6.4-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/sha/sha-1.6.4-r1.ebuild,v 1.1 2014/02/21 21:57:05 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+#hackport: flags: -decoderinterface
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="SHA"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Implementations of the SHA suite of message digest functions"
+HOMEPAGE="http://hackage.haskell.org/package/SHA"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="exe"
+
+RDEPEND=">=dev-haskell/binary-0.7:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=decoderinterface \
+ $(cabal_flag exe exe)
+}