summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2008-01-13 23:32:52 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2008-01-13 23:32:52 +0000
commit9ae27ae0c3f3ac9f0d3fece578ae80c3569671a3 (patch)
tree7ffe74696eb639595600a34a595f62c35c70f11a /dev-haskell
parentRemoved old header, fixed compilation. (diff)
downloadgentoo-2-9ae27ae0c3f3ac9f0d3fece578ae80c3569671a3.tar.gz
gentoo-2-9ae27ae0c3f3ac9f0d3fece578ae80c3569671a3.tar.bz2
gentoo-2-9ae27ae0c3f3ac9f0d3fece578ae80c3569671a3.zip
Get hsshellscript-2.7.0 working with ghc6.8.x
(Portage version: 2.1.4)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hsshellscript/ChangeLog8
-rw-r--r--dev-haskell/hsshellscript/hsshellscript-2.7.0.ebuild11
2 files changed, 15 insertions, 4 deletions
diff --git a/dev-haskell/hsshellscript/ChangeLog b/dev-haskell/hsshellscript/ChangeLog
index d279ed544d7a..cfe5f9111199 100644
--- a/dev-haskell/hsshellscript/ChangeLog
+++ b/dev-haskell/hsshellscript/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/hsshellscript
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/ChangeLog,v 1.19 2007/12/15 16:34:00 dcoutts Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/ChangeLog,v 1.20 2008/01/13 23:32:52 araujo Exp $
+
+ 13 Jan 2008; Luis F. Araujo <araujo@gentoo.org>
+ hsshellscript-2.7.0.ebuild:
+ get hsshellscript to work with ghc6.8.x
15 Dec 2007; Duncan Coutts <dcoutts@gentoo.org>
hsshellscript-2.7.0.ebuild:
diff --git a/dev-haskell/hsshellscript/hsshellscript-2.7.0.ebuild b/dev-haskell/hsshellscript/hsshellscript-2.7.0.ebuild
index 5b84c0a57c0c..35b6c2f7d051 100644
--- a/dev-haskell/hsshellscript/hsshellscript-2.7.0.ebuild
+++ b/dev-haskell/hsshellscript/hsshellscript-2.7.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/hsshellscript-2.7.0.ebuild,v 1.3 2007/12/15 16:34:00 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/hsshellscript-2.7.0.ebuild,v 1.4 2008/01/13 23:32:52 araujo Exp $
inherit base eutils multilib ghc-package
@@ -20,6 +20,13 @@ RDEPEND=""
pkg_setup() {
HSLIB="/usr/$(get_libdir)/${P}/ghc-$(ghc-version)/"
+ if has_version '>=dev-lang/ghc-6.8'; then
+ if (! has_version '>=dev-haskell/parsec-2.1.0.0' || ! built_with_use -o dev-haskell/parsec profile) ; then
+ echo
+ eerror "You need to install dev-haskell/parsec with the 'profile' USE flag."
+ die "hsshellscript needs the package dev-haskell/parsec."
+ fi
+ fi
}
src_unpack() {