summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2008-01-26 20:14:37 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2008-01-26 20:14:37 +0000
commitf7e62b7c4810c191c5c1958240b913f123996d1d (patch)
treeb1731276368c963718d913b1adf22dfb0f1adc00 /dev-haskell
parentTouchup install and make sure we error out if dash isnt found. (diff)
downloadgentoo-2-f7e62b7c4810c191c5c1958240b913f123996d1d.tar.gz
gentoo-2-f7e62b7c4810c191c5c1958240b913f123996d1d.tar.bz2
gentoo-2-f7e62b7c4810c191c5c1958240b913f123996d1d.zip
Remove old version fixing bug #207435. Also add dev-util/pkgconfig dep, fixing bug #206023.
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/gtk2hs/ChangeLog7
-rw-r--r--dev-haskell/gtk2hs/files/digest-gtk2hs-0.9.10-r13
-rw-r--r--dev-haskell/gtk2hs/gtk2hs-0.9.10-r1.ebuild112
-rw-r--r--dev-haskell/gtk2hs/gtk2hs-0.9.12.1.ebuild5
4 files changed, 9 insertions, 118 deletions
diff --git a/dev-haskell/gtk2hs/ChangeLog b/dev-haskell/gtk2hs/ChangeLog
index dc80ca545e83..a4e81bc17699 100644
--- a/dev-haskell/gtk2hs/ChangeLog
+++ b/dev-haskell/gtk2hs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/gtk2hs
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/ChangeLog,v 1.41 2008/01/20 18:56:57 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/ChangeLog,v 1.42 2008/01/26 20:14:36 dcoutts Exp $
+
+ 26 Jan 2008; Duncan Coutts <dcoutts@gentoo.org> -gtk2hs-0.9.10-r1.ebuild,
+ gtk2hs-0.9.12.1.ebuild:
+ Remove old version fixing bug #207435. Also add dev-util/pkgconfig dep,
+ fixing bug #206023.
20 Jan 2008; Christoph Mende <angelos@gentoo.org> gtk2hs-0.9.12.1.ebuild:
Stable on amd64 wrt bug #205272
diff --git a/dev-haskell/gtk2hs/files/digest-gtk2hs-0.9.10-r1 b/dev-haskell/gtk2hs/files/digest-gtk2hs-0.9.10-r1
deleted file mode 100644
index 7326ea1f2c69..000000000000
--- a/dev-haskell/gtk2hs/files/digest-gtk2hs-0.9.10-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 13d300e07153f37ba5893ac336b078bc gtk2hs-0.9.10.tar.gz 830866
-RMD160 2b0a5275b43c0b22588028ba7944622ff08fbbb6 gtk2hs-0.9.10.tar.gz 830866
-SHA256 da99b248f3674acba43bd636d1c67813851290ed11860f7f99a44a882cdea924 gtk2hs-0.9.10.tar.gz 830866
diff --git a/dev-haskell/gtk2hs/gtk2hs-0.9.10-r1.ebuild b/dev-haskell/gtk2hs/gtk2hs-0.9.10-r1.ebuild
deleted file mode 100644
index 794950d31017..000000000000
--- a/dev-haskell/gtk2hs/gtk2hs-0.9.10-r1.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/gtk2hs-0.9.10-r1.ebuild,v 1.6 2007/10/31 12:56:42 dcoutts Exp $
-
-inherit base eutils ghc-package multilib autotools
-
-DESCRIPTION="A GUI Library for Haskell based on Gtk+"
-HOMEPAGE="http://haskell.org/gtk2hs/"
-SRC_URI="mirror://sourceforge/gtk2hs/${P}.tar.gz"
-LICENSE="LGPL-2"
-SLOT="0"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-#enable sparc when CFLAGS/-mcpu ebuild bug is fixed
-
-IUSE="doc glade gnome firefox"
-
-RDEPEND="<dev-lang/ghc-6.6
- !>=dev-lang/ghc-6.6
- amd64? ( || ( >=dev-lang/ghc-6.4.1 >=dev-lang/ghc-bin-6.4.1 ) )
- >=x11-libs/gtk+-2
- glade? ( >=gnome-base/libglade-2 )
- gnome? ( >=gnome-base/libglade-2
- =x11-libs/gtksourceview-1*
- >=gnome-base/gconf-2 )
- firefox? ( >=www-client/mozilla-firefox-1.0.4 )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-haskell/haddock-0.7 )"
-
-src_unpack() {
- base_src_unpack
- cd "${S}"
- epatch "${FILESDIR}/${PN}-0.9.10-cflags.patch"
- epatch "${FILESDIR}/${PN}-0.9.10-ghc622.patch"
- epatch "${FILESDIR}/${PN}-0.9.10-store.patch"
-}
-
-src_compile() {
- # only needed because of the cflags patch above.
- eautoreconf
-
- econf \
- --enable-packager-mode \
- $(has_version '>=x11-libs/gtk+-2.8' && echo --enable-cairo) \
- $(use glade || use gnome && echo --enable-libglade) \
- $(use_enable gnome gconf) \
- $(use_enable gnome sourceview) \
- $(use_enable firefox firefox) \
- $(use_enable doc docs) \
- || die "Configure failed"
-
- # parallel build doesn't work, so specify -j1
- emake -j1 || die "Make failed"
-}
-
-src_install() {
-
- make install \
- DESTDIR="${D}" \
- htmldir="/usr/share/doc/${PF}/html" \
- haddockifacedir="/usr/share/doc/${PF}" \
- || die "Make install failed"
-
- # for some reason it creates the doc dir even if it is configured
- # to not generate docs, so lets remove the empty dirs in that case
- # (and lets be cautious and only remove them if they're empty)
- if ! use doc; then
- rmdir "${D}/usr/share/doc/${PF}/html"
- rmdir "${D}/usr/share/doc/${PF}"
- rmdir "${D}/usr/share/doc"
- rmdir "${D}/usr/share"
- fi
-
- # arrange for the packages to be registered
- if ghc-cabal; then
- pkgext=package.conf
- else
- pkgext=pkg
- fi
- ghc-setup-pkg \
- "${D}/usr/$(get_libdir)/gtk2hs/glib.${pkgext}" \
- $(has_version '>=x11-libs/gtk+-2.8' && echo \
- "${D}/usr/$(get_libdir)/gtk2hs/cairo.${pkgext}") \
- "${D}/usr/$(get_libdir)/gtk2hs/gtk.${pkgext}" \
- "${D}/usr/$(get_libdir)/gtk2hs/mogul.${pkgext}" \
- $(use glade || use gnome && echo \
- "${D}/usr/$(get_libdir)/gtk2hs/glade.${pkgext}") \
- $(use gnome && echo \
- "${D}/usr/$(get_libdir)/gtk2hs/gconf.${pkgext}" \
- "${D}/usr/$(get_libdir)/gtk2hs/sourceview.${pkgext}") \
- $(use firefox && echo \
- "${D}/usr/$(get_libdir)/gtk2hs/mozembed.${pkgext}")
- ghc-install-pkg
-
- # build ghci .o files from .a files
- ghc-makeghcilib "${D}/usr/$(get_libdir)/gtk2hs/libHSglib.a"
- if has_version '>=x11-libs/gtk+-2.8'; then
- ghc-makeghcilib "${D}/usr/$(get_libdir)/gtk2hs/libHScairo.a"
- fi
- ghc-makeghcilib "${D}/usr/$(get_libdir)/gtk2hs/libHSgtk.a"
- ghc-makeghcilib "${D}/usr/$(get_libdir)/gtk2hs/libHSmogul.a"
- if use glade || use gnome; then
- ghc-makeghcilib "${D}/usr/$(get_libdir)/gtk2hs/libHSglade.a"
- fi
- if use gnome; then
- ghc-makeghcilib "${D}/usr/$(get_libdir)/gtk2hs/libHSgconf.a"
- ghc-makeghcilib "${D}/usr/$(get_libdir)/gtk2hs/libHSsourceview.a"
- fi
- if use firefox; then
- ghc-makeghcilib "${D}/usr/$(get_libdir)/gtk2hs/libHSmozembed.a"
- fi
-}
diff --git a/dev-haskell/gtk2hs/gtk2hs-0.9.12.1.ebuild b/dev-haskell/gtk2hs/gtk2hs-0.9.12.1.ebuild
index 17fa4e3ad651..e67fe9ef8d4c 100644
--- a/dev-haskell/gtk2hs/gtk2hs-0.9.12.1.ebuild
+++ b/dev-haskell/gtk2hs/gtk2hs-0.9.12.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/gtk2hs-0.9.12.1.ebuild,v 1.4 2008/01/20 18:56:57 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/gtk2hs-0.9.12.1.ebuild,v 1.5 2008/01/26 20:14:36 dcoutts Exp $
inherit base eutils ghc-package multilib toolchain-funcs versionator
@@ -27,7 +27,8 @@ RDEPEND=">=dev-lang/ghc-6.4
firefox? ( >=www-client/mozilla-firefox-1.0.4 )
xulrunner? ( net-libs/xulrunner )"
DEPEND="${RDEPEND}
- doc? ( >=dev-haskell/haddock-0.8 )"
+ doc? ( >=dev-haskell/haddock-0.8 )
+ dev-util/pkgconfig"
src_compile() {
econf \