summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-09-27 11:48:47 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-09-27 11:48:47 +0000
commitace4d737fbe390b71dbd2d521fedb558515e0c8a (patch)
treef5e6292884c27c13220ea87a3e7f413b8e99140a /dev-java/ant-apache-bsf
parentAdd note to keep IUSE in sync with ant-apache-bsf. (diff)
downloadgentoo-2-ace4d737fbe390b71dbd2d521fedb558515e0c8a.tar.gz
gentoo-2-ace4d737fbe390b71dbd2d521fedb558515e0c8a.tar.bz2
gentoo-2-ace4d737fbe390b71dbd2d521fedb558515e0c8a.zip
Use EAPI 2 use dependencies instead of built_with_use warnings.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'dev-java/ant-apache-bsf')
-rw-r--r--dev-java/ant-apache-bsf/ChangeLog6
-rw-r--r--dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1.ebuild18
2 files changed, 10 insertions, 14 deletions
diff --git a/dev-java/ant-apache-bsf/ChangeLog b/dev-java/ant-apache-bsf/ChangeLog
index c936a86e094c..fe8a2cf3eaf5 100644
--- a/dev-java/ant-apache-bsf/ChangeLog
+++ b/dev-java/ant-apache-bsf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/ant-apache-bsf
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-apache-bsf/ChangeLog,v 1.14 2008/07/14 22:06:45 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-apache-bsf/ChangeLog,v 1.15 2008/09/27 11:48:47 betelgeuse Exp $
+
+ 27 Sep 2008; Petteri Räty <betelgeuse@gentoo.org>
+ ant-apache-bsf-1.7.1.ebuild:
+ Use EAPI 2 use dependencies instead of built_with_use warnings.
*ant-apache-bsf-1.7.1 (14 Jul 2008)
diff --git a/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1.ebuild b/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1.ebuild
index 9cb35b0acd97..c6cbdd4b10f7 100644
--- a/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1.ebuild
+++ b/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1.ebuild,v 1.1 2008/07/14 22:06:45 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1.ebuild,v 1.2 2008/09/27 11:48:47 betelgeuse Exp $
-EAPI=1
+EAPI=2
ANT_TASK_DEPNAME="bsf-2.3"
@@ -12,10 +12,12 @@ KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
# ant-nodeps contains <script> task which is needed for this
# although it's not a build dep through import
-DEPEND=">=dev-java/bsf-2.4.0-r1:2.3"
+DEPEND=">=dev-java/bsf-2.4.0-r1:2.3[python?,javascript?,tcl?]"
RDEPEND="${DEPEND}
~dev-java/ant-nodeps-${PV}"
+IUSE="python javascript tcl"
+
JAVA_PKG_FILTER_COMPILER="jikes"
src_install() {
@@ -23,17 +25,7 @@ src_install() {
java-pkg_register-dependency ant-nodeps
}
-built_with_use_warn() {
- if ! built_with_use --missing false -o dev-java/bsf ${1}; then
- elog "If you want to use ${2} in <script> tasks in build.xml files,"
- elog "dev-java/bsf must be installed with \"${3-${1}}\" USE flag"
- fi
-}
-
pkg_postinst() {
- built_with_use_warn python Python
- built_with_use_warn javascript JavaScript
- built_with_use_warn tcl TCL
elog "Also, >=dev-java/bsf-2.4.0-r1 adds optional support for groovy,"
elog "ruby and beanshell. See its postinst elog messages for instructions."
}