summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-04-03 20:29:22 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-04-03 20:29:22 +0000
commit1424c076e43a17ef03bc358533267c31d22bcfa8 (patch)
tree58b662475a8e2b581048e5ca938d65967a4f2617 /dev-java/ant-core
parentBug \#83630 (diff)
downloadgentoo-2-1424c076e43a17ef03bc358533267c31d22bcfa8.tar.gz
gentoo-2-1424c076e43a17ef03bc358533267c31d22bcfa8.tar.bz2
gentoo-2-1424c076e43a17ef03bc358533267c31d22bcfa8.zip
die when wrapper cant be found
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-java/ant-core')
-rw-r--r--dev-java/ant-core/ChangeLog6
-rw-r--r--dev-java/ant-core/ant-core-1.6.2-r2.ebuild7
-rw-r--r--dev-java/ant-core/ant-core-1.6.3_beta1.ebuild7
-rw-r--r--dev-java/ant-core/files/1.6.3-ant166
4 files changed, 175 insertions, 11 deletions
diff --git a/dev-java/ant-core/ChangeLog b/dev-java/ant-core/ChangeLog
index d42e149ec66b..fbc5fc923ce3 100644
--- a/dev-java/ant-core/ChangeLog
+++ b/dev-java/ant-core/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/ant-core
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ChangeLog,v 1.19 2005/04/03 17:27:50 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ChangeLog,v 1.20 2005/04/03 20:29:22 axxo Exp $
+
+ 03 Apr 2005; Thomas Matthijs <axxo@gentoo.org> +files/1.6.3-ant,
+ ant-core-1.6.2-r2.ebuild, ant-core-1.6.3_beta1.ebuild:
+ die when wrapper cant be found
*ant-core-1.6.3_beta1 (03 Apr 2005)
diff --git a/dev-java/ant-core/ant-core-1.6.2-r2.ebuild b/dev-java/ant-core/ant-core-1.6.2-r2.ebuild
index 1467c36a228f..0db13b1b492f 100644
--- a/dev-java/ant-core/ant-core-1.6.2-r2.ebuild
+++ b/dev-java/ant-core/ant-core-1.6.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ant-core-1.6.2-r2.ebuild,v 1.1 2005/04/02 23:32:24 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ant-core-1.6.2-r2.ebuild,v 1.2 2005/04/03 20:29:22 axxo Exp $
inherit java-pkg eutils
@@ -55,10 +55,7 @@ src_compile() {
}
src_install() {
- cp ${FILESDIR}/${PV}-ant ${S}/src/ant
-
- exeinto /usr/bin
- doexe src/ant
+ newbin ${FILESDIR}/${PV}-ant ant || die "failed to install wrapper"
dodir /usr/share/${PN}/bin
for each in antRun runant.pl runant.py complete-ant-cmd.pl ; do
diff --git a/dev-java/ant-core/ant-core-1.6.3_beta1.ebuild b/dev-java/ant-core/ant-core-1.6.3_beta1.ebuild
index 5fccf9c6f8b9..7d2be3a6b37b 100644
--- a/dev-java/ant-core/ant-core-1.6.3_beta1.ebuild
+++ b/dev-java/ant-core/ant-core-1.6.3_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ant-core-1.6.3_beta1.ebuild,v 1.1 2005/04/03 17:27:50 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ant-core-1.6.3_beta1.ebuild,v 1.2 2005/04/03 20:29:22 axxo Exp $
inherit java-pkg eutils
@@ -54,10 +54,7 @@ src_compile() {
}
src_install() {
- cp ${FILESDIR}/${PV}-ant ${S}/src/ant
-
- exeinto /usr/bin
- doexe src/ant
+ newbin ${FILESDIR}/${PV/_*}-ant ant || die "failed to install wrapper"
dodir /usr/share/${PN}/bin
for each in antRun runant.pl runant.py complete-ant-cmd.pl ; do
diff --git a/dev-java/ant-core/files/1.6.3-ant b/dev-java/ant-core/files/1.6.3-ant
new file mode 100644
index 000000000000..827dce3af8a2
--- /dev/null
+++ b/dev-java/ant-core/files/1.6.3-ant
@@ -0,0 +1,166 @@
+#! /bin/bash
+
+# Copyright 2001-2004 The Apache Software Foundation
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# Edited for Gentoo Linux
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/files/1.6.3-ant,v 1.1 2005/04/03 20:29:22 axxo Exp $
+
+# Extract launch and ant arguments, (see details below).
+ant_exec_args=
+no_config=false
+use_jikes_default=false
+ant_exec_debug=false
+show_help=false
+for arg in "$@" ; do
+ if [ "$arg" = "--noconfig" ] ; then
+ no_config=true
+ elif [ "$arg" = "--usejikes" ] ; then
+ use_jikes_default=true
+ elif [ "$arg" = "--execdebug" ] ; then
+ ant_exec_debug=true
+ elif [ my"$arg" = my"--h" -o my"$arg" = my"--help" ] ; then
+ show_help=true
+ ant_exec_args="$ant_exec_args -h"
+ else
+ if [ my"$arg" = my"-h" -o my"$arg" = my"-help" ] ; then
+ show_help=true
+ fi
+ ant_exec_args="$ant_exec_args \"$arg\""
+ fi
+done
+
+# Source/default ant configuration
+if $no_config ; then
+ rpm_mode=false
+ usejikes=$use_jikes_default
+else
+ # load system-wide ant configuration
+ if [ -f "/etc/ant.conf" ] ; then
+ . /etc/ant.conf
+ fi
+
+ # load user ant configuration
+ if [ -f "$HOME/.ant/ant.conf" ] ; then
+ . $HOME/.ant/ant.conf
+ fi
+ if [ -f "$HOME/.antrc" ] ; then
+ . "$HOME/.antrc"
+ fi
+
+ # provide default configuration values
+ if [ -z "$rpm_mode" ] ; then
+ rpm_mode=false
+ fi
+ if [ -z "$usejikes" ] ; then
+ usejikes=$use_jikes_default
+ fi
+fi
+
+
+if [ -z $JAVA_HOME ] ; then
+ if [ -f $HOME/.gentoo/java-env ] ; then
+ source $HOME/.gentoo/java-env
+ else
+ JAVA_HOME=`java-config --jdk-home`
+ CLASSPATH=`java-config --classpath`:${CLASSPATH}
+ fi
+fi
+
+if [ -z $JAVA_HOME ] ; then
+ echo "Error: No JDK found!"
+ echo "Try using java-config script to set your JDK"
+ echo "Remember that you need a JDK not a JRE"
+ exit 1
+fi
+
+ANT_HOME=/usr/share/ant-core
+
+# set ANT_LIB location
+ANT_LIB="${ANT_HOME}/lib"
+
+JAVACMD="`java-config --java`"
+
+if [ ! -x "$JAVACMD" ] ; then
+ echo "Error: JAVA_HOME is not defined correctly."
+ echo " We cannot execute $JAVACMD"
+ exit 1
+fi
+
+if [ -z "$LOCALCLASSPATH" ] ; then
+ LOCALCLASSPATH=$ANT_LIB/ant-launcher.jar
+else
+ LOCALCLASSPATH=$ANT_LIB/ant-launcher.jar:$LOCALCLASSPATH
+fi
+
+if [ -n "$JAVA_HOME" ] ; then
+ if [ -f "$JAVA_HOME/lib/tools.jar" ] ; then
+ LOCALCLASSPATH="$LOCALCLASSPATH:$JAVA_HOME/lib/tools.jar"
+ fi
+
+ if [ -f "$JAVA_HOME/lib/classes.zip" ] ; then
+ LOCALCLASSPATH="$LOCALCLASSPATH:$JAVA_HOME/lib/classes.zip"
+ fi
+
+else
+ echo "Warning: JAVA_HOME environment variable is not set (or not exported)."
+ echo " If build fails because sun.* classes could not be found"
+ echo " you will need to set the JAVA_HOME environment variable"
+ echo " to the installation directory of java."
+ echo " Try using java-config script"
+fi
+
+# Allow Jikes support (off by default)
+if $usejikes; then
+ ANT_OPTS="$ANT_OPTS -Dbuild.compiler=jikes"
+fi
+
+# Show script help if requested
+if $show_help ; then
+ echo $0 '[script options] [options] [target [target2 [target3] ..]]'
+ echo 'Script Options:'
+ echo ' --help, --h print this message and ant help'
+ echo ' --noconfig suppress sourcing of /etc/ant.conf,'
+ echo ' $HOME/.ant/ant.conf, and $HOME/.antrc'
+ echo ' configuration files'
+ echo ' --usejikes enable use of jikes by default, unless'
+ echo ' set explicitly in configuration files'
+ echo ' --execdebug print ant exec line generated by this'
+ echo ' launch script'
+ echo ' '
+fi
+
+# Execute ant using eval/exec to preserve spaces in paths,
+# java options, and ant args
+ant_sys_opts=
+
+
+if [ -n "$JIKESPATH" ]; then
+ ant_sys_opts="-Djikes.class.path=\"$JIKESPATH\""
+fi
+
+# 2002-11-02, karltk@gentoo.org:
+# The Blackdown JDK on PPC hiccups with native threads
+#
+if [ "`arch`" == "ppc" ] ; then
+ export THREADS_FLAG="green"
+fi
+
+
+ant_exec_command="exec \"$JAVACMD\" $ANT_OPTS -classpath \"$LOCALCLASSPATH\" -Dant.home=\"$ANT_HOME\" -Dant.library.dir=\"$ANT_LIB\" $ant_sys_opts org.apache.tools.ant.launch.Launcher $ANT_ARGS -lib \"$CLASSPATH\" $ant_exec_args"
+
+if $ant_exec_debug ; then
+ echo $ant_exec_command
+fi
+eval $ant_exec_command