summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-05-15 21:05:23 +0000
committerVlastimil Babka <caster@gentoo.org>2010-05-15 21:05:23 +0000
commitc39651d1a8c1e1cbe67539052951bce9b4efd7ad (patch)
tree2c43aff0f7d867f8b576191c7e6662b5f30ee59f /dev-java/ant-testutil/ant-testutil-1.8.1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-c39651d1a8c1e1cbe67539052951bce9b4efd7ad.tar.gz
gentoo-2-c39651d1a8c1e1cbe67539052951bce9b4efd7ad.tar.bz2
gentoo-2-c39651d1a8c1e1cbe67539052951bce9b4efd7ad.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/ant-testutil/ant-testutil-1.8.1.ebuild')
-rw-r--r--dev-java/ant-testutil/ant-testutil-1.8.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-java/ant-testutil/ant-testutil-1.8.1.ebuild b/dev-java/ant-testutil/ant-testutil-1.8.1.ebuild
new file mode 100644
index 000000000000..aa14e56bdcff
--- /dev/null
+++ b/dev-java/ant-testutil/ant-testutil-1.8.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-testutil/ant-testutil-1.8.1.ebuild,v 1.1 2010/05/15 21:05:23 caster Exp $
+
+EAPI="1"
+
+inherit ant-tasks
+
+DESCRIPTION="Apache Ant's optional test utility classes"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="dev-java/junit:0
+ ~dev-java/ant-nodeps-${PV}
+ ~dev-java/ant-swing-${PV}
+ ~dev-java/ant-trax-${PV}
+ ~dev-java/ant-junit-${PV}"
+RDEPEND=""
+
+IUSE=""
+
+# the build system builds much more than it actually packages, so there are many
+# build-only deps, but since those are quite common, it wasn't worth to patch it
+
+src_unpack() {
+ ant-tasks_src_unpack base
+ java-pkg_jar-from --build-only junit,ant-nodeps,ant-junit,ant-swing,ant-trax
+ java-pkg_jar-from --build-only ant-core ant-launcher.jar
+}
+
+src_compile() {
+ eant test-jar
+}