summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-07-14 20:45:23 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-07-14 20:45:23 +0000
commit6d788679fddad381b4465760fd2d9187bdb353b0 (patch)
tree1f057112e615afff7316e1c4199def2ef0ccd936 /dev-java/aspectj/aspectj-1.2.ebuild
parentdon't dep on arch for gnuconfig_update (diff)
downloadgentoo-2-6d788679fddad381b4465760fd2d9187bdb353b0.tar.gz
gentoo-2-6d788679fddad381b4465760fd2d9187bdb353b0.tar.bz2
gentoo-2-6d788679fddad381b4465760fd2d9187bdb353b0.zip
new version
Diffstat (limited to 'dev-java/aspectj/aspectj-1.2.ebuild')
-rw-r--r--dev-java/aspectj/aspectj-1.2.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/dev-java/aspectj/aspectj-1.2.ebuild b/dev-java/aspectj/aspectj-1.2.ebuild
new file mode 100644
index 000000000000..dcf7aff1aa0c
--- /dev/null
+++ b/dev-java/aspectj/aspectj-1.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/aspectj/aspectj-1.2.ebuild,v 1.1 2004/07/14 20:45:23 axxo Exp $
+
+inherit java-pkg eutils
+
+DESCRIPTION="AspectJ is a seemless extension to the Java programming language for Aspect Oriented Programming (AOP)"
+SRC_URI="mirror://gentoo/aspectj-CVS-V1_2_0.tar.bz2"
+HOMEPAGE="http://www.eclipse.org/aspectj/"
+DEPEND=">=virtual/jdk-1.3
+ dev-java/ant"
+SLOT="0"
+LICENSE="CPL-1.0 Apache-1.1"
+KEYWORDS="~x86"
+IUSE="doc"
+
+# Welcome to the AspectJ ebuild. An upstream source archive is not
+# available directly. The AspectJ source .tar.bz2 snapshot is taken
+# from CVS with the following command:
+#
+# cvs -z3 -d:pserver:anonymous@dev.eclipse.org:/home/technology \
+# co -rV1_2_0 org.aspectj/modules
+#
+# The source is then patched so that the installed binaries have
+# version information which reflects the tagged source release. The
+# AspectJ build system does not do this automatically.
+#
+# Useful documentation for this port:
+#
+# http://dev.eclipse.org/viewcvs/index.cgi/~checkout~/org.aspectj/modules/build/readme-build-and-test-aspectj.html?rev=HEAD&content-type=text/html&cvsroot=Technology_Project
+#
+# http://dev.eclipse.org/viewcvs/index.cgi/~checkout~/org.aspectj/modules/build/release-checklist.txt?rev=HEAD&content-type=text/plain&cvsroot=Technology_Project
+#
+
+S=${WORKDIR}/org.aspectj/modules
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/aspectj-${PV}-version-gentoo.patch
+ epatch ${FILESDIR}/aspectj-${PV}-fix-javadoc.patch
+ epatch ${FILESDIR}/aspectj-${PV}-fix-examples-build.xml.patch
+ sed -i "s,DEVELOPMENT,${PV},g" build/build-properties.xml
+ sed -i -e "s,@PV@,${PV},g" -e "s,@PV_LONG@,${PV} (Gentoo Build),g" \
+ org.aspectj.ajdt.core/src/org/aspectj/ajdt/ajc/messages.properties
+}
+
+src_compile() {
+ cd build
+ ant -f build.xml || die "build failed"
+}
+
+src_install () {
+ mkdir aspectj-unpack
+ java -jar aj-build/dist/aspectj-${PV}.jar -to aspectj-unpack
+ cd aspectj-unpack
+ java-pkg_dojar lib/*.jar
+ dobin ${FILESDIR}/{ajc,ajbrowser}
+
+ dohtml doc/*.html
+ cp *.html ${D}/usr/share/doc/${PF}/
+ if use doc; then
+ cp -R doc/{devguide,api,progguide} ${D}/usr/share/doc/${PF}/html
+ cp -R doc/examples ${D}/usr/share/doc/${PF}
+ cp doc/*.pdf ${D}/usr/share/doc/${PF}
+ fi
+}