summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-03-19 23:29:24 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-03-19 23:29:24 +0000
commit3635f9612114cb917737a6510e8fdcd4f2369291 (patch)
tree95a640414625958d967ff95772b2c80e178317ca /dev-java/batik
parentgiflib fixes; bug 85720 (diff)
downloadgentoo-2-3635f9612114cb917737a6510e8fdcd4f2369291.tar.gz
gentoo-2-3635f9612114cb917737a6510e8fdcd4f2369291.tar.bz2
gentoo-2-3635f9612114cb917737a6510e8fdcd4f2369291.zip
version 1.5 is needed to remove the packed jar issue from dev-java/fop, see #63262. now all jars are accessible by jar-from, java-config -p etc
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-java/batik')
-rw-r--r--dev-java/batik/ChangeLog9
-rw-r--r--dev-java/batik/Manifest8
-rw-r--r--dev-java/batik/batik-1.5.1-r4.ebuild63
-rw-r--r--dev-java/batik/batik-1.5.ebuild63
-rw-r--r--dev-java/batik/files/digest-batik-1.51
-rw-r--r--dev-java/batik/files/digest-batik-1.5.1-r41
6 files changed, 142 insertions, 3 deletions
diff --git a/dev-java/batik/ChangeLog b/dev-java/batik/ChangeLog
index 3a7b238c23ef..5e5dfeeb17b7 100644
--- a/dev-java/batik/ChangeLog
+++ b/dev-java/batik/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/batik
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/batik/ChangeLog,v 1.19 2005/02/18 18:40:39 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/batik/ChangeLog,v 1.20 2005/03/19 23:29:24 luckyduck Exp $
+
+*batik-1.5.1-r4 (20 Mar 2005)
+
+ 20 Mar 2005; Jan Brinkmann <luckyduck@gentoo.org> +batik-1.5.1-r4.ebuild,
+ +batik-1.5.ebuild:
+ version 1.5 is needed to remove the packed jar issue from dev-java/fop, see
+ #63262. now all jars are accessible by jar-from, java-config -p etc
18 Feb 2005; Saleem Abdulrasool <compnerd@gentoo.org>
batik-1.5.1-r3.ebuild:
diff --git a/dev-java/batik/Manifest b/dev-java/batik/Manifest
index f130d698c72a..c9fbf55b0172 100644
--- a/dev-java/batik/Manifest
+++ b/dev-java/batik/Manifest
@@ -1,6 +1,10 @@
MD5 ef995a113c15163bc4db93eaedc0c1d4 batik-1.5.1-r3.ebuild 1718
-MD5 914f1ad23f39cbaa68716d2557b2c956 batik-1.5.1.ebuild 1050
-MD5 aa3b019ddd838c5f96eff9be5e78c104 ChangeLog 2184
+MD5 5b9c7f4c0f2533e017343786b89c658b batik-1.5.1.ebuild 1054
+MD5 46d0179cf21f014326b23ceab46bc5cc ChangeLog 2452
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+MD5 42c074daba9ac803b45583558598ee6a batik-1.5.1-r4.ebuild 1677
+MD5 5fe3521c51653e250a83fd8f89e9dfe0 batik-1.5.ebuild 1679
+MD5 479ed0922a69b318b40b485614a6af16 files/digest-batik-1.5 63
MD5 2773f6aa10bcb901bd07ea509571ccef files/digest-batik-1.5.1 66
MD5 2773f6aa10bcb901bd07ea509571ccef files/digest-batik-1.5.1-r3 66
+MD5 2773f6aa10bcb901bd07ea509571ccef files/digest-batik-1.5.1-r4 66
diff --git a/dev-java/batik/batik-1.5.1-r4.ebuild b/dev-java/batik/batik-1.5.1-r4.ebuild
new file mode 100644
index 000000000000..f2c8de6db108
--- /dev/null
+++ b/dev-java/batik/batik-1.5.1-r4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/batik/batik-1.5.1-r4.ebuild,v 1.1 2005/03/19 23:29:24 luckyduck Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Batik is a Java(tm) technology based toolkit for applications or applets that want to use images in the Scalable Vector Graphics (SVG) format for various purposes, such as viewing, generation or manipulation."
+SRC_URI="mirror://apache/xml/batik/${PN}-src-${PV}.zip"
+HOMEPAGE="http://xml.apache.org/batik/"
+IUSE="doc"
+DEPEND=">=virtual/jdk-1.3
+ =dev-java/rhino-1.5*
+ app-arch/unzip
+ >=dev-java/xerces-2.6.2-r1
+ dev-java/ant"
+RDEPEND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+
+S=${WORKDIR}/xml-batik
+
+src_unpack() {
+ jar xf ${DISTDIR}/${PN}-src-${PV}.zip
+ cd ${S}/lib
+ rm -f *.jar
+ java-pkg_jar-from xerces-2
+ java-pkg_jar-from rhino-1.5
+}
+
+src_compile() {
+ export ANT_OPTS=-Xmx256m
+ local antflags="jars all-jar"
+ ant ${antflags} || die "compile problem"
+}
+
+src_install () {
+ java-pkg_dojar ${P}/batik*.jar
+
+ cd ${P}/lib
+ rm {js,x*}.jar
+
+ # needed because batik expects this layout:
+ # batik.jar lib/*.jar
+ # there are hardcoded classpathes in the manifest :(
+ for jar in *.jar
+ do
+ java-pkg_dojar ${jar}
+ rm -f ${jar}
+ ln -s ${DESTTREE}/share/${PN}/lib/${jar} ${jar}
+ done
+
+ cd ${S}
+ cp -ra ${P}/lib ${D}${DESTTREE}/share/${PN}/lib/
+
+ dodoc README LICENSE
+ use doc && java-pkg_dohtml -r ${P}/docs/
+
+ echo "#!/bin/sh" > ${PN}
+ echo '${JAVA_HOME}/bin/java -classpath $(java-config -p batik,xerces-2,rhino-1.5) org.apache.batik.apps.svgbrowser.Main $*' >> ${PN}
+ dobin ${PN}
+
+}
diff --git a/dev-java/batik/batik-1.5.ebuild b/dev-java/batik/batik-1.5.ebuild
new file mode 100644
index 000000000000..5ef239c3f2af
--- /dev/null
+++ b/dev-java/batik/batik-1.5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/batik/batik-1.5.ebuild,v 1.8 2005/03/19 23:29:24 luckyduck Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Batik is a Java(tm) technology based toolkit for applications or applets that want to use images in the Scalable Vector Graphics (SVG) format for various purposes, such as viewing, generation or manipulation."
+SRC_URI="mirror://apache/xml/batik/${PN}-src-${PV}.zip"
+HOMEPAGE="http://xml.apache.org/batik/"
+IUSE="doc"
+DEPEND=">=virtual/jdk-1.3
+ =dev-java/rhino-1.5*
+ app-arch/unzip
+ >=dev-java/xerces-2.6.2-r1
+ dev-java/ant"
+RDEPEND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="1.5"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+
+S=${WORKDIR}/xml-batik
+
+src_unpack() {
+ jar xf ${DISTDIR}/${PN}-src-${PV}.zip
+ cd ${S}/lib
+ rm -f *.jar
+ java-pkg_jar-from xerces-2
+ java-pkg_jar-from rhino-1.5
+}
+
+src_compile() {
+ export ANT_OPTS=-Xmx256m
+ local antflags="jars all-jar"
+ ant ${antflags} || die "compile problem"
+}
+
+src_install () {
+ java-pkg_dojar ${P}/batik*.jar
+
+ cd ${P}/lib
+ rm {js,x*}.jar
+
+ # needed because batik expects this layout:
+ # batik.jar lib/*.jar
+ # there are hardcoded classpathes in the manifest :(
+ for jar in *.jar
+ do
+ java-pkg_dojar ${jar}
+ rm -f ${jar}
+ ln -s ${DESTTREE}/share/${PN}/lib/${jar} ${jar}
+ done
+
+ cd ${S}
+ cp -ra ${P}/lib ${D}${DESTTREE}/share/${PN}/lib/
+
+ dodoc README LICENSE
+ use doc && java-pkg_dohtml -r ${P}/docs/
+
+ echo "#!/bin/sh" > ${PN}
+ echo '${JAVA_HOME}/bin/java -classpath $(java-config -p batik,xerces-2,rhino-1.5) org.apache.batik.apps.svgbrowser.Main $*' >> ${PN}
+ dobin ${PN}
+
+}
diff --git a/dev-java/batik/files/digest-batik-1.5 b/dev-java/batik/files/digest-batik-1.5
new file mode 100644
index 000000000000..75f845fbef96
--- /dev/null
+++ b/dev-java/batik/files/digest-batik-1.5
@@ -0,0 +1 @@
+MD5 94d3e981014a5ed6f8c0e3fd80be3033 batik-src-1.5.zip 9234151
diff --git a/dev-java/batik/files/digest-batik-1.5.1-r4 b/dev-java/batik/files/digest-batik-1.5.1-r4
new file mode 100644
index 000000000000..cab50b8d6f96
--- /dev/null
+++ b/dev-java/batik/files/digest-batik-1.5.1-r4
@@ -0,0 +1 @@
+MD5 8a3ba8b76dcef9415216d6a5b9685a9c batik-src-1.5.1.zip 11474737