summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-06-01 14:51:29 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-06-01 14:51:29 +0000
commit3f1ed77dfe41653c5b5658e319753e28770906b9 (patch)
tree58c22898d85aae1bd32bec844af33c8c704fab75 /dev-java/bcprov
parentEAPI bump wrt bug 460572 (diff)
downloadgentoo-2-3f1ed77dfe41653c5b5658e319753e28770906b9.tar.gz
gentoo-2-3f1ed77dfe41653c5b5658e319753e28770906b9.tar.bz2
gentoo-2-3f1ed77dfe41653c5b5658e319753e28770906b9.zip
Revision bump to add test classes to jar such that other bc* packages can use it.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/bcprov')
-rw-r--r--dev-java/bcprov/ChangeLog8
-rw-r--r--dev-java/bcprov/bcprov-1.49-r1.ebuild71
2 files changed, 78 insertions, 1 deletions
diff --git a/dev-java/bcprov/ChangeLog b/dev-java/bcprov/ChangeLog
index 87c210af59ac..71cc520d6e8c 100644
--- a/dev-java/bcprov/ChangeLog
+++ b/dev-java/bcprov/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/bcprov
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/bcprov/ChangeLog,v 1.45 2013/06/01 14:09:07 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bcprov/ChangeLog,v 1.46 2013/06/01 14:51:29 tomwij Exp $
+
+*bcprov-1.49-r1 (01 Jun 2013)
+
+ 01 Jun 2013; Tom Wijsman <TomWij@gentoo.org> +bcprov-1.49-r1.ebuild:
+ Revision bump to add test classes to jar such that other bc* packages can use
+ it.
*bcprov-1.49 (01 Jun 2013)
diff --git a/dev-java/bcprov/bcprov-1.49-r1.ebuild b/dev-java/bcprov/bcprov-1.49-r1.ebuild
new file mode 100644
index 000000000000..3dafafd1ecdb
--- /dev/null
+++ b/dev-java/bcprov/bcprov-1.49-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bcprov/bcprov-1.49-r1.ebuild,v 1.1 2013/06/01 14:51:29 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}-jdk15on-${PV/./}"
+DESCRIPTION="Java cryptography APIs"
+HOMEPAGE="http://www.bouncycastle.org/java.html"
+SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos"
+
+# Tests are currently broken. Needs further investigation.
+# java.security.NoSuchAlgorithmException: Cannot find any provider supporting McElieceFujisakiWithSHA256
+RESTRICT="test"
+
+# The src_unpack find needs a new find
+# https://bugs.gentoo.org/show_bug.cgi?id=182276
+DEPEND=">=virtual/jdk-1.5
+ userland_GNU? ( >=sys-apps/findutils-4.3 )
+ app-arch/unzip
+ test? ( dev-java/junit:4 )"
+RDEPEND=">=virtual/jre-1.5"
+
+IUSE="userland_GNU"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ default
+
+ cd "${S}" || die
+ unpack ./src.zip
+}
+
+java_prepare() {
+ mkdir "${S}"/classes || die
+
+ java-pkg_jar-from --build-only junit-4
+}
+
+src_compile() {
+ find . -name "*.java" > "${T}"/src.list
+ ejavac -cp junit.jar -encoding ISO-8859-1 -d "${S}"/classes "@${T}"/src.list
+
+ cd "${S}"/classes || die
+
+ jar -cf "${S}"/${PN}.jar * || die "Failed to create jar."
+}
+
+src_test() {
+ java -cp ${PN}.jar:junit.jar org.bouncycastle.pqc.jcajce.provider.test.AllTests | tee pqc.tests
+ java -cp ${PN}.jar:junit.jar org.bouncycastle.ocsp.test.AllTests | tee oscp.tests
+ java -cp ${PN}.jar:junit.jar org.bouncycastle.jce.provider.test.AllTests | tee jce.tests
+
+ grep -q FAILURES *.tests && die "Tests failed."
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ use source && java-pkg_dosrc org
+ use doc && java-pkg_dojavadoc docs
+}