summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-03-16 06:59:59 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-03-16 06:59:59 +0000
commit7d1e4f64c14baa5ba1bc18124dd52417f48316e4 (patch)
tree6e2f6580836fe45442b956fd3a3e3c93e357307f /dev-java/commons-cli
parentVersion bump. Manpage fixed; tile.gif was replaced with tile.png; igal.css ad... (diff)
downloadgentoo-2-7d1e4f64c14baa5ba1bc18124dd52417f48316e4.tar.gz
gentoo-2-7d1e4f64c14baa5ba1bc18124dd52417f48316e4.tar.bz2
gentoo-2-7d1e4f64c14baa5ba1bc18124dd52417f48316e4.zip
Initial import. Jakarta Commons CLI provides a simple and easy-to-use API for working with commandline arguments and options in Java.
Diffstat (limited to 'dev-java/commons-cli')
-rw-r--r--dev-java/commons-cli/commons-cli-1.0.ebuild36
-rw-r--r--dev-java/commons-cli/files/digest-commons-cli-1.01
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-java/commons-cli/commons-cli-1.0.ebuild b/dev-java/commons-cli/commons-cli-1.0.ebuild
new file mode 100644
index 000000000000..8d0a225e4f4c
--- /dev/null
+++ b/dev-java/commons-cli/commons-cli-1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-cli/commons-cli-1.0.ebuild,v 1.1 2003/03/16 06:59:59 absinthe Exp $
+
+S=${WORKDIR}/${PN}-${PV}
+DESCRIPTION="Jakarta-Commons library for working with command line arguments and options"
+HOMEPAGE="http://jakarta.apache.org/commons/cli/index.html"
+SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v${PV}/${PN}-${PV}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=ant-1.4
+ >=dev-java/junit-3.7"
+RDEPEND=">=virtual/jre-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="jikes junit"
+
+src_compile() {
+ local myc
+
+ if [ -n "`use jikes`" ] ; then
+ myc="${myc} -Dbuild.compiler=jikes"
+ fi
+
+ ANT_OPTS=${myc} ant jar || die "JAR compile failed"
+
+ if [ -n "`use doc`" ]
+ then
+ ANT_OPTS=${myc} ant javadoc || die "Document compile failed"
+ fi
+}
+
+src_install () {
+ dojar target/*.jar || die "Unable to Install"
+ use doc && dohtml -r dist/docs/*
+}
diff --git a/dev-java/commons-cli/files/digest-commons-cli-1.0 b/dev-java/commons-cli/files/digest-commons-cli-1.0
new file mode 100644
index 000000000000..d067a440774d
--- /dev/null
+++ b/dev-java/commons-cli/files/digest-commons-cli-1.0
@@ -0,0 +1 @@
+MD5 ba34d585046b1f17dacbb13b377f4255 commons-cli-1.0-src.tar.gz 37046