summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-11-13 22:29:56 +0000
committerVlastimil Babka <caster@gentoo.org>2010-11-13 22:29:56 +0000
commit49ea0ff02aafd932c5bf576477298035cb0062d1 (patch)
tree1a9fa96ceae1fcabfac62fd8b865210dba4a47ec /dev-java/commons-daemon/commons-daemon-1.0.4.ebuild
parentVersion bump, thanks to wltjr. (diff)
downloadgentoo-2-49ea0ff02aafd932c5bf576477298035cb0062d1.tar.gz
gentoo-2-49ea0ff02aafd932c5bf576477298035cb0062d1.tar.bz2
gentoo-2-49ea0ff02aafd932c5bf576477298035cb0062d1.zip
Version bump.
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/commons-daemon/commons-daemon-1.0.4.ebuild')
-rw-r--r--dev-java/commons-daemon/commons-daemon-1.0.4.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-java/commons-daemon/commons-daemon-1.0.4.ebuild b/dev-java/commons-daemon/commons-daemon-1.0.4.ebuild
new file mode 100644
index 000000000000..f329d31d1bf9
--- /dev/null
+++ b/dev-java/commons-daemon/commons-daemon-1.0.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-daemon/commons-daemon-1.0.4.ebuild,v 1.1 2010/11/13 22:29:56 caster Exp $
+
+EAPI="2"
+WANT_AUTOCONF=2.5
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-ant-2 eutils autotools
+
+DESCRIPTION="Tools to allow java programs to run as unix daemons"
+SRC_URI="mirror://apache/commons/daemon/source/${P}-src.tar.gz"
+HOMEPAGE="http://commons.apache.org/daemon/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}/${P}-src
+
+java_prepare() {
+ # https://issues.apache.org/jira/browse/DAEMON-154
+ find . -name "*.o" -delete -print || die
+
+ rm src/samples/build/classes/*.class || die
+
+ cd "${S}/src/native/unix"
+ sed -e "s/powerpc/powerpc|powerpc64/g" -i support/apsupport.m4
+ eautoconf
+}
+
+src_configure() {
+ java-ant-2_src_configure
+ cd "${S}/src/native/unix"
+ econf || die "configure failed"
+}
+
+src_compile() {
+ # compile native stuff
+ cd "${S}/src/native/unix"
+ emake || die "make failed"
+
+ # compile java stuff
+ cd "${S}"
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ dobin src/native/unix/jsvc || die
+ java-pkg_newjar dist/*.jar
+
+ dodoc README RELEASE-NOTES.txt *.html || die
+ use doc && java-pkg_dohtml -r dist/docs/*
+ use examples && java-pkg_doexamples src/samples
+ use source && java-pkg_dosrc src/java/* src/native/unix/native
+}