summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Noël Rivasseau <elvanor@gentoo.org>2008-01-14 10:46:40 +0000
committerJean-Noël Rivasseau <elvanor@gentoo.org>2008-01-14 10:46:40 +0000
commit2001dd128ffb284b8505035ea0deadc4dd469b11 (patch)
tree9944163c3396d4ba63ce927167415c23c711235b /dev-java/commons-el
parentRemoved the strict dependency on icu4j-3.0, as it compiles fine with 3.6.1. (diff)
downloadgentoo-2-2001dd128ffb284b8505035ea0deadc4dd469b11.tar.gz
gentoo-2-2001dd128ffb284b8505035ea0deadc4dd469b11.tar.bz2
gentoo-2-2001dd128ffb284b8505035ea0deadc4dd469b11.zip
Uses java-osgi to create an OSGi compliant jar.
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-java/commons-el')
-rw-r--r--dev-java/commons-el/ChangeLog10
-rw-r--r--dev-java/commons-el/commons-el-1.0-r1.ebuild6
-rw-r--r--dev-java/commons-el/commons-el-1.0-r2.ebuild45
-rw-r--r--dev-java/commons-el/files/commons-el-1.0-manifest11
-rw-r--r--dev-java/commons-el/files/digest-commons-el-1.0-r23
5 files changed, 70 insertions, 5 deletions
diff --git a/dev-java/commons-el/ChangeLog b/dev-java/commons-el/ChangeLog
index 6cfaa2586ee7..201c6caea2e8 100644
--- a/dev-java/commons-el/ChangeLog
+++ b/dev-java/commons-el/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-el
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-el/ChangeLog,v 1.21 2007/04/25 19:24:48 betelgeuse Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-el/ChangeLog,v 1.22 2008/01/14 10:46:39 elvanor Exp $
+
+*commons-el-1.0-r2 (14 Jan 2008)
+
+ 14 Jan 2008; Jean-Noël Rivasseau <elvanor@gentoo.org>
+ +files/commons-el-1.0-manifest, +commons-el-1.0-r2.ebuild:
+ Uses java-osgi to create an OSGi compliant jar.
25 Apr 2007; Petteri Räty <betelgeuse@gentoo.org>
commons-el-1.0-r1.ebuild:
diff --git a/dev-java/commons-el/commons-el-1.0-r1.ebuild b/dev-java/commons-el/commons-el-1.0-r1.ebuild
index e97c66a68a5f..4d4aab55084d 100644
--- a/dev-java/commons-el/commons-el-1.0-r1.ebuild
+++ b/dev-java/commons-el/commons-el-1.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-el/commons-el-1.0-r1.ebuild,v 1.8 2007/04/25 19:24:48 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-el/commons-el-1.0-r1.ebuild,v 1.9 2008/01/14 10:46:39 elvanor Exp $
JAVA_PKG_IUSE="source"
@@ -23,7 +23,7 @@ S=${WORKDIR}/${P}-src
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
mv build.properties build.properties.old
echo "servlet-api.jar=$(java-pkg_getjar servletapi-2.4 servlet-api.jar)" >> build.properties
diff --git a/dev-java/commons-el/commons-el-1.0-r2.ebuild b/dev-java/commons-el/commons-el-1.0-r2.ebuild
new file mode 100644
index 000000000000..ed61152a3862
--- /dev/null
+++ b/dev-java/commons-el/commons-el-1.0-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-el/commons-el-1.0-r2.ebuild,v 1.1 2008/01/14 10:46:39 elvanor Exp $
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2 java-osgi
+
+DESCRIPTION="EL is the JSP 2.0 Expression Language Interpreter from Apache."
+HOMEPAGE="http://jakarta.apache.org/commons/el/"
+SRC_URI="mirror://apache/jakarta/commons/el/source/${P}-src.tar.gz"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+COMMON_DEP="~dev-java/servletapi-2.4"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}"
+
+S=${WORKDIR}/${P}-src
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ mv "build.properties" "build.properties.old"
+
+ echo "servlet-api.jar=$(java-pkg_getjar servletapi-2.4 servlet-api.jar)" >> build.properties
+ echo "jsp-api.jar=$(java-pkg_getjar servletapi-2.4 jsp-api.jar)" >> build.properties
+ echo "servletapi.build.notrequired = true" >> build.properties
+ echo "jspapi.build.notrequired = true" >> build.properties
+
+ # Build.xml is broken, fix it
+ sed -i "s:../LICENSE:./LICENSE.txt:" build.xml || die "sed failed"
+}
+
+src_install() {
+ java-osgi_dojar-fromfile "dist/${PN}.jar" "${FILESDIR}/${P}-manifest" \
+ "Apache Commons EL" || die "Unable to install"
+
+ dodoc LICENSE.txt RELEASE-NOTES.txt || die
+ dohtml STATUS.html PROPOSAL.html || die
+
+ use source && java-pkg_dosrc src/java/org
+}
diff --git a/dev-java/commons-el/files/commons-el-1.0-manifest b/dev-java/commons-el/files/commons-el-1.0-manifest
new file mode 100644
index 000000000000..86777e8ec2f7
--- /dev/null
+++ b/dev-java/commons-el/files/commons-el-1.0-manifest
@@ -0,0 +1,11 @@
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: %bundleName
+Bundle-Vendor: %vendorName
+Bundle-Localization: plugin
+Bundle-SymbolicName: org.apache.commons.el
+Bundle-Version: 1.0
+Export-Package: org.apache.commons.el;version="1.0.0",org.apache.commons.el.parser;version="1.0.0"
+Import-Package: javax.servlet;version="2.4",javax.servlet.http;version="2.4",javax.servlet.jsp;version="2.0",
+ javax.servlet.jsp.el;version="2.0",javax.servlet.jsp.resources;version="2.0",
+ javax.servlet.jsp.tagext;version="2.0",javax.servlet.resources;version="2.4"
diff --git a/dev-java/commons-el/files/digest-commons-el-1.0-r2 b/dev-java/commons-el/files/digest-commons-el-1.0-r2
new file mode 100644
index 000000000000..22867fcbbb5e
--- /dev/null
+++ b/dev-java/commons-el/files/digest-commons-el-1.0-r2
@@ -0,0 +1,3 @@
+MD5 25038283a0b5f638db5e891295d20020 commons-el-1.0-src.tar.gz 64009
+RMD160 1f178aeb6aed1cd807573c3add6195a719a533e2 commons-el-1.0-src.tar.gz 64009
+SHA256 3c9bdded6073563aaaddc9ad7c7387b242dc03cc385381503026b665a366c2c6 commons-el-1.0-src.tar.gz 64009