summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-03-18 01:18:09 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-03-18 01:18:09 +0000
commit9fdb119b32c4db9c6af271899057b66ad0f4f4d3 (patch)
treebe272c63ff632e8236af3d0fb433471eaee3747c /dev-java/commons-launcher/commons-launcher-1.1-r1.ebuild
parentUse wxGTK 2.8 instead of 2.6 (diff)
downloadgentoo-2-9fdb119b32c4db9c6af271899057b66ad0f4f4d3.tar.gz
gentoo-2-9fdb119b32c4db9c6af271899057b66ad0f4f4d3.tar.bz2
gentoo-2-9fdb119b32c4db9c6af271899057b66ad0f4f4d3.zip
Add empty src_test to prepare for the generic src_test.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-java/commons-launcher/commons-launcher-1.1-r1.ebuild')
-rw-r--r--dev-java/commons-launcher/commons-launcher-1.1-r1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-java/commons-launcher/commons-launcher-1.1-r1.ebuild b/dev-java/commons-launcher/commons-launcher-1.1-r1.ebuild
index 3b79ff1749a0..0e7b2728352a 100644
--- a/dev-java/commons-launcher/commons-launcher-1.1-r1.ebuild
+++ b/dev-java/commons-launcher/commons-launcher-1.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-launcher/commons-launcher-1.1-r1.ebuild,v 1.4 2007/11/18 18:12:57 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-launcher/commons-launcher-1.1-r1.ebuild,v 1.5 2008/03/18 01:18:09 betelgeuse Exp $
JAVA_PKG_IUSE="examples doc source"
@@ -20,13 +20,16 @@ RDEPEND=">=virtual/jre-1.4
S=${WORKDIR}/${PN}
# https://issues.apache.org/jira/browse/LAUNCHER-7
-PATCHES="${FILESDIR}/1.1-javadoc.patch"
+PATCHES=( "${FILESDIR}/1.1-javadoc.patch" )
src_compile() {
java-ant_rewrite-classpath "${S}/build.xml"
EANT_GENTOO_CLASSPATH="ant-core" java-pkg-2_src_compile
}
+# Standard commons build.xml but no tests actually implemented
+src_test() { :; }
+
src_install() {
java-pkg_dojar dist/bin/*.jar || die "java-pkg_dojar died"
dodoc README.txt NOTICE.txt || die