summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2010-10-24 09:09:34 +0000
committerSerkan Kaba <serkan@gentoo.org>2010-10-24 09:09:34 +0000
commit2ae519198f3585ce09e174b05baee20474866888 (patch)
tree085fe92bada4f7a2a314eca7f913f86a50f464c2 /dev-java/commons-math
parentMissing x11-libs/qt-svg:4 rdepend wrt #342405 by David Abbott. (diff)
downloadgentoo-2-2ae519198f3585ce09e174b05baee20474866888.tar.gz
gentoo-2-2ae519198f3585ce09e174b05baee20474866888.tar.bz2
gentoo-2-2ae519198f3585ce09e174b05baee20474866888.zip
Version bump. Also fixes bugs #291663 and #336536.
(Portage version: 2.2.0_alpha1/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/commons-math')
-rw-r--r--dev-java/commons-math/ChangeLog7
-rw-r--r--dev-java/commons-math/commons-math-2.1.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-java/commons-math/ChangeLog b/dev-java/commons-math/ChangeLog
index b1646eb9241c..754b64998dbf 100644
--- a/dev-java/commons-math/ChangeLog
+++ b/dev-java/commons-math/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/commons-math
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-math/ChangeLog,v 1.3 2010/03/21 09:08:18 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-math/ChangeLog,v 1.4 2010/10/24 09:09:34 serkan Exp $
+
+*commons-math-2.1 (24 Oct 2010)
+
+ 24 Oct 2010; Serkan Kaba <serkan@gentoo.org> +commons-math-2.1.ebuild:
+ Version bump. Also fixes bugs #291663 and #336536.
21 Mar 2010; Petteri Räty <betelgeuse@gentoo.org>
-commons-math-1.2.ebuild:
diff --git a/dev-java/commons-math/commons-math-2.1.ebuild b/dev-java/commons-math/commons-math-2.1.ebuild
new file mode 100644
index 000000000000..436d003175f4
--- /dev/null
+++ b/dev-java/commons-math/commons-math-2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-math/commons-math-2.1.ebuild,v 1.1 2010/10/24 09:09:34 serkan Exp $
+
+EAPI="3"
+
+JAVA_PKG_IUSE="doc test source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Lightweight, self-contained mathematics and statistics components"
+HOMEPAGE="http://commons.apache.org/math/"
+SRC_URI="mirror://apache/commons/math/source/${P}-src.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5
+ test? (
+ dev-java/ant-junit4
+ dev-java/hamcrest-core:0
+ )"
+
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/${P}-src"
+
+java_prepare() {
+ epatch "${FILESDIR}"/${P}-buildfixes.patch
+}
+
+src_test() {
+ java-pkg_jar-from junit-4
+ java-pkg_jar-from hamcrest-core
+ ANT_TASKS="ant-junit4" eant -Djunit.jar=junit.jar test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+# use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/main/java/org
+}