summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-10-02 18:15:45 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-10-02 18:15:45 +0000
commitae3b0c88d8e7d6cbf04bc4d358ba52f25d7dd9a1 (patch)
tree7dd5f0627e0632974587d452eb55c914f6dfc148 /dev-java/commons-math
parentStable for ppc. (diff)
downloadgentoo-2-ae3b0c88d8e7d6cbf04bc4d358ba52f25d7dd9a1.tar.gz
gentoo-2-ae3b0c88d8e7d6cbf04bc4d358ba52f25d7dd9a1.tar.bz2
gentoo-2-ae3b0c88d8e7d6cbf04bc4d358ba52f25d7dd9a1.zip
Import from Java overlay and rewrite
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/commons-math')
-rw-r--r--dev-java/commons-math/ChangeLog11
-rw-r--r--dev-java/commons-math/commons-math-1.2.ebuild52
-rw-r--r--dev-java/commons-math/commons-math-2.0.ebuild46
-rw-r--r--dev-java/commons-math/metadata.xml9
4 files changed, 118 insertions, 0 deletions
diff --git a/dev-java/commons-math/ChangeLog b/dev-java/commons-math/ChangeLog
new file mode 100644
index 000000000000..05fe935a1cb9
--- /dev/null
+++ b/dev-java/commons-math/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-java/commons-math
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-math/ChangeLog,v 1.1 2009/10/02 18:15:45 weaver Exp $
+
+*commons-math-2.0 (02 Oct 2009)
+*commons-math-1.2 (02 Oct 2009)
+
+ 02 Oct 2009; Andrey Kislyuk <weaver@gentoo.org> +metadata.xml,
+ +commons-math-1.2.ebuild, +commons-math-2.0.ebuild:
+ Import from Java overlay and rewrite
+
diff --git a/dev-java/commons-math/commons-math-1.2.ebuild b/dev-java/commons-math/commons-math-1.2.ebuild
new file mode 100644
index 000000000000..a822c752a14e
--- /dev/null
+++ b/dev-java/commons-math/commons-math-1.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-math/commons-math-1.2.ebuild,v 1.1 2009/10/02 18:15:45 weaver Exp $
+
+EAPI="2"
+
+WANT_ANT_TASKS="ant-junit"
+EANT_GENTOO_CLASSPATH="commons-discovery,commons-logging,junit"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+JAVA_PKG_IUSE="test source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Lightweight, self-contained mathematics and statistics components"
+HOMEPAGE="http://commons.apache.org/math/"
+SRC_URI="mirror://apache/commons/math/source/${P}-src.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+COMMON_DEP="
+ >=dev-java/commons-discovery-0.2
+ >=dev-java/commons-logging-1.0.3"
+
+DEPEND=">=virtual/jdk-1.5
+ >=dev-java/ant-core-1.6
+ ${COMMON_DEP}
+ test? ( dev-java/ant-junit )"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${P}-src"
+
+src_prepare() {
+ sed -i -e 's/depends="get-deps"//' \
+ -e 's/depends="compile,test"/depends="compile"/' "${S}/build.xml" || die
+}
+
+src_compile() {
+ eant -Duser.home="${WORKDIR}/user_home"
+}
+
+src_test() {
+ eant -Duser.home="${WORKDIR}/user_home" test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+ use source && java-pkg_dosrc src/java/org
+}
diff --git a/dev-java/commons-math/commons-math-2.0.ebuild b/dev-java/commons-math/commons-math-2.0.ebuild
new file mode 100644
index 000000000000..16eca6b2ed93
--- /dev/null
+++ b/dev-java/commons-math/commons-math-2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-math/commons-math-2.0.ebuild,v 1.1 2009/10/02 18:15:45 weaver Exp $
+
+EAPI="2"
+
+WANT_ANT_TASKS="ant-junit"
+JAVA_PKG_IUSE="doc test source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Lightweight, self-contained mathematics and statistics components"
+HOMEPAGE="http://commons.apache.org/math/"
+SRC_URI="mirror://apache/commons/math/source/${P}-src.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+COMMON_DEP="
+ >=dev-java/commons-discovery-0.2
+ >=dev-java/commons-logging-1.0.3"
+
+DEPEND=">=virtual/jdk-1.5
+ >=dev-java/ant-core-1.6
+ ${COMMON_DEP}
+ test? ( dev-java/ant-junit )"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${P}-src"
+
+src_test() {
+ cd lib || die
+ java-pkg_jar-from junit
+ cd ..
+ ANT_TASKS="ant-junit" eant test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+# use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/main/java/org
+}
diff --git a/dev-java/commons-math/metadata.xml b/dev-java/commons-math/metadata.xml
new file mode 100644
index 000000000000..b51100b7aeef
--- /dev/null
+++ b/dev-java/commons-math/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>weaver@gentoo.org</email>
+ <name>Andrey Kislyuk</name>
+ </maintainer>
+ <herd>java</herd>
+</pkgmetadata>