summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-01-26 18:34:28 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-01-26 18:34:28 +0000
commit3cb42a38c78acf986b15bf08ea79c4d7b0609ddf (patch)
tree5673dae24b89460d13e1c4cfe1258af0ba4dee43 /dev-java/commons-net/commons-net-1.4.1-r1.ebuild
parentEbuild cleanup. Use dojavadoc. (diff)
downloadgentoo-2-3cb42a38c78acf986b15bf08ea79c4d7b0609ddf.tar.gz
gentoo-2-3cb42a38c78acf986b15bf08ea79c4d7b0609ddf.tar.bz2
gentoo-2-3cb42a38c78acf986b15bf08ea79c4d7b0609ddf.zip
use dojavadoc and remove redundant src_compile
(Portage version: 2.1.2-r4)
Diffstat (limited to 'dev-java/commons-net/commons-net-1.4.1-r1.ebuild')
-rw-r--r--dev-java/commons-net/commons-net-1.4.1-r1.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/dev-java/commons-net/commons-net-1.4.1-r1.ebuild b/dev-java/commons-net/commons-net-1.4.1-r1.ebuild
index 4dc3e87de99c..e67d63411365 100644
--- a/dev-java/commons-net/commons-net-1.4.1-r1.ebuild
+++ b/dev-java/commons-net/commons-net-1.4.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.4.1-r1.ebuild,v 1.5 2006/10/17 02:47:29 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.4.1-r1.ebuild,v 1.6 2007/01/26 18:34:28 betelgeuse Exp $
inherit eutils java-pkg-2 java-ant-2
@@ -26,24 +26,20 @@ IUSE="doc examples source" # junit
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
mkdir -p target/lib
cd target/lib
java-pkg_jar-from jakarta-oro-2.0 jakarta-oro.jar oro.jar
- cd ${S}
+ cd "${S}"
# always disable tests
sed -i 's/depends="compile,test"/depends="compile"/' build.xml || die "Failed to disable junit"
}
-src_compile() {
- eant jar -Dnoget=true $(use_doc)
-}
-
src_install() {
java-pkg_newjar target/${P}.jar ${PN}.jar
- use doc && java-pkg_dohtml -r dist/docs/
+ use doc && java-pkg_dojavadoc dist/docs/api
if use examples; then
dodir /usr/share/doc/${PF}/examples
cp -r src/java/examples/* ${D}/usr/share/doc/${PF}/examples