summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-05-14 05:09:02 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-05-14 05:09:02 +0000
commitceb6f043d713168ca364634ff6fe7dee83ce2795 (patch)
tree93f519b2b555524c90b0b3f21c7962430b7cd02b /dev-java/cryptix-jce/cryptix-jce-20030217.ebuild
parentInitial import. (diff)
downloadgentoo-2-ceb6f043d713168ca364634ff6fe7dee83ce2795.tar.gz
gentoo-2-ceb6f043d713168ca364634ff6fe7dee83ce2795.tar.bz2
gentoo-2-ceb6f043d713168ca364634ff6fe7dee83ce2795.zip
Initial import.
Diffstat (limited to 'dev-java/cryptix-jce/cryptix-jce-20030217.ebuild')
-rw-r--r--dev-java/cryptix-jce/cryptix-jce-20030217.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-java/cryptix-jce/cryptix-jce-20030217.ebuild b/dev-java/cryptix-jce/cryptix-jce-20030217.ebuild
new file mode 100644
index 000000000000..91750f3350a8
--- /dev/null
+++ b/dev-java/cryptix-jce/cryptix-jce-20030217.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/cryptix-jce/cryptix-jce-20030217.ebuild,v 1.1 2003/05/14 05:08:58 absinthe Exp $
+
+inherit java-pkg
+
+S=${WORKDIR}
+DESCRIPTION="Cryptix JCE is a complete clean-room implementation of the official JCE 1.2 API as published by Sun."
+SRC_URI="http://cryptix.org/dist/${P}-snap.zip"
+HOMEPAGE="http://cryptix.org/products/jce/"
+KEYWORDS="~x86 ~ppc ~sparc"
+LICENSE="GPL-2"
+SLOT="0"
+DEPEND=""
+RDEPEND=">=virtual/jdk-1.2"
+
+src_compile() {
+ einfo "This ebuild is, for the time being, just a binary install."
+}
+
+src_install() {
+
+ dodoc README.TXT ChangeLog.txt LICENCE.TXT
+ java-pkg_dojar bin/*.jar
+}