summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-01-12 21:12:23 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-01-12 21:12:23 +0000
commit3f63081e180e309988bd64a5580160840e8cade1 (patch)
tree4565c9fb31d9c09bbce854d4425877f9052516b5 /dev-java/echo2
parentVersion bump, bug 134198 (diff)
downloadgentoo-2-3f63081e180e309988bd64a5580160840e8cade1.tar.gz
gentoo-2-3f63081e180e309988bd64a5580160840e8cade1.tar.bz2
gentoo-2-3f63081e180e309988bd64a5580160840e8cade1.zip
Remove fetch restriction by manually uploading to distfile as versioned to the Gentoo mirrors and corrected LICENSE.
(Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'dev-java/echo2')
-rw-r--r--dev-java/echo2/ChangeLog8
-rw-r--r--dev-java/echo2/echo2-2.0.0.ebuild30
2 files changed, 15 insertions, 23 deletions
diff --git a/dev-java/echo2/ChangeLog b/dev-java/echo2/ChangeLog
index f8a947786efd..cc3e062a5740 100644
--- a/dev-java/echo2/ChangeLog
+++ b/dev-java/echo2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/echo2
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/echo2/ChangeLog,v 1.3 2006/09/10 16:52:18 nelchael Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/echo2/ChangeLog,v 1.4 2007/01/12 21:12:23 betelgeuse Exp $
+
+ 12 Jan 2007; Petteri Räty <betelgeuse@gentoo.org> echo2-2.0.0.ebuild:
+ Remove fetch restriction by manually uploading to distfile as versioned to
+ the Gentoo mirrors and corrected LICENSE.
10 Sep 2006; Krzysiek Pawlik <nelchael@gentoo.org> echo2-2.0.0.ebuild:
Added ~ppc.
diff --git a/dev-java/echo2/echo2-2.0.0.ebuild b/dev-java/echo2/echo2-2.0.0.ebuild
index 4c42d10b5a32..d21b9e1aa909 100644
--- a/dev-java/echo2/echo2-2.0.0.ebuild
+++ b/dev-java/echo2/echo2-2.0.0.ebuild
@@ -1,42 +1,30 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/echo2/echo2-2.0.0.ebuild,v 1.3 2006/09/10 16:52:18 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/echo2/echo2-2.0.0.ebuild,v 1.4 2007/01/12 21:12:23 betelgeuse Exp $
inherit java-pkg-2 java-ant-2
DESCRIPTION="Echo2 is the next-generation of the Echo Web Framework"
HOMEPAGE="http://www.nextapp.com/platform/echo2/echo/"
-SRC_URI="NextApp_Echo2-${PV}.tgz"
-DOWNLOAD_URI="http://www.nextapp.com/downloads/echo2/${PV}/NextApp_Echo2.tgz"
+# NextApp uses broken file naming, all versions of Echo2
+# are named NextApp_Echo2.tgz. So you have manually put this to the mirrors
+# DOWNLOAD_URI="http://www.nextapp.com/downloads/echo2/${PV}/NextApp_Echo2.tgz"
-LICENSE="GPL-2"
+SRC_URI="mirror://gentoo/NextApp_Echo2-${PV}.tgz"
+
+
+LICENSE="|| ( MPL-1.1 LGPL-2.1 )"
SLOT="0"
KEYWORDS="~ppc ~x86"
IUSE="doc source"
-RESTRICT="fetch"
-
DEPEND=">=virtual/jdk-1.4"
RDEPEND=">=virtual/jre-1.4
>=dev-java/servletapi-2.4"
S="${WORKDIR}/NextApp_Echo2/"
-pkg_nofetch() {
-
- ewarn
- ewarn "NextApp uses broken file naming, all versions of Echo2"
- ewarn "are named NextApp_Echo2.tgz."
- ewarn
- ewarn "Please download following file:"
- ewarn " ${DOWNLOAD_URI}"
- ewarn "and move it to:"
- ewarn " ${DISTDIR}/${SRC_URI}"
- ewarn
-
-}
-
src_compile() {
export SERVLET_LIB_JAR=$(java-config -p servletapi-2.4)