summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2015-03-13 23:37:24 +0000
committerJames Le Cuirot <chewi@gentoo.org>2015-03-13 23:37:24 +0000
commit69b79c2f61aab7c59bbd66de4fb3b1e3c18e4919 (patch)
tree03359e89173107451f910643742a440f693a3c78 /dev-java/hawtjni-runtime
parentRemove old. (diff)
downloadgentoo-2-69b79c2f61aab7c59bbd66de4fb3b1e3c18e4919.tar.gz
gentoo-2-69b79c2f61aab7c59bbd66de4fb3b1e3c18e4919.tar.bz2
gentoo-2-69b79c2f61aab7c59bbd66de4fb3b1e3c18e4919.zip
Version bump. Closes bug #542466. Thanks to Arfrever.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 9C6D7DE4)
Diffstat (limited to 'dev-java/hawtjni-runtime')
-rw-r--r--dev-java/hawtjni-runtime/ChangeLog10
-rw-r--r--dev-java/hawtjni-runtime/hawtjni-runtime-1.10.ebuild30
-rw-r--r--dev-java/hawtjni-runtime/hawtjni-runtime-1.8.ebuild37
3 files changed, 38 insertions, 39 deletions
diff --git a/dev-java/hawtjni-runtime/ChangeLog b/dev-java/hawtjni-runtime/ChangeLog
index 00e7c0f7d1a2..a0069732e122 100644
--- a/dev-java/hawtjni-runtime/ChangeLog
+++ b/dev-java/hawtjni-runtime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/hawtjni-runtime
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/hawtjni-runtime/ChangeLog,v 1.2 2014/01/08 19:43:53 tomwij Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/hawtjni-runtime/ChangeLog,v 1.3 2015/03/13 23:37:24 chewi Exp $
+
+*hawtjni-runtime-1.10 (13 Mar 2015)
+
+ 13 Mar 2015; James Le Cuirot <chewi@gentoo.org> +hawtjni-runtime-1.10.ebuild,
+ -hawtjni-runtime-1.8.ebuild:
+ Version bump. Closes bug #542466. Thanks to Arfrever.
08 Jan 2014; Tom Wijsman <TomWij@gentoo.org> hawtjni-runtime-1.8.ebuild:
Remanifest for bug #497354, reported by John (EBo) David. Changed Copyright
diff --git a/dev-java/hawtjni-runtime/hawtjni-runtime-1.10.ebuild b/dev-java/hawtjni-runtime/hawtjni-runtime-1.10.ebuild
new file mode 100644
index 000000000000..4aedada4c681
--- /dev/null
+++ b/dev-java/hawtjni-runtime/hawtjni-runtime-1.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/hawtjni-runtime/hawtjni-runtime-1.10.ebuild,v 1.1 2015/03/13 23:37:24 chewi Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_P="hawtjni-project-${PV}"
+
+DESCRIPTION="A JNI code generator based on the generator used by the Eclipse SWT project"
+HOMEPAGE="https://github.com/fusesource/hawtjni"
+SRC_URI="https://github.com/fusesource/hawtjni/archive/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/hawtjni-${MY_P}/${PN}/src"
+JAVA_SRC_DIR="main/java"
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc ../../{changelog,notice,readme}.md
+}
diff --git a/dev-java/hawtjni-runtime/hawtjni-runtime-1.8.ebuild b/dev-java/hawtjni-runtime/hawtjni-runtime-1.8.ebuild
deleted file mode 100644
index e867485c7795..000000000000
--- a/dev-java/hawtjni-runtime/hawtjni-runtime-1.8.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/hawtjni-runtime/hawtjni-runtime-1.8.ebuild,v 1.2 2014/01/08 19:43:53 tomwij Exp $
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc source"
-
-inherit vcs-snapshot java-pkg-2 java-pkg-simple
-
-MY_P="hawtjni-project-${PV}"
-
-DESCRIPTION="A JNI code generator based on the generator used by the Eclipse SWT project"
-HOMEPAGE="http://jansi.fusesource.org/"
-SRC_URI="https://github.com/fusesource/hawtjni/tarball/${MY_P} -> ${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND=">=virtual/jdk-1.5"
-RDEPEND=">=virtual/jre-1.5"
-
-S="${WORKDIR}/${MY_P}/${PN}"
-
-JAVA_SRC_DIR="src/main/java"
-
-java_prepare() {
- # Easier to use java-pkg-simple.
- rm -v pom.xml || die
-}
-
-src_install() {
- java-pkg-simple_src_install
-
- dodoc ../{changelog,notice,readme}.md
-}