summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-05-22 16:02:45 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-05-22 16:02:45 +0000
commitbd811663ee3095ca475fa51c20977c8dc38fed9a (patch)
treede08555a1331678cd8ab48e88d7c7862e44287ce /dev-java/helpgui/helpgui-1.1.ebuild
parentBeautified *DEPEND and SRC_URI. (diff)
downloadgentoo-2-bd811663ee3095ca475fa51c20977c8dc38fed9a.tar.gz
gentoo-2-bd811663ee3095ca475fa51c20977c8dc38fed9a.tar.bz2
gentoo-2-bd811663ee3095ca475fa51c20977c8dc38fed9a.zip
Initial import, ebuild based on the contribution by Josh Nichols <nichoj@alum.rpi.edu>. Fixes #93561
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-java/helpgui/helpgui-1.1.ebuild')
-rw-r--r--dev-java/helpgui/helpgui-1.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-java/helpgui/helpgui-1.1.ebuild b/dev-java/helpgui/helpgui-1.1.ebuild
new file mode 100644
index 000000000000..25b51735746c
--- /dev/null
+++ b/dev-java/helpgui/helpgui-1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/helpgui/helpgui-1.1.ebuild,v 1.1 2005/05/22 16:02:45 luckyduck Exp $
+
+inherit java-pkg
+
+DESCRIPTION="HelpGUI is a simple library which develop a help viewer component."
+HOMEPAGE="http://helpgui.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.jar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc jikes source"
+
+RESTRICT="primaryuri"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core
+ jikes? ( dev-java/jikes )
+ source? ( app-arch/zip )"
+RDEPEND=">=virtual/jre-1.4"
+
+src_unpack() {
+ jar xf ${DISTDIR}/${A}
+}
+
+src_compile() {
+ local antflags="helpgui_jar"
+ use doc && antflags="${antflags} javadocs"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "Compile failed"
+}
+
+src_install() {
+ java-pkg_newjar build/${P}.jar ${PN}.jar
+
+ dodoc README
+ use doc && java-pkg_dohtml -r build/docs/
+ use source && java-pkg_dosrc src/*
+}