summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-07-27 15:23:53 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-07-27 15:23:53 +0000
commit6e889505f61c328c3d41c78881a968e9dc1805e3 (patch)
tree081f99c2c075666e12f9543a2c06d8375d2bea41 /dev-java/hessian/hessian-3.0.8-r3.ebuild
parentMoving virtual/jdk depends first so that the JDK's JRE will provide thisvirtu... (diff)
downloadgentoo-2-6e889505f61c328c3d41c78881a968e9dc1805e3.tar.gz
gentoo-2-6e889505f61c328c3d41c78881a968e9dc1805e3.tar.bz2
gentoo-2-6e889505f61c328c3d41c78881a968e9dc1805e3.zip
Revision bump to use new Java system.
(Portage version: 2.1.1_pre3-r5)
Diffstat (limited to 'dev-java/hessian/hessian-3.0.8-r3.ebuild')
-rw-r--r--dev-java/hessian/hessian-3.0.8-r3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-java/hessian/hessian-3.0.8-r3.ebuild b/dev-java/hessian/hessian-3.0.8-r3.ebuild
new file mode 100644
index 000000000000..1235f1c94c88
--- /dev/null
+++ b/dev-java/hessian/hessian-3.0.8-r3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/hessian/hessian-3.0.8-r3.ebuild,v 1.1 2006/07/27 15:23:53 nichoj Exp $
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="The Hessian binary web service protocol makes web services usable without requiring a large framework, and without learning yet another alphabet soup of protocols."
+HOMEPAGE="http://www.caucho.com/hessian/"
+SRC_URI="http://www.caucho.com/hessian/download/${P}-src.jar"
+
+LICENSE="Apache-1.1"
+SLOT="3.0.8"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc source"
+
+COMMON_DEP="=dev-java/servletapi-2.3*
+ ~dev-java/caucho-services-${PV}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+# FIXME doesn't like Java 1.5's XML APIs
+DEPEND="=virtual/jdk-1.4*
+ app-arch/unzip
+ source? ( app-arch/zip )
+ dev-java/ant-core
+ ${COMMON_DEP}"
+
+src_unpack() {
+ mkdir -p ${P}/src
+ unzip -qq -d ${S}/src ${DISTDIR}/${A}
+
+ # They package stuff from burlap in here
+ # Burlap is a separate protocol
+ rm -fr ${S}/src/com/caucho/burlap
+ rm -fr ${S}/src/com/caucho/services
+
+ cd ${S}
+ # No included ant script! Bad Java developer, bad!
+ cp ${FILESDIR}/build-${PV}.xml build.xml
+
+ # Populate classpath
+ echo "classpath=$(java-pkg_getjars servletapi-2.3):$(java-pkg_getjars caucho-services-3.0)" >> build.properties
+}
+
+src_compile() {
+ eant -Dproject.name=${PN} jar $(use_doc)
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+
+ use doc && java-pkg_dohtml -r dist/doc/api
+ use source && java-pkg_dosrc src/*
+}