summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2007-01-09 20:35:13 +0000
committerVlastimil Babka <caster@gentoo.org>2007-01-09 20:35:13 +0000
commit517177b438c658bcfde112a3a83db0a38a029601 (patch)
treed90f2d73b6e34e5d09f1f182ab268f16e54a46fa /dev-java/higlayout
parentForce java5 useflag on globally rather than just a few packages. (diff)
downloadgentoo-2-517177b438c658bcfde112a3a83db0a38a029601.tar.gz
gentoo-2-517177b438c658bcfde112a3a83db0a38a029601.tar.bz2
gentoo-2-517177b438c658bcfde112a3a83db0a38a029601.zip
Fix jar command.
(Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'dev-java/higlayout')
-rw-r--r--dev-java/higlayout/ChangeLog8
-rw-r--r--dev-java/higlayout/files/digest-higlayout-1.0-r13
-rw-r--r--dev-java/higlayout/higlayout-1.0-r1.ebuild56
3 files changed, 66 insertions, 1 deletions
diff --git a/dev-java/higlayout/ChangeLog b/dev-java/higlayout/ChangeLog
index 0c04cd8616eb..c21fab8ec4cd 100644
--- a/dev-java/higlayout/ChangeLog
+++ b/dev-java/higlayout/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/higlayout
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/higlayout/ChangeLog,v 1.1 2007/01/07 22:46:29 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/higlayout/ChangeLog,v 1.2 2007/01/09 20:35:13 caster Exp $
+
+*higlayout-1.0-r1 (09 Jan 2007)
+
+ 09 Jan 2007; Vlastimil Babka <caster@gentoo.org> -higlayout-1.0.ebuild,
+ +higlayout-1.0-r1.ebuild:
+ Fix jar command.
*higlayout-1.0 (07 Jan 2007)
diff --git a/dev-java/higlayout/files/digest-higlayout-1.0-r1 b/dev-java/higlayout/files/digest-higlayout-1.0-r1
new file mode 100644
index 000000000000..809cf490fd81
--- /dev/null
+++ b/dev-java/higlayout/files/digest-higlayout-1.0-r1
@@ -0,0 +1,3 @@
+MD5 5bd79f33157824499b0fc03d6a5e080a HIGLayout1.0.zip 78855
+RMD160 c0b447b8176d3d3cb0f54a2be3c3511eb3db9a51 HIGLayout1.0.zip 78855
+SHA256 87464c9c889c7f5c94170ccb76ec088b1452897f670dab090ff3db06c3fed5e7 HIGLayout1.0.zip 78855
diff --git a/dev-java/higlayout/higlayout-1.0-r1.ebuild b/dev-java/higlayout/higlayout-1.0-r1.ebuild
new file mode 100644
index 000000000000..3d09f9f8e4da
--- /dev/null
+++ b/dev-java/higlayout/higlayout-1.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/higlayout/higlayout-1.0-r1.ebuild,v 1.1 2007/01/09 20:35:13 caster Exp $
+
+inherit java-pkg-2
+
+DESCRIPTION="Java Swing layout manager that's powerful and easy to use"
+
+HOMEPAGE="http://www.autel.cz/dmi/tutorial.html"
+SRC_URI="http://www.autel.cz/dmi/HIGLayout${PV}.zip"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="doc examples source"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ source? ( app-arch/zip )"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ mkdir classes api
+ cd tutorial
+ for d in *.GIF;
+ do
+ mv $d $(basename $d .GIF).gif
+ done
+}
+
+src_compile() {
+ ejavac -d classes src/cz/autel/dmi/*.java || die "failed to compile sources"
+ jar -cf higlayout.jar -C classes cz || die "failed to create .jar"
+ if use doc; then
+ javadoc -author -version -d api src/cz/autel/dmi/*.java \
+ || die "javadoc failed"
+ fi
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ dodoc *.txt
+ if use doc; then
+ dohtml -r tutorial
+ java-pkg_dojavadoc api
+ fi
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+ use source && java-pkg_dosrc src/cz
+}