summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-04-14 13:50:07 +0000
committerVlastimil Babka <caster@gentoo.org>2010-04-14 13:50:07 +0000
commit066e3c7150f29ec39e1c68e9622c4a97537e3511 (patch)
treeb63498bffd31373186f9dffe64fffb41a38febfb /dev-java/icu4j
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-066e3c7150f29ec39e1c68e9622c4a97537e3511.tar.gz
gentoo-2-066e3c7150f29ec39e1c68e9622c4a97537e3511.tar.bz2
gentoo-2-066e3c7150f29ec39e1c68e9622c4a97537e3511.zip
Version bump, bug #296767.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/icu4j')
-rw-r--r--dev-java/icu4j/ChangeLog7
-rw-r--r--dev-java/icu4j/icu4j-4.4.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/dev-java/icu4j/ChangeLog b/dev-java/icu4j/ChangeLog
index 2c9a386ce28b..e14c1c306195 100644
--- a/dev-java/icu4j/ChangeLog
+++ b/dev-java/icu4j/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/icu4j
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/ChangeLog,v 1.41 2010/04/14 07:42:45 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/ChangeLog,v 1.42 2010/04/14 13:50:07 caster Exp $
+
+*icu4j-4.4 (14 Apr 2010)
+
+ 14 Apr 2010; Vlastimil Babka <caster@gentoo.org> +icu4j-4.4.ebuild:
+ Version bump, bug #296767.
14 Apr 2010; Vlastimil Babka <caster@gentoo.org> icu4j-4.2.1.1.ebuild:
Stop restricting tests
diff --git a/dev-java/icu4j/icu4j-4.4.ebuild b/dev-java/icu4j/icu4j-4.4.ebuild
new file mode 100644
index 000000000000..952d68336c3b
--- /dev/null
+++ b/dev-java/icu4j/icu4j-4.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/icu4j-4.4.ebuild,v 1.1 2010/04/14 13:50:07 caster Exp $
+
+EAPI=2
+
+# We currently download the Javadoc documentation.
+# It could optionally be built using the Ant build file.
+# testdata.jar and icudata.jar do not contain *.class files but *.res files
+# These *.res data files are needed to built the final jar
+# They do not need to be installed however as they will already be present in icu4j.jar
+
+JAVA_PKG_IUSE="doc test source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A set of Java libraries providing Unicode and Globalization support."
+MY_PV=${PV//./_}
+
+SRC_URI="http://download.icu-project.org/files/${PN}/${PV}/${PN}-${MY_PV}-src.jar
+ doc? ( http://download.icu-project.org/files/${PN}/${PV}/${PN}-${MY_PV}-docs.jar )"
+
+HOMEPAGE="http://www.icu-project.org/"
+LICENSE="icu"
+SLOT="4.4"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+# Tests only work with JDK-1.6, severe out of memory problems appear with 1.5
+DEPEND="test? ( =virtual/jdk-1.6* )
+ !test? ( >=virtual/jdk-1.5 )"
+RDEPEND=">=virtual/jre-1.5"
+
+RESTRICT="ia64? ( test )"
+
+JAVA_PKG_WANT_SOURCE="1.5"
+JAVA_PKG_WANT_TARGET="1.5"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ jar -xf "${DISTDIR}/${PN}-${MY_PV}-src.jar" || die "Failed to unpack"
+
+ if use doc; then
+ mkdir docs; cd docs
+ jar -xf "${DISTDIR}/${PN}-${MY_PV}-docs.jar" || die "Failed to unpack docs"
+ fi
+}
+
+src_compile() {
+ # Classes extending CharsetICU not implementing Comparable
+ # Breaks with ecj on jdk 1.5+, javac doesn't mind - Sun's hack?
+ # Restricting to javac (didn't even care to try jikes) is better
+ # than forcing 1.4
+ java-pkg_force-compiler javac
+ eant jar || die "Compile failed"
+}
+
+src_install() {
+ java-pkg_dojar "${PN}.jar"
+ java-pkg_dojar "${PN}-charsets.jar"
+ java-pkg_dojar "${PN}-localespi.jar"
+
+ dohtml readme.html
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc main/classes/*/src/com
+}
+
+src_test() {
+ # bug #299082 - these tests fail with icedtea, assume too much about double<>string conversions
+ sed -i '/DiagBigDecimal/d' main/tests/core/src/com/ibm/icu/dev/test/TestAllCore.java || die
+ eant check
+}