summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-05-23 07:41:59 +0000
committerVlastimil Babka <caster@gentoo.org>2009-05-23 07:41:59 +0000
commit7a20ef4ee8fe51d6ad9ea1f5609ed0d314717436 (patch)
tree04f73c10c0b9ddbd8eef0c3c58813226cfe59ab2 /dev-java/jna-posix/jna-posix-1.0.ebuild
parentNew package, jruby dependency, bug #244785. Ebuild provided by serkan and che... (diff)
downloadgentoo-2-7a20ef4ee8fe51d6ad9ea1f5609ed0d314717436.tar.gz
gentoo-2-7a20ef4ee8fe51d6ad9ea1f5609ed0d314717436.tar.bz2
gentoo-2-7a20ef4ee8fe51d6ad9ea1f5609ed0d314717436.zip
New package, jruby dependency, bug #268435. Ebuild provided by chewi in java-overlay.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/jna-posix/jna-posix-1.0.ebuild')
-rw-r--r--dev-java/jna-posix/jna-posix-1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/jna-posix/jna-posix-1.0.ebuild b/dev-java/jna-posix/jna-posix-1.0.ebuild
new file mode 100644
index 000000000000..9922d492dc32
--- /dev/null
+++ b/dev-java/jna-posix/jna-posix-1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jna-posix/jna-posix-1.0.ebuild,v 1.1 2009/05/23 07:41:59 caster Exp $
+
+EAPI=2
+JAVA_PKG_IUSE="source test"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Lightweight cross-platform POSIX emulation layer for Java"
+HOMEPAGE="http://kenai.com/projects/jna-posix"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="|| ( CPL-1.0 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5
+ dev-java/jna:0"
+
+DEPEND=">=virtual/jdk-1.5
+ dev-java/jna:0
+ test? ( dev-java/ant-junit4 )"
+
+java_prepare() {
+ java-pkg_jar-from --into lib jna
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+ use source && java-pkg_dosrc src/*
+ dodoc README.txt || die
+}
+
+src_test() {
+ ANT_TASKS="ant-junit4" eant test -Dlibs.junit_4.classpath="$(java-pkg_getjars --with-dependencies junit-4)"
+}