summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2006-09-30 00:21:34 +0000
committerVlastimil Babka <caster@gentoo.org>2006-09-30 00:21:34 +0000
commit223160a74224cf2de56e5d14ef5663ccd3bcd1a5 (patch)
tree964b9b09ddd08d956bf2725ae2b49256b50d6d82 /dev-java/joda-time
parentStable on x86, bug #148798. (diff)
downloadgentoo-2-223160a74224cf2de56e5d14ef5663ccd3bcd1a5.tar.gz
gentoo-2-223160a74224cf2de56e5d14ef5663ccd3bcd1a5.tar.bz2
gentoo-2-223160a74224cf2de56e5d14ef5663ccd3bcd1a5.zip
Version bump, using gen-2 eclases. Added source USE flag and src_test() but it's disabled because testcases fail to compile with 1.5+ JDK.
(Portage version: 2.1.2_pre1-r4)
Diffstat (limited to 'dev-java/joda-time')
-rw-r--r--dev-java/joda-time/ChangeLog10
-rw-r--r--dev-java/joda-time/files/digest-joda-time-1.22
-rw-r--r--dev-java/joda-time/files/digest-joda-time-1.33
-rw-r--r--dev-java/joda-time/joda-time-1.3.ebuild55
4 files changed, 68 insertions, 2 deletions
diff --git a/dev-java/joda-time/ChangeLog b/dev-java/joda-time/ChangeLog
index f8fd2a58f5bf..e3515a5990b7 100644
--- a/dev-java/joda-time/ChangeLog
+++ b/dev-java/joda-time/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/joda-time
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/joda-time/ChangeLog,v 1.11 2005/12/23 04:16:27 nichoj Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/joda-time/ChangeLog,v 1.12 2006/09/30 00:21:34 caster Exp $
+
+*joda-time-1.3 (30 Sep 2006)
+
+ 30 Sep 2006; Vlastimil Babka <caster@gentoo.org> +joda-time-1.3.ebuild:
+ Version bump, using gen-2 eclases. Added source USE flag and src_test() but
+ it's disabled because testcases fail to compile with 1.5+ JDK.
*joda-time-1.2 (23 Dec 2005)
diff --git a/dev-java/joda-time/files/digest-joda-time-1.2 b/dev-java/joda-time/files/digest-joda-time-1.2
index 6b210ae10620..9d8510314cd8 100644
--- a/dev-java/joda-time/files/digest-joda-time-1.2
+++ b/dev-java/joda-time/files/digest-joda-time-1.2
@@ -1 +1,3 @@
MD5 9797e1333eb660ce3c122d728d88df43 joda-time-1.2-src.tar.gz 1093743
+RMD160 39374c51948dbf3be979d73b80a3a3a7898e65e5 joda-time-1.2-src.tar.gz 1093743
+SHA256 7b2099f9f7bf74e9df324743df7a5644da21d4f73a4c7546eff18a9b4f961188 joda-time-1.2-src.tar.gz 1093743
diff --git a/dev-java/joda-time/files/digest-joda-time-1.3 b/dev-java/joda-time/files/digest-joda-time-1.3
new file mode 100644
index 000000000000..50c8deaf121d
--- /dev/null
+++ b/dev-java/joda-time/files/digest-joda-time-1.3
@@ -0,0 +1,3 @@
+MD5 2c01c7454ac8201a03e447b30ffd9982 joda-time-1.3-src.tar.gz 1143041
+RMD160 f8c38be48bcb5392b43756ba455627176b6d6bcd joda-time-1.3-src.tar.gz 1143041
+SHA256 dddabdbeafe8be472eb358697b241ab6e01b03b8c3d46e2fda08b9b7b17b47a4 joda-time-1.3-src.tar.gz 1143041
diff --git a/dev-java/joda-time/joda-time-1.3.ebuild b/dev-java/joda-time/joda-time-1.3.ebuild
new file mode 100644
index 000000000000..31071647d2ed
--- /dev/null
+++ b/dev-java/joda-time/joda-time-1.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/joda-time/joda-time-1.3.ebuild,v 1.1 2006/09/30 00:21:34 caster Exp $
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${P}-src"
+
+DESCRIPTION="A quality open-source replacement for the Java Date and Time classes."
+HOMEPAGE="http://${PN}.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc source test"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core
+ source? ( app-arch/zip )
+ test? (
+ dev-java/junit
+ dev-java/ant
+ )"
+RDEPEND=">=virtual/jre-1.4"
+
+# test cases won't compile with 1.5+, overriding stuff not implementing abstract
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ rm ${P}.jar
+}
+
+src_compile() {
+ # chokes on static inner class making instance of non-static inner class
+ java-pkg_filter-compiler jikes
+ # little trick so it doesn't try to download junit
+ eant -Djunit.ant=1 -Djunit.present=1 jar $(use_doc)
+}
+
+src_test() {
+ eant -Djunit.jar="$(java-pkg_getjars junit)" test
+}
+
+src_install() {
+ java-pkg_newjar build/${P}.jar ${PN}.jar
+
+ dodoc LICENSE.txt NOTICE.txt RELEASE-NOTES.txt ToDo.txt
+ use doc && java-pkg_dojavadoc build/docs
+ use source && java-pkg_dosrc src/java
+}