summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-08-03 11:08:35 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-08-03 11:08:35 +0000
commit600c1fbd6f1d035c5fc92bfa7f65381b2488ada5 (patch)
tree096fd9b181a659a0d105a10ace6674ea9a08bfbb /dev-java/jta/jta-1.0.1-r1.ebuild
parentMigrated to generation 2 Java build system. (diff)
downloadgentoo-2-600c1fbd6f1d035c5fc92bfa7f65381b2488ada5.tar.gz
gentoo-2-600c1fbd6f1d035c5fc92bfa7f65381b2488ada5.tar.bz2
gentoo-2-600c1fbd6f1d035c5fc92bfa7f65381b2488ada5.zip
Migrated to generation 2 Java build system.
(Portage version: 2.1.1_pre4-r2)
Diffstat (limited to 'dev-java/jta/jta-1.0.1-r1.ebuild')
-rw-r--r--dev-java/jta/jta-1.0.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/jta/jta-1.0.1-r1.ebuild b/dev-java/jta/jta-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..e426362c1b90
--- /dev/null
+++ b/dev-java/jta/jta-1.0.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jta/jta-1.0.1-r1.ebuild,v 1.1 2006/08/03 11:08:35 nelchael Exp $
+
+inherit java-pkg-2
+
+At="jta-1_0_1B-classes.zip"
+DESCRIPTION="The Java Transaction API"
+HOMEPAGE="http://java.sun.com/products/jta/"
+SRC_URI="${At}"
+LICENSE="sun-bcla-jta"
+SLOT=0
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND=">=app-arch/unzip-5.50-r1
+ >=virtual/jdk-1.3"
+RDEPEND=">=virtual/jre-1.3"
+RESTRICT="fetch"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo
+ einfo " Due to license restrictions, we cannot fetch the"
+ einfo " distributables automagically."
+ einfo
+ einfo " 1. Visit ${HOMEPAGE}"
+ einfo " 2. Select 'Java Transaction API Specification 1.0.1B Class Files 1.0.1B'"
+ einfo " 3. Download ${At}"
+ einfo " 4. Move file to ${DISTDIR}"
+ einfo " 5. Restart the emerge process"
+ einfo
+}
+
+src_unpack() {
+ unzip -qq ${DISTDIR}/${At} || die "failed too unpack"
+}
+
+src_compile() {
+ jar cvf jta.jar javax/ || die "failed to create jar"
+}
+
+src_install() {
+ java-pkg_dojar jta.jar
+}