summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-08-25 03:12:02 +0000
committerAron Griffis <agriffis@gentoo.org>2005-08-25 03:12:02 +0000
commitfb4ce35c4a3e20df39128492f95e685ecb00c872 (patch)
tree8831bde7105ce391a57a21d23503035d1818cfad /dev-java/jtidy/jtidy-0_pre20010801.ebuild
parentMarking 2.10.0 stable (x86) (diff)
downloadgentoo-2-fb4ce35c4a3e20df39128492f95e685ecb00c872.tar.gz
gentoo-2-fb4ce35c4a3e20df39128492f95e685ecb00c872.tar.bz2
gentoo-2-fb4ce35c4a3e20df39128492f95e685ecb00c872.zip
Add patch to allow compilation with java-1.5. Add ~ia64
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-java/jtidy/jtidy-0_pre20010801.ebuild')
-rw-r--r--dev-java/jtidy/jtidy-0_pre20010801.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-java/jtidy/jtidy-0_pre20010801.ebuild b/dev-java/jtidy/jtidy-0_pre20010801.ebuild
index 3b2c6e48ba47..2283d7ff88ca 100644
--- a/dev-java/jtidy/jtidy-0_pre20010801.ebuild
+++ b/dev-java/jtidy/jtidy-0_pre20010801.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jtidy/jtidy-0_pre20010801.ebuild,v 1.6 2005/05/15 01:16:06 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jtidy/jtidy-0_pre20010801.ebuild,v 1.7 2005/08/25 03:12:02 agriffis Exp $
-inherit java-pkg
+inherit eutils java-pkg
MY_PV="04aug2000r7"
DESCRIPTION="Tidy is a Java port of HTML Tidy , a HTML syntax checker and pretty printer."
@@ -10,7 +10,7 @@ HOMEPAGE="http://jtidy.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}-dev.zip"
LICENSE="Apache-1.1"
SLOT="0"
-KEYWORDS="x86 ppc amd64"
+KEYWORDS="amd64 ~ia64 ppc x86"
IUSE="doc jikes"
DEPEND=">=virtual/jdk-1.4
app-arch/unzip
@@ -20,6 +20,12 @@ RDEPEND=">=virtual/jre-1.4"
S=${WORKDIR}/${PN}-${MY_PV}-dev
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/jtidy-source-1.4.patch
+}
+
src_compile() {
local antflags="jar"
use doc && antflags="${antflags} javadoc"