summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2012-04-18 19:31:12 +0000
committerAlistair Bush <ali_bush@gentoo.org>2012-04-18 19:31:12 +0000
commit665c33f2428dccf0b73c9887d1f3faa4a5276161 (patch)
treec72ce1d2474cbe2eff80d36e7c07247494c4f7bd /dev-java/nailgun
parentx86 stable, bug #409403 (diff)
downloadgentoo-2-665c33f2428dccf0b73c9887d1f3faa4a5276161.tar.gz
gentoo-2-665c33f2428dccf0b73c9887d1f3faa4a5276161.tar.bz2
gentoo-2-665c33f2428dccf0b73c9887d1f3faa4a5276161.zip
Fix LDFLAGS bug #335445.
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/nailgun')
-rw-r--r--dev-java/nailgun/ChangeLog10
-rw-r--r--dev-java/nailgun/files/0.7.1-r1-Makefile.patch18
-rw-r--r--dev-java/nailgun/nailgun-0.7.1-r1.ebuild67
3 files changed, 93 insertions, 2 deletions
diff --git a/dev-java/nailgun/ChangeLog b/dev-java/nailgun/ChangeLog
index 30d9fd100e06..71475a25be7c 100644
--- a/dev-java/nailgun/ChangeLog
+++ b/dev-java/nailgun/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/nailgun
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/nailgun/ChangeLog,v 1.8 2011/08/05 16:08:14 ulm Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/nailgun/ChangeLog,v 1.9 2012/04/18 19:31:12 ali_bush Exp $
+
+*nailgun-0.7.1-r1 (18 Apr 2012)
+
+ 18 Apr 2012; Alistair Bush <ali_bush@gentoo.org>
+ +files/0.7.1-r1-Makefile.patch, +nailgun-0.7.1-r1.ebuild:
+ Fix LDFLAGS bug #335445.
05 Aug 2011; Ulrich Mueller <ulm@gentoo.org> nailgun-0.7.1.ebuild:
Fix typo in blocker against app-editors/ng.
diff --git a/dev-java/nailgun/files/0.7.1-r1-Makefile.patch b/dev-java/nailgun/files/0.7.1-r1-Makefile.patch
new file mode 100644
index 000000000000..a38185485578
--- /dev/null
+++ b/dev-java/nailgun/files/0.7.1-r1-Makefile.patch
@@ -0,0 +1,18 @@
+diff -Naur nailgun-0.7.1/Makefile nailgun-0.7.1_patches/Makefile
+--- nailgun-0.7.1/Makefile 2004-11-25 11:00:22.000000000 +1300
++++ nailgun-0.7.1_patches/Makefile 2012-04-19 07:22:16.000000000 +1200
+@@ -5,13 +5,11 @@
+ #
+ # Marty Lamb
+
+-CC=gcc
+ WIN32_CC=/usr/local/mingw32/bin/mingw32-gcc
+-CFLAGS=-Wall -pedantic -s -O3
+
+ ng: src/c/ng.c
+ @echo "Building ng client. To build a Windows binary, type 'make ng.exe'"
+- ${CC} ${CFLAGS} -o ng src/c/ng.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o ng src/c/ng.c
+
+ ng.exe: src/c/ng.c
+ # any idea why the command line is so sensitive to the order of
diff --git a/dev-java/nailgun/nailgun-0.7.1-r1.ebuild b/dev-java/nailgun/nailgun-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..1b58f0ef871b
--- /dev/null
+++ b/dev-java/nailgun/nailgun-0.7.1-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/nailgun/nailgun-0.7.1-r1.ebuild,v 1.1 2012/04/18 19:31:12 ali_bush Exp $
+
+EAPI="2"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="a client, protocol, and server for running Java apps without incurring the JVM startup overhead"
+HOMEPAGE="http://martiansoftware.com/nailgun/index.html"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND=">=virtual/jre-1.4
+ !app-editors/ng"
+DEPEND=">=virtual/jdk-1.4
+ dev-java/java-getopt:1
+ dev-java/bcel:0
+ dev-java/jakarta-oro:2.0
+ dev-java/log4j:0
+ app-arch/unzip
+ dev-java/junit:0
+ test? (
+ dev-java/ant-junit:0
+ )"
+
+#need jcoverage
+RESTRICT="test"
+
+java_prepare() {
+ rm -vf ng* beansh
+ find . -iname '*.jar' -delete
+
+ epatch "${FILESDIR}/${PV}-r1-Makefile.patch"
+
+ sed -i '/<arg line="ng.exe/d' build.xml || die
+ sed -i 's/depends="test"/depends="compile"/' build.xml || die
+
+ java-pkg_jar-from --into tools/lib --build-only java-getopt-1 \
+ gnu.getopt.jar java-getopt-1.0.10.jar
+ java-pkg_jar-from --into tools/lib --build-only junit junit.jar
+ java-pkg_jar-from --into tools/lib --build-only bcel bcel.jar \
+ bcel-5.1.jar
+ java-pkg_jar-from --into tools/lib --build-only jakarta-oro-2.0 \
+ jakarta-oro.jar jakarta-oro-2.0.8.jar
+ java-pkg_jar-from --into tools/lib --build-only log4j log4j.jar \
+ log4j-1.2.8.jar
+}
+
+src_test() {
+ WANT_TASKS="ant-junit" eant test
+}
+
+src_install() {
+ dobin ng
+ # Should we have a dolauncher?
+
+ java-pkg_newjar "dist/${P}.jar"
+ use doc && java-pkg_dojavadoc docs/api
+ use source && java-pkg_dosrc src/java/prod/*
+}