summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-05-20 22:01:16 +0000
committerVlastimil Babka <caster@gentoo.org>2009-05-20 22:01:16 +0000
commite0828ef4068648936bb6eb5955509de47666d91d (patch)
tree609da231d4e729944f9d77bfcc3406b68ceb78d3 /dev-java/offo-hyphenation
parentVersion bump, bug #200851. (diff)
downloadgentoo-2-e0828ef4068648936bb6eb5955509de47666d91d.tar.gz
gentoo-2-e0828ef4068648936bb6eb5955509de47666d91d.tar.bz2
gentoo-2-e0828ef4068648936bb6eb5955509de47666d91d.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/offo-hyphenation')
-rw-r--r--dev-java/offo-hyphenation/ChangeLog10
-rw-r--r--dev-java/offo-hyphenation/offo-hyphenation-1.2.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-java/offo-hyphenation/ChangeLog b/dev-java/offo-hyphenation/ChangeLog
index 5d0824eaee25..fe49d0ddf700 100644
--- a/dev-java/offo-hyphenation/ChangeLog
+++ b/dev-java/offo-hyphenation/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/offo-hyphenation
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/offo-hyphenation/ChangeLog,v 1.4 2007/08/21 05:12:31 wltjr Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/offo-hyphenation/ChangeLog,v 1.5 2009/05/20 22:01:16 caster Exp $
+
+*offo-hyphenation-1.2 (20 May 2009)
+
+ 20 May 2009; Vlastimil Babka <caster@gentoo.org>
+ +offo-hyphenation-1.2.ebuild:
+ Version bump.
21 Aug 2007; William L. Thomson Jr. <wltjr@gentoo.org>
offo-hyphenation-1.0.ebuild:
diff --git a/dev-java/offo-hyphenation/offo-hyphenation-1.2.ebuild b/dev-java/offo-hyphenation/offo-hyphenation-1.2.ebuild
new file mode 100644
index 000000000000..18fe3ee5e964
--- /dev/null
+++ b/dev-java/offo-hyphenation/offo-hyphenation-1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/offo-hyphenation/offo-hyphenation-1.2.ebuild,v 1.1 2009/05/20 22:01:16 caster Exp $
+
+DESCRIPTION="Hyphenation patterns for Apache Fop"
+HOMEPAGE="http://offo.sourceforge.net"
+# upstream will hopefully version future release...
+SRC_URI="mirror://sourceforge/offo/${PN}_v${PV}.zip"
+# review this upon update!
+LICENSE="GPL-2 Apache-2.0 LPPL-1.3b TeX"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/${PN}/
+ insinto /usr/share/${PN}/
+ doins -r hyph
+
+ dohtml licenses.html || die
+ if use doc; then
+ dohtml -r images skin i*.html
+ fi
+}
+
+pkg_postinst() {
+ elog "This package installs hyphenation files for several languages"
+ elog "into /usr/share/${PN}/hyph"
+ elog "Check /usr/share/doc/${PF}/html/licenses.html for each file's license."
+ elog "To compile the patterns, install dev-java/fop with USE=hyphenation."
+ elog "Alternatively, use the uncompiled patterns via the <hyphenation-base>"
+ elog "configuration option. See the documentation for more details."
+}