summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-09-19 08:25:58 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-09-19 08:25:58 +0000
commitef3749b1ff4a063242f8833f76697841a9005aca (patch)
tree37e5d8619f03bea4b1bb7dc88dbbfafd41e459de /dev-java/poi
parentMarked stable on mips. (Manifest recommit) (diff)
downloadgentoo-2-ef3749b1ff4a063242f8833f76697841a9005aca.tar.gz
gentoo-2-ef3749b1ff4a063242f8833f76697841a9005aca.tar.bz2
gentoo-2-ef3749b1ff4a063242f8833f76697841a9005aca.zip
Doesn't use packed jars anymore, thanks too Mark Wolfe <mwolfe@netspace.net.au>. The ebuild also evilly fetched other jars it then used, i corrected those. closes #63263
Diffstat (limited to 'dev-java/poi')
-rw-r--r--dev-java/poi/ChangeLog9
-rw-r--r--dev-java/poi/Manifest4
-rw-r--r--dev-java/poi/files/digest-poi-2.5-r11
-rw-r--r--dev-java/poi/poi-2.5-r1.ebuild60
4 files changed, 72 insertions, 2 deletions
diff --git a/dev-java/poi/ChangeLog b/dev-java/poi/ChangeLog
index e7d9eba28152..adb94a97cf5c 100644
--- a/dev-java/poi/ChangeLog
+++ b/dev-java/poi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/poi
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/poi/ChangeLog,v 1.5 2004/07/22 14:47:24 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/poi/ChangeLog,v 1.6 2004/09/19 08:25:58 axxo Exp $
+
+*poi-2.5-r1 (19 Sep 2004)
+
+ 19 Sep 2004; Thomas Matthijs <axxo@gentoo.org> +poi-2.5-r1.ebuild:
+ Doesn't use packed jars anymore, thanks too Mark Wolfe
+ <mwolfe@netspace.net.au>. The ebuild also evilly fetched other jars it then
+ used, i corrected those. closes #63263
*poi-2.5 (22 Jul 2004)
diff --git a/dev-java/poi/Manifest b/dev-java/poi/Manifest
index 3881d7e8bb65..b57011e595f4 100644
--- a/dev-java/poi/Manifest
+++ b/dev-java/poi/Manifest
@@ -1,8 +1,10 @@
+MD5 79f6849edd3c61059b35b596eef11d17 poi-2.5-r1.ebuild 2065
MD5 ecc4a894b8756146e6cabab65e804cb1 poi-2.5.ebuild 1139
MD5 6f22c15f3e854e31bf13a50505bf8d24 poi-2.0.ebuild 1140
-MD5 6c7791821498783bdc75e405d3a6316f ChangeLog 853
+MD5 fd93294861f384f4e9c1fcc990326b50 ChangeLog 1111
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 023344518eb201171e9d2ff652b476e7 files/digest-poi-2.0 79
MD5 34ac7de875dec815d44a2bdbf7f4a64f files/digest-poi-2.5 79
MD5 bf71154ca919a88d8c12da29e33ef4d9 files/poi-2.0-jikes-fix.patch 1190
+MD5 34ac7de875dec815d44a2bdbf7f4a64f files/digest-poi-2.5-r1 79
MD5 bf71154ca919a88d8c12da29e33ef4d9 files/poi-2.5-jikes-fix.patch 1190
diff --git a/dev-java/poi/files/digest-poi-2.5-r1 b/dev-java/poi/files/digest-poi-2.5-r1
new file mode 100644
index 000000000000..1a3f8246b36e
--- /dev/null
+++ b/dev-java/poi/files/digest-poi-2.5-r1
@@ -0,0 +1 @@
+MD5 b45cd066ff4a8ca4a9555839722e7f80 poi-src-2.5-final-20040302.tar.gz 6878720
diff --git a/dev-java/poi/poi-2.5-r1.ebuild b/dev-java/poi/poi-2.5-r1.ebuild
new file mode 100644
index 000000000000..2bedf25b1ec9
--- /dev/null
+++ b/dev-java/poi/poi-2.5-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/poi/poi-2.5-r1.ebuild,v 1.1 2004/09/19 08:25:58 axxo Exp $
+
+inherit java-pkg eutils
+
+DESCRIPTION="Java API To Access Microsoft Format Files"
+HOMEPAGE="http://jakarta.apache.org/poi/"
+SRC_URI="mirror://apache/jakarta/poi/release/src/${PN}-src-${PV}-final-20040302.tar.gz"
+IUSE="jikes junit"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+DEPEND=">=virtual/jdk-1.2
+ junit? ( dev-java/junit )
+ sys-apps/sed
+ >=dev-java/ant-1.4
+ jikes? ( dev-java/jikes )"
+RDEPEND=">=virtual/jre-1.2
+ >=dev-java/commons-logging-1.0
+ >=dev-java/log4j-1.2.8
+ >=dev-java/commons-beanutils-1.6
+ >=dev-java/commons-collections-2.1
+ >=dev-java/commons-lang-1.0
+ >=dev-java/xerces-2.6.2-r1"
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ rm -f src/contrib/lib/*.jar lib/*.jar
+ use jikes && epatch ${FILESDIR}/${P}-jikes-fix.patch
+ sed -e 's:<target name="init" depends="check-jars,fetch-jars">:<target name="init" depends="check-jars">:' -i build.xml
+
+ cd ${S}/lib
+ use junit && java-pkg_jar-from junit junit.jar junit-3.8.1.jar
+ java-pkg_jar-from log4j log4j.jar log4j-1.2.8.jar
+ java-pkg_jar-from commons-logging commons-logging.jar commons-logging-1.0.1.jar
+ cd ${S}/src/contrib/lib
+ java-pkg_jar-from commons-beanutils commons-beanutils.jar commons-beanutils-1.6.jar
+ java-pkg_jar-from commons-collections commons-collections.jar commons-collections-2.1.jar
+ java-pkg_jar-from commons-lang commons-lang.jar commons-lang-1.0-b1.jar
+ java-pkg_jar-from xerces-2 xmlParserAPIs.jar xmlParserAPIs-2.2.1.jar
+ java-pkg_jar-from xerces-2 xercesImpl.jar xercesImpl-2.4.0.jar
+}
+
+src_compile() {
+ local antflags="jar"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use junit && antflags="${antflags} test"
+ ant ${antflags} || die "compile problem"
+}
+
+src_install() {
+ cd build/dist/
+ mv poi-scratchpad-${PV}* ${PN}-scratchpad.jar
+ mv poi-contrib-${PV}* ${PN}-contrib.jar
+ mv poi-${PV}* ${PN}.jar
+ java-pkg_dojar *.jar
+}