summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2008-02-07 12:02:40 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2008-02-07 12:02:40 +0000
commitfa9f42a3ec74282c0c9f791c23f534983c7d535e (patch)
treefb619821b3f3e342a0e5823c6a569595289f8b64 /dev-java/poi
parentsparc stable wrt #206684 (diff)
downloadgentoo-2-fa9f42a3ec74282c0c9f791c23f534983c7d535e.tar.gz
gentoo-2-fa9f42a3ec74282c0c9f791c23f534983c7d535e.tar.bz2
gentoo-2-fa9f42a3ec74282c0c9f791c23f534983c7d535e.zip
Added patch that fixes detection of custom dates and datetimes in HSSFDateUtil.isADateFormat() method
(Portage version: 2.1.4.1)
Diffstat (limited to 'dev-java/poi')
-rw-r--r--dev-java/poi/ChangeLog10
-rw-r--r--dev-java/poi/files/poi-3.0.2-isADateFormat.patch11
-rw-r--r--dev-java/poi/poi-3.0.2-r1.ebuild (renamed from dev-java/poi/poi-3.0.2.ebuild)8
3 files changed, 24 insertions, 5 deletions
diff --git a/dev-java/poi/ChangeLog b/dev-java/poi/ChangeLog
index 3e987f1559da..963888aefb7f 100644
--- a/dev-java/poi/ChangeLog
+++ b/dev-java/poi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/poi
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/poi/ChangeLog,v 1.42 2008/02/06 18:23:27 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/poi/ChangeLog,v 1.43 2008/02/07 12:02:40 fordfrog Exp $
+
+*poi-3.0.2-r1 (07 Feb 2008)
+
+ 07 Feb 2008; Miroslav Šulc <fordfrog@gentoo.org>
+ +files/poi-3.0.2-isADateFormat.patch, -poi-3.0.2.ebuild,
+ +poi-3.0.2-r1.ebuild:
+ Added patch that fixes detection of custom dates and datetimes in
+ HSSFDateUtil.isADateFormat() method
*poi-3.0.2 (06 Feb 2008)
diff --git a/dev-java/poi/files/poi-3.0.2-isADateFormat.patch b/dev-java/poi/files/poi-3.0.2-isADateFormat.patch
new file mode 100644
index 000000000000..d4743148ef04
--- /dev/null
+++ b/dev-java/poi/files/poi-3.0.2-isADateFormat.patch
@@ -0,0 +1,11 @@
+--- ./src/java/org/apache/poi/hssf/usermodel/HSSFDateUtil.java.orig 2008-02-07 12:02:57.000000000 +0100
++++ ./src/java/org/apache/poi/hssf/usermodel/HSSFDateUtil.java 2008-02-07 12:29:17.000000000 +0100
+@@ -210,7 +210,7 @@
+
+ // Otherwise, check it's only made up of:
+ // y m d - / ,
+- if(fs.matches("^[ymd\\-/, ]+$")) {
++ if(fs.matches("^[yYmMdDhHsS\\-/,. :]+$")) {
+ return true;
+ }
+
diff --git a/dev-java/poi/poi-3.0.2.ebuild b/dev-java/poi/poi-3.0.2-r1.ebuild
index 839dd3d23813..85179bda35b6 100644
--- a/dev-java/poi/poi-3.0.2.ebuild
+++ b/dev-java/poi/poi-3.0.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/poi/poi-3.0.2.ebuild,v 1.1 2008/02/06 18:23:27 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/poi/poi-3.0.2-r1.ebuild,v 1.1 2008/02/07 12:02:40 fordfrog Exp $
EAPI=1
JAVA_PKG_IUSE="doc examples source"
@@ -32,9 +32,9 @@ src_unpack() {
unpack ${A}
cd "${S}"
- # Patch that adds unofficial support for detection whether cell is
- # date/time format till upstream solves that
- #epatch "${FILESDIR}/${P}-src-isDateFormat.patch"
+ # Patch that adds unofficial fix for detection of custom date/time formats
+ # See bug: http://issues.apache.org/bugzilla/show_bug.cgi?id=44373
+ epatch "${FILESDIR}/${P}-isADateFormat.patch"
find -name "*.jar" | xargs rm -v