summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-03-09 20:24:09 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-03-09 20:24:09 +0000
commitf04dd95d57ba798ec75dcf539f27332224a75ea7 (patch)
treeb2a97034bcc09c8c278676e9a3c606140db77220 /dev-java/rxtx/rxtx-2.1.7_pre17.ebuild
parentadd 3.4.0-final support (diff)
downloadgentoo-2-f04dd95d57ba798ec75dcf539f27332224a75ea7.tar.gz
gentoo-2-f04dd95d57ba798ec75dcf539f27332224a75ea7.tar.bz2
gentoo-2-f04dd95d57ba798ec75dcf539f27332224a75ea7.zip
Initial import. Ebuild contributed by Nikolas Coukouma <otto@atrus.org>. Fixes #72580.
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-java/rxtx/rxtx-2.1.7_pre17.ebuild')
-rw-r--r--dev-java/rxtx/rxtx-2.1.7_pre17.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-java/rxtx/rxtx-2.1.7_pre17.ebuild b/dev-java/rxtx/rxtx-2.1.7_pre17.ebuild
new file mode 100644
index 000000000000..b0708b32f68c
--- /dev/null
+++ b/dev-java/rxtx/rxtx-2.1.7_pre17.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/rxtx/rxtx-2.1.7_pre17.ebuild,v 1.1 2005/03/09 20:24:09 luckyduck Exp $
+
+inherit java-pkg
+
+NP=rxtx-2.1-7pre17
+
+DESCRIPTION="Native lib providing serial and parallel communication for Java"
+HOMEPAGE="http://rxtx.org/"
+SRC_URI="ftp://jarvi.dsl.frii.com/pub/rxtx/${NP}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${NP}"
+
+src_compile() {
+ cd ${S}
+ econf || die "Configuration failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ java-pkg_dojar RXTXcomm.jar
+ java-pkg_doso $CHOST/.libs/*.so
+ dodoc AUTHORS COPYING ChangeLog PORTING TODO SerialPortInstructions.txt
+ java-pkg_dohtml RMISecurityManager.html
+}