summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-16 00:24:09 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-16 00:24:09 +0000
commit1cde014837f847e518563d8413993d037ad64e56 (patch)
tree19bd0c037b16d32073369650621e9edc635273e1 /dev-java/sun-jdk
parentupdated to the final version of Blender (diff)
downloadgentoo-2-1cde014837f847e518563d8413993d037ad64e56.tar.gz
gentoo-2-1cde014837f847e518563d8413993d037ad64e56.tar.bz2
gentoo-2-1cde014837f847e518563d8413993d037ad64e56.zip
Fixes tail problem and include a 586 binary.
Diffstat (limited to 'dev-java/sun-jdk')
-rw-r--r--dev-java/sun-jdk/ChangeLog9
-rw-r--r--dev-java/sun-jdk/files/digest-sun-jdk-1.4.0-r30
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.4.0-r3.ebuild70
3 files changed, 78 insertions, 1 deletions
diff --git a/dev-java/sun-jdk/ChangeLog b/dev-java/sun-jdk/ChangeLog
index 949b44e02307..610b7e3c25b4 100644
--- a/dev-java/sun-jdk/ChangeLog
+++ b/dev-java/sun-jdk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/sun-jdk
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.9 2002/05/04 00:57:10 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.10 2002/06/16 00:24:09 rphillips Exp $
+
+*sun-jdk-1.3.1-r3 (15 Jun 2002)
+
+ 15 May 2002; Ryan Phillips <rphillips@gentoo.org> sun-jdk-1.3.1-r3.ebuild :
+
+ Sun changed the binary package of the current SDK... This fixes the tail + problem
+ and the binary that is now provided is compiled for 586.
*sun-jdk-1.3.1.02 (04 May 2002)
diff --git a/dev-java/sun-jdk/files/digest-sun-jdk-1.4.0-r3 b/dev-java/sun-jdk/files/digest-sun-jdk-1.4.0-r3
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/dev-java/sun-jdk/files/digest-sun-jdk-1.4.0-r3
diff --git a/dev-java/sun-jdk/sun-jdk-1.4.0-r3.ebuild b/dev-java/sun-jdk/sun-jdk-1.4.0-r3.ebuild
new file mode 100644
index 000000000000..665c248529a2
--- /dev/null
+++ b/dev-java/sun-jdk/sun-jdk-1.4.0-r3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tools Team <tools@gentoo.org>
+# Author: Daniel Mettler <mettlerd@icu.unizh.ch>
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.0-r3.ebuild,v 1.1 2002/06/16 00:24:09 rphillips Exp $
+
+At="j2sdk-1_4_0_01-linux-i586.bin"
+S=${WORKDIR}/j2sdk1.4.0
+SRC_URI=""
+DESCRIPTION="Sun's J2SE Development Kit, version 1.4.0"
+HOMEPAGE="http://java.sun.com/j2se/1.4/download.html"
+
+DEPEND="virtual/glibc
+ >=dev-java/java-config-0.1.3"
+RDEPEND="$DEPEND"
+
+PROVIDE="virtual/jre-1.4
+ virtual/jdk-1.4
+ virtual/java-scheme-2"
+
+src_unpack() {
+ if [ ! -f ${DISTDIR}/${At} ] ; then
+ die "Please download ${At} from ${HOMEPAGE} (select the \"Linux GNUZIP Tar shell script\" package format of the SDK) and move it to ${DISTDIR}"
+ fi
+ tail +336 ${DISTDIR}/${At} > install.sfx
+ chmod +x install.sfx
+ ./install.sfx || die
+ rm install.sfx
+}
+
+src_install () {
+ local dirs="bin include jre lib"
+ dodir /opt/${P}
+
+
+ for i in $dirs ; do
+ cp -a $i ${D}/opt/${P}/
+ done
+
+ dodoc COPYRIGHT README LICENSE
+ dohtml README.html
+
+ doman man/man1/*.1
+
+ dodir /opt/${P}/share/
+ cp -a demo src.zip ${D}/opt/${P}/share/
+
+ if [ "`use mozilla`" ] ; then
+ dodir /usr/lib/mozilla/plugins
+ dosym /opt/${P}/jre/plugin/i386/ns610/libjavaplugin_oji140.so /usr/lib/mozilla/plugins/
+ fi
+
+ dodir /etc/env.d/java
+ sed \
+ -e "s/@P@/${P}/g" \
+ -e "s/@PV@/${PV}/g" \
+ -e "s/@PF@/${PF}/g" \
+ < ${FILESDIR}/sun-jdk-${PV} \
+ > ${D}/etc/env.d/java/20sun-jdk-${PV}
+}
+
+pkg_postinst () {
+ if [ "`use mozilla`" ] ; then
+ einfo "The Mozilla browser plugin has been installed as /usr/lib/mozilla/plugins/libjavaplugin_oji140.so"
+ else
+ einfo "To install the Java plugin for Mozilla manually, do:"
+ einfo "ln -s /opt/${P}/jre/plugin/i386/ns610/libjavaplugin_oji140.so /usr/lib/mozilla/plugins/"
+ einfo "(Make certain the directory /usr/lib/mozilla/plugins exists first)"
+ fi
+}