summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-09-02 02:26:51 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-09-02 02:26:51 +0000
commit3336f1b3094d5203a80413867e086f02f2e35ac8 (patch)
tree68c8e553dccedb2f435212e37a4aaa14a36be4af /dev-java/sun-jms/sun-jms-1.1-r2.ebuild
parentForgot to commit local use flags used by app-text/webgen (diff)
downloadgentoo-2-3336f1b3094d5203a80413867e086f02f2e35ac8.tar.gz
gentoo-2-3336f1b3094d5203a80413867e086f02f2e35ac8.tar.bz2
gentoo-2-3336f1b3094d5203a80413867e086f02f2e35ac8.zip
Revision bump to support the new Java system.
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'dev-java/sun-jms/sun-jms-1.1-r2.ebuild')
-rw-r--r--dev-java/sun-jms/sun-jms-1.1-r2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-java/sun-jms/sun-jms-1.1-r2.ebuild b/dev-java/sun-jms/sun-jms-1.1-r2.ebuild
new file mode 100644
index 000000000000..1131b356f4e0
--- /dev/null
+++ b/dev-java/sun-jms/sun-jms-1.1-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jms/sun-jms-1.1-r2.ebuild,v 1.1 2006/09/02 02:26:51 nichoj Exp $
+
+inherit java-pkg-2
+
+At="jms-${PV/./_}-fr-apidocs.zip"
+DESCRIPTION="The Java Message Service (JMS) API is a messaging standard that allows application components to create, send, receive, and read messages."
+HOMEPAGE="http://java.sun.com/products/jms/"
+SRC_URI="${At}"
+LICENSE="sun-bcla-jms"
+SLOT=0
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+RDEPEND=">=virtual/jre-1.3"
+DEPEND="app-arch/unzip
+ >=virtual/jdk-1.3"
+RESTRICT="fetch"
+
+S="${WORKDIR}/${PN//sun-/}${PV}"
+
+pkg_nofetch() {
+ einfo
+ einfo " Due to license restrictions, we cannot fetch the"
+ einfo " distributables automagically."
+ einfo
+ einfo " 1. Visit ${HOMEPAGE} and select 'Downloads'"
+ einfo " 2. Select 'Download the version 1.1 API Documentation, Jar and Source'"
+ einfo " 3. Download ${At}"
+ einfo " 4. Move file to ${DISTDIR}"
+ einfo
+}
+
+src_compile() {
+ mkdir build
+ cd src/share
+ ejavac -nowarn -d ${S}/build $(find -name "*.java") || die "failed too build"
+ if use doc ; then
+ mkdir ${S}/api
+ javadoc -d ${S}/api -quiet javax.jms
+ fi
+
+ cd ${S}
+ jar cf jms.jar -C build . || die "failed too create jar"
+}
+
+src_install() {
+ java-pkg_dojar jms.jar
+ use doc && java-pkg_dohtml -r api
+}
+