summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-10-18 20:22:25 +0000
committerAron Griffis <agriffis@gentoo.org>2005-10-18 20:22:25 +0000
commit924360744b63bc47157cd1a51863e4bba01fdb61 (patch)
treec61b3d8577718393a883c78adc6e398d76a4f357 /dev-java/sun-jre-bin
parentadd back browserplugin, marked as deprecated (diff)
downloadgentoo-2-924360744b63bc47157cd1a51863e4bba01fdb61.tar.gz
gentoo-2-924360744b63bc47157cd1a51863e4bba01fdb61.tar.bz2
gentoo-2-924360744b63bc47157cd1a51863e4bba01fdb61.zip
Warn about deprecated browserplugin useflag
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'dev-java/sun-jre-bin')
-rw-r--r--dev-java/sun-jre-bin/ChangeLog8
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild17
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild22
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.4.2.09.ebuild23
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.5.0.04.ebuild23
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.5.0.05.ebuild23
6 files changed, 69 insertions, 47 deletions
diff --git a/dev-java/sun-jre-bin/ChangeLog b/dev-java/sun-jre-bin/ChangeLog
index 4db5b42c9705..bfb56c5c9fc4 100644
--- a/dev-java/sun-jre-bin/ChangeLog
+++ b/dev-java/sun-jre-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/sun-jre-bin
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.33 2005/10/18 19:20:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.34 2005/10/18 20:22:25 agriffis Exp $
+
+ 18 Oct 2005; Aron Griffis <agriffis@gentoo.org>
+ sun-jre-bin-1.4.2.08.ebuild, sun-jre-bin-1.4.2.08-r1.ebuild,
+ sun-jre-bin-1.4.2.09.ebuild, sun-jre-bin-1.5.0.04.ebuild,
+ sun-jre-bin-1.5.0.05.ebuild:
+ Warn about deprecated browserplugin useflag
18 Oct 2005; Aron Griffis <agriffis@gentoo.org>
sun-jre-bin-1.4.2.08.ebuild, sun-jre-bin-1.4.2.08-r1.ebuild,
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild
index 5fe0d543321d..44503f078929 100644
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild,v 1.7 2005/10/18 19:20:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild,v 1.8 2005/10/18 20:22:25 agriffis Exp $
inherit java eutils
@@ -15,7 +15,7 @@ SLOT="1.4"
LICENSE="sun-bcla-java-vm-1.4.2"
KEYWORDS="-* x86"
RESTRICT="fetch"
-IUSE="nsplugin mozilla"
+IUSE="browserplugin nsplugin mozilla"
DEPEND=">=dev-java/java-config-1.1.5
sys-apps/sed"
@@ -85,7 +85,9 @@ src_install() {
dodoc CHANGES COPYRIGHT README LICENSE THIRDPARTYLICENSEREADME.txt
dohtml Welcome.html ControlPanel.html
- if use nsplugin || use mozilla; then
+ if use nsplugin || # global useflag for netscape-compat plugins
+ use browserplugin || # deprecated but honor for now
+ use mozilla; then # wrong but used to honor it
local plugin_dir="ns610"
if has_version '>=sys-devel/gcc-3.2' ; then
plugin_dir="ns610-gcc32"
@@ -155,9 +157,10 @@ pkg_postinst () {
eerror "Some parts of Sun's JDK require virtual/x11 to be installed."
eerror "Be careful which Java libraries you attempt to use."
- if ! use nsplugin && use mozilla; then
- ewarn
- ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'nsplugin' please update your USE"
+ if ! use nsplugin && ( use browserplugin || use mozilla ); then
+ echo
+ ewarn "The 'browserplugin' and 'mozilla' useflags will not be honored in"
+ ewarn "future jdk/jre ebuilds for plugin installation. Please"
+ ewarn "update your USE to include 'nsplugin'."
fi
}
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild
index 5568fcd17d48..3fa66efcfa4d 100644
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild,v 1.7 2005/10/18 19:20:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08.ebuild,v 1.8 2005/10/18 20:22:25 agriffis Exp $
inherit java eutils
@@ -15,7 +15,7 @@ SLOT="1.4"
LICENSE="sun-bcla-java-vm-1.4.2"
KEYWORDS="x86 -*"
RESTRICT="fetch"
-IUSE="nsplugin mozilla"
+IUSE="browserplugin nsplugin mozilla"
DEPEND=">=dev-java/java-config-1.1.5
sys-apps/sed"
@@ -78,7 +78,9 @@ src_install() {
dodoc CHANGES COPYRIGHT README LICENSE THIRDPARTYLICENSEREADME.txt
dohtml Welcome.html ControlPanel.html
- if use nsplugin || use mozilla; then
+ if use nsplugin || # global useflag for netscape-compat plugins
+ use browserplugin || # deprecated but honor for now
+ use mozilla; then # wrong but used to honor it
local plugin_dir="ns610"
if has_version '>=sys-devel/gcc-3.2' ; then
plugin_dir="ns610-gcc32"
@@ -112,7 +114,14 @@ pkg_postinst () {
java_pkg_postinst
- #Show info about netscape
+ if ! use nsplugin && ( use browserplugin || use mozilla ); then
+ echo
+ ewarn "The 'browserplugin' and 'mozilla' useflags will not be honored in"
+ ewarn "future jdk/jre ebuilds for plugin installation. Please"
+ ewarn "update your USE to include 'nsplugin'."
+ fi
+
+ # Show info about netscape
if has_version '>=www-client/netscape-navigator-4.79-r1' || has_version '>=www-client/netscape-communicator-4.79-r1' ; then
echo
einfo "If you want to install the plugin for Netscape 4.x, type"
@@ -147,9 +156,4 @@ pkg_postinst () {
echo
eerror "Some parts of Sun's JDK require virtual/x11 to be installed."
eerror "Be careful which Java libraries you attempt to use."
- if ! use nsplugin && use mozilla; then
- ewarn
- ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'nsplugin' please update your USE"
- fi
}
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.09.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.09.ebuild
index e27ec2451a87..c9a74127e420 100644
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.09.ebuild
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.09.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.09.ebuild,v 1.3 2005/10/18 19:20:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.09.ebuild,v 1.4 2005/10/18 20:22:25 agriffis Exp $
inherit java eutils
@@ -15,7 +15,7 @@ SLOT="1.4"
LICENSE="sun-bcla-java-vm-1.4.2"
KEYWORDS="-* ~x86"
RESTRICT="fetch"
-IUSE="nsplugin mozilla"
+IUSE="browserplugin nsplugin mozilla"
DEPEND=">=dev-java/java-config-1.1.5
sys-apps/sed"
@@ -85,7 +85,9 @@ src_install() {
dodoc CHANGES COPYRIGHT README LICENSE THIRDPARTYLICENSEREADME.txt
dohtml Welcome.html ControlPanel.html
- if use nsplugin || use mozilla; then
+ if use nsplugin || # global useflag for netscape-compat plugins
+ use browserplugin || # deprecated but honor for now
+ use mozilla; then # wrong but used to honor it
local plugin_dir="ns610"
if has_version '>=sys-devel/gcc-3.2' ; then
plugin_dir="ns610-gcc32"
@@ -119,7 +121,14 @@ pkg_postinst () {
java_pkg_postinst
- #Show info about netscape
+ if ! use nsplugin && ( use browserplugin || use mozilla ); then
+ echo
+ ewarn "The 'browserplugin' and 'mozilla' useflags will not be honored in"
+ ewarn "future jdk/jre ebuilds for plugin installation. Please"
+ ewarn "update your USE to include 'nsplugin'."
+ fi
+
+ # Show info about netscape
if has_version '>=www-client/netscape-navigator-4.79-r1' || has_version '>=www-client/netscape-communicator-4.79-r1' ; then
echo
einfo "If you want to install the plugin for Netscape 4.x, type"
@@ -154,10 +163,4 @@ pkg_postinst () {
echo
eerror "Some parts of Sun's JDK require virtual/x11 to be installed."
eerror "Be careful which Java libraries you attempt to use."
-
- if ! use nsplugin && use mozilla; then
- ewarn
- ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'nsplugin' please update your USE"
- fi
}
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.04.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.04.ebuild
index 48bb74c4c714..6c9cf9f36ac0 100644
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.04.ebuild
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.04.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.04.ebuild,v 1.7 2005/10/18 19:20:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.04.ebuild,v 1.8 2005/10/18 20:22:25 agriffis Exp $
inherit java eutils
@@ -24,7 +24,7 @@ SLOT="1.5"
LICENSE="sun-bcla-java-vm"
KEYWORDS="~x86 ~amd64 -*"
RESTRICT="fetch"
-IUSE="nsplugin mozilla"
+IUSE="browserplugin nsplugin mozilla"
DEPEND=">=dev-java/java-config-1.2
sys-apps/sed"
@@ -97,7 +97,9 @@ src_install() {
dodoc COPYRIGHT LICENSE README
dohtml Welcome.html
- if use nsplugin || use mozilla; then
+ if use nsplugin || # global useflag for netscape-compat plugins
+ use browserplugin || # deprecated but honor for now
+ use mozilla; then # wrong but used to honor it
local plugin_dir="ns7-gcc29"
if has_version '>=sys-devel/gcc-3' ; then
plugin_dir="ns7"
@@ -140,7 +142,14 @@ pkg_postinst() {
# Set as default VM if none exists
java_pkg_postinst
- #Show info about netscape
+ if ! use nsplugin && ( use browserplugin || use mozilla ); then
+ echo
+ ewarn "The 'browserplugin' and 'mozilla' useflags will not be honored in"
+ ewarn "future jdk/jre ebuilds for plugin installation. Please"
+ ewarn "update your USE to include 'nsplugin'."
+ fi
+
+ # Show info about netscape
if has_version '>=www-client/netscape-navigator-4.79-r1' || has_version '>=www-client/netscape-communicator-4.79-r1' ; then
echo
einfo "If you want to install the plugin for Netscape 4.x, type"
@@ -175,10 +184,4 @@ pkg_postinst() {
echo
eerror "Some parts of Sun's JRE require virtual/x11 and virtual/lpr to be installed."
eerror "Be careful which Java libraries you attempt to use."
-
- if ! use nsplugin && use mozilla; then
- ewarn
- ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'nsplugin' please update your USE"
- fi
}
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.05.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.05.ebuild
index 3d1eda1fb4a1..9a06b2677a96 100644
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.05.ebuild
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.05.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.05.ebuild,v 1.2 2005/10/18 19:20:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.05.ebuild,v 1.3 2005/10/18 20:22:25 agriffis Exp $
inherit java eutils
@@ -24,7 +24,7 @@ SLOT="1.5"
LICENSE="sun-bcla-java-vm"
KEYWORDS="~x86 ~amd64 -*"
RESTRICT="fetch"
-IUSE="nsplugin mozilla"
+IUSE="browserplugin nsplugin mozilla"
DEPEND=">=dev-java/java-config-1.2
sys-apps/sed"
@@ -105,7 +105,9 @@ src_install() {
dodoc COPYRIGHT LICENSE README
dohtml Welcome.html
- if use nsplugin || use mozilla; then
+ if use nsplugin || # global useflag for netscape-compat plugins
+ use browserplugin || # deprecated but honor for now
+ use mozilla; then # wrong but used to honor it
local plugin_dir="ns7-gcc29"
if has_version '>=sys-devel/gcc-3' ; then
plugin_dir="ns7"
@@ -148,7 +150,14 @@ pkg_postinst() {
# Set as default VM if none exists
java_pkg_postinst
- #Show info about netscape
+ if ! use nsplugin && ( use browserplugin || use mozilla ); then
+ echo
+ ewarn "The 'browserplugin' and 'mozilla' useflags will not be honored in"
+ ewarn "future jdk/jre ebuilds for plugin installation. Please"
+ ewarn "update your USE to include 'nsplugin'."
+ fi
+
+ # Show info about netscape
if has_version '>=www-client/netscape-navigator-4.79-r1' || has_version '>=www-client/netscape-communicator-4.79-r1' ; then
echo
einfo "If you want to install the plugin for Netscape 4.x, type"
@@ -183,10 +192,4 @@ pkg_postinst() {
echo
eerror "Some parts of Sun's JRE require virtual/x11 and virtual/lpr to be installed."
eerror "Be careful which Java libraries you attempt to use."
-
- if ! use nsplugin && use mozilla; then
- ewarn
- ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'nsplugin' please update your USE."
- fi
}