summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-17 11:19:53 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-17 11:19:53 +0000
commit7bc7ba9fc999b1f28901413a77436619bc79827b (patch)
tree01752381c5ecebf7890f18ca234309338246ca87 /dev-java/swt/swt-3.5.2.ebuild
parentRemove has_version check for dev-java/swt[xulrunner] wrt #409301. Correct elo... (diff)
downloadgentoo-2-7bc7ba9fc999b1f28901413a77436619bc79827b.tar.gz
gentoo-2-7bc7ba9fc999b1f28901413a77436619bc79827b.tar.bz2
gentoo-2-7bc7ba9fc999b1f28901413a77436619bc79827b.zip
Remove obsolete USE="xulrunner" and net-libs/xulrunner dependency since nothing is using it in tree and 3.7.x series has webkit replacement wrt #409299
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/swt/swt-3.5.2.ebuild')
-rw-r--r--dev-java/swt/swt-3.5.2.ebuild42
1 files changed, 3 insertions, 39 deletions
diff --git a/dev-java/swt/swt-3.5.2.ebuild b/dev-java/swt/swt-3.5.2.ebuild
index 82e9eb64cb56..0bdac2c61bf1 100644
--- a/dev-java/swt/swt-3.5.2.ebuild
+++ b/dev-java/swt/swt-3.5.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.5.2.ebuild,v 1.7 2011/03/29 09:17:56 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.5.2.ebuild,v 1.8 2012/04/17 11:19:53 ssuominen Exp $
EAPI=2
@@ -32,7 +32,7 @@ SLOT="3.5"
LICENSE="CPL-1.0 LGPL-2.1 MPL-1.1"
KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="cairo gnome opengl xulrunner"
+IUSE="cairo gnome opengl"
COMMON=">=dev-libs/glib-2.6
>=x11-libs/gtk+-2.6.8:2
>=dev-libs/atk-1.10.2
@@ -42,7 +42,6 @@ COMMON=">=dev-libs/glib-2.6
=gnome-base/gnome-vfs-2*
=gnome-base/libgnomeui-2*
)
- xulrunner? ( =net-libs/xulrunner-1.9* )
opengl? (
virtual/opengl
virtual/glu
@@ -139,28 +138,6 @@ src_compile() {
${make} make_gnome || die "Failed to build GNOME VFS support"
fi
- if use xulrunner ; then
- einfo "Building the Mozilla component against xulrunner-1.9"
-
- export MOZILLA_INCLUDES="$(pkg-config --cflags libxul libxul-embedding)"
- # the -R is a workaround for bug #234934
- export MOZILLA_LIBS="-Wl,-R$(pkg-config libxul --variable=sdkdir) $(pkg-config --libs libxul libxul-embedding)"
-
- ${make} make_mozilla || die "Failed to build Mozilla support"
-
- # upstream ships libswt-xulrunner*.so even though the build.sh does not
- # build it anymore... missing this file leads to another instance
- # of bug #234934 so we build it too
- einfo "Building the xulrunner component against xulrunner-1.9"
-
- export XULRUNNER_INCLUDES="${MOZILLA_INCLUDES}"
- export XULRUNNER_LIBS="${MOZILLA_LIBS}"
-
- ${make} make_xulrunner || die "Failed to build xulrunner support"
-
- ${make} make_xpcominit || die "Failed to build xpcominit support"
- fi
-
if use cairo ; then
einfo "Building CAIRO support"
${make} make_cairo || die "Unable to build CAIRO support"
@@ -194,18 +171,5 @@ src_install() {
java-pkg_sointo /usr/$(get_libdir)
java-pkg_doso *.so
- if use xulrunner; then
- local gecko_dir="$(pkg-config libxul --variable=sdkdir)"
- java-pkg_register-environment-variable MOZILLA_FIVE_HOME "${gecko_dir}"
- fi
-
dohtml about.html || die
}
-
-pkg_postinst() {
- if use xulrunner; then
- local gecko_dir="$(pkg-config libxul --variable=sdkdir)"
- elog "You built swt with xulrunner support. For your custom applications please set"
- elog "MOZILLA_FIVE_HOME environment variable to ${gecko_dir}"
- fi
-}