summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-05-07 07:07:09 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-05-07 07:07:09 +0000
commit49e30f300d9ebab06c7255ecc58ebc6fb8859478 (patch)
treea10a14e1ac5f18e411225c0835b1d689c5bcf5c0 /dev-java/swt
parentRemoving maintainer (diff)
downloadgentoo-2-49e30f300d9ebab06c7255ecc58ebc6fb8859478.tar.gz
gentoo-2-49e30f300d9ebab06c7255ecc58ebc6fb8859478.tar.bz2
gentoo-2-49e30f300d9ebab06c7255ecc58ebc6fb8859478.zip
version bump from upstream
(Portage version: 2.1_pre10-r3)
Diffstat (limited to 'dev-java/swt')
-rw-r--r--dev-java/swt/ChangeLog7
-rw-r--r--dev-java/swt/files/digest-swt-3.2_rc29
-rw-r--r--dev-java/swt/swt-3.2_rc2.ebuild157
3 files changed, 172 insertions, 1 deletions
diff --git a/dev-java/swt/ChangeLog b/dev-java/swt/ChangeLog
index fbd5b83d4150..fe4780317763 100644
--- a/dev-java/swt/ChangeLog
+++ b/dev-java/swt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/swt
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/ChangeLog,v 1.33 2006/02/04 06:06:05 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/ChangeLog,v 1.34 2006/05/07 07:07:09 compnerd Exp $
+
+*swt-3.2_rc2 (07 May 2006)
+
+ 07 May 2006; Saleem Abdulrasool <compnerd@gentoo.org> +swt-3.2_rc2.ebuild:
+ Version bump from upstream
04 Feb 2006; Saleem Abdulrasool <compnerd@gentoo.org> swt-3.1-r1.ebuild,
swt-3.2_pre1.ebuild:
diff --git a/dev-java/swt/files/digest-swt-3.2_rc2 b/dev-java/swt/files/digest-swt-3.2_rc2
new file mode 100644
index 000000000000..418b9117b6ff
--- /dev/null
+++ b/dev-java/swt/files/digest-swt-3.2_rc2
@@ -0,0 +1,9 @@
+MD5 88f0b44c44fa145a3bc9cb92e50836fd swt-3.2RC2-gtk-linux-ppc.zip 2902121
+RMD160 43b4e79796a2ae6b0726b7713b9267228cce5f29 swt-3.2RC2-gtk-linux-ppc.zip 2902121
+SHA256 0e5ca130872c9e9ad61a59cf35d4031198eb12e2a97c5edd44e382fff8c460e9 swt-3.2RC2-gtk-linux-ppc.zip 2902121
+MD5 e1b465bee8b7fc8cdc059e93861af799 swt-3.2RC2-gtk-linux-x86.zip 2925435
+RMD160 9b9f96c9cd3bf0be7fbf48fb5e214b712552bc10 swt-3.2RC2-gtk-linux-x86.zip 2925435
+SHA256 c7f9bb6f1d6a019ffdc9dc0c486fd7f6d0eed1b528cbb05eb71468d403ac34e4 swt-3.2RC2-gtk-linux-x86.zip 2925435
+MD5 a4dfa2251062ae21112a7ea4a07650c7 swt-3.2RC2-gtk-linux-x86_64.zip 2828002
+RMD160 65246c119a51567fb0e1ac308536d4e50218a256 swt-3.2RC2-gtk-linux-x86_64.zip 2828002
+SHA256 a39d7c62ab76fe73422bf1128dba7ae2e3d210c3a395d922a87c1872c33f8a6f swt-3.2RC2-gtk-linux-x86_64.zip 2828002
diff --git a/dev-java/swt/swt-3.2_rc2.ebuild b/dev-java/swt/swt-3.2_rc2.ebuild
new file mode 100644
index 000000000000..af86f512c802
--- /dev/null
+++ b/dev-java/swt/swt-3.2_rc2.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.2_rc2.ebuild,v 1.1 2006/05/07 07:07:09 compnerd Exp $
+
+inherit eutils java-pkg
+
+MY_DMF="S-3.2RC2-200604281315"
+MY_VERSION="3.2RC2"
+
+DESCRIPTION="GTK based SWT Library"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="x86? ( http://download.eclipse.org/downloads/drops/${MY_DMF}/swt-${MY_VERSION}-gtk-linux-x86.zip )
+ amd64? ( http://download.eclipse.org/downloads/drops/${MY_DMF}/swt-${MY_VERSION}-gtk-linux-x86_64.zip )
+ ppc? ( http://download.eclipse.org/downloads/drops/${MY_DMF}/swt-${MY_VERSION}-gtk-linux-ppc.zip )"
+
+SLOT="3"
+LICENSE="CPL-1.0 LGPL-2.1 MPL-1.1"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="accessibility cairo gnome mozilla opengl"
+COMMON=">=dev-libs/glib-2.6
+ >=x11-libs/gtk+-2.6.8
+ accessibility? ( >=dev-libs/atk-1.10.2 )
+ || (
+ (
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+ virtual/x11
+ )
+ cairo? ( >=x11-libs/cairo-1.0.2 )
+ gnome? (
+ =gnome-base/libgnome-2*
+ =gnome-base/gnome-vfs-2*
+ =gnome-base/libgnomeui-2*
+ )
+ mozilla? ( >=net-libs/gecko-sdk-1.7 )
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON}
+ >=dev-util/pkgconfig-0.9
+ dev-java/ant-core
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unzip -jq "${DISTDIR}/${A}" "*src.zip" || die "unable to extract distfile"
+
+ # Unpack the sources
+ einfo "Unpacking src.zip to ${S}"
+ unzip -q src.zip || die "Unable to extract sources"
+
+ # Cleanup the redirtied directory structure
+ rm -rf about_files/
+ rm -f .classpath .project
+
+ # Replace the build.xml to allow compilation without Eclipse tasks
+ cp ${FILESDIR}/build.xml ${S}/build.xml || die "Unable to update build.xml"
+ mkdir ${S}/src && mv ${S}/org ${S}/src || die "Unable to restructure SWT sources"
+}
+
+src_compile() {
+ JAVA_HOME=$(java-config -O)
+
+ # Identify the AWT path
+ # The IBM VMs and the GNU GCC implementations do not store the AWT libraries
+ # in the same location as the rest of the binary VMs.
+ if [[ ! -z "$(java-config --java-version | grep 'IBM')" ]] ; then
+ export AWT_LIB_PATH=$JAVA_HOME/jre/bin
+ elif [[ ! -z "$(java-config --java-version | grep 'GNU libgcj')" ]] ; then
+ export AWT_LIB_PATH=$JAVA_HOME/$(get_libdir)
+ else
+ if [[ ${ARCH} == 'x86' ]] ; then
+ export AWT_LIB_PATH=$JAVA_HOME/jre/lib/i386
+ elif [[ ${ARCH} == 'ppc' ]] ; then
+ export AWT_LIB_PATH=$JAVA_HOME/jre/lib/ppc
+ else
+ export AWT_LIB_PATH=$JAVA_HOME/jre/lib/amd64
+ fi
+ fi
+
+ # Fix the GTK+ Library path
+ export GTKLIBS="$(pkg-config --libs-only-L gtk+-2.0 gthread-2.0) -lgtk-x11-2.0 -lgthread-2.0 -L/usr/$(get_libdir)/X11 -lXtst"
+
+ # Fix the pointer size for AMD64
+ [[ ${ARCH} == 'amd64' ]] && export SWT_PTR_CFLAGS=-DSWT_PTR_SIZE_64
+
+ einfo "Building AWT library"
+ emake -f make_linux.mak make_awt || die "Failed to build AWT support"
+
+ einfo "Building SWT library"
+ emake -f make_linux.mak make_swt || die "Failed to build SWT support"
+
+ if use accessibility ; then
+ einfo "Building JAVA-AT-SPI bridge"
+ emake -f make_linux.mak make_atk || die "Failed to build ATK support"
+ fi
+
+ if use gnome ; then
+ einfo "Building GNOME VFS support"
+ emake -f make_linux.mak make_gnome || die "Failed to build GNOME VFS support"
+ fi
+
+ if use mozilla ; then
+ export GECKO_INCLUDES="$(gecko-sdk-config --cflags)"
+
+ einfo "Building the Mozilla component"
+ emake -f make_linux.mak make_mozilla || die "Failed to build Mozilla support"
+ fi
+
+ if use cairo ; then
+ einfo "Building CAIRO support"
+ emake -f make_linux.mak make_cairo || die "Unable to build CAIRO support"
+ fi
+
+ if use opengl ; then
+ einfo "Building OpenGL component"
+ emake -f make_linux.mak make_glx || die "Unable to build OpenGL component"
+ fi
+
+ einfo "Building JNI libraries"
+ ant compile || die "Failed to compile JNI interfaces"
+
+ einfo "Creating missing files"
+ cp ${FILESDIR}/SWTMessages.properties ${S}/build/org/eclipse/swt/internal/
+ echo -n "version 3.231" >> ${S}/build/version.txt
+
+ einfo "Packing JNI libraries"
+ ant jar || die "Failed to create JNI jar"
+}
+
+src_install() {
+ java-pkg_dojar swt.jar
+
+ java-pkg_sointo /usr/$(get_libdir)
+ java-pkg_doso *.so
+
+ dohtml about.html
+}
+
+pkg_postinst() {
+ if use cairo; then
+ ewarn
+ ewarn "CAIRO Support is experimental! We are not responsible if"
+ ewarn "enabling support for CAIRO corrupts your Gentoo install,"
+ ewarn "if it blows up your computer, or if it becomes sentient"
+ ewarn "and chases you down the street yelling random binary!"
+ ewarn
+ ebeep 5
+ fi
+}