summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2006-12-20 21:11:53 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2006-12-20 21:11:53 +0000
commit033babe916ca87ad2463965e643037398d27b8ea (patch)
tree77be66396e70d228d915bc8c2cc531e28c3b020b /dev-java/tagsoup
parentReadded ~x86-fbsd keyword since dazuko-2.3.2-r2 is keyworded (diff)
downloadgentoo-2-033babe916ca87ad2463965e643037398d27b8ea.tar.gz
gentoo-2-033babe916ca87ad2463965e643037398d27b8ea.tar.bz2
gentoo-2-033babe916ca87ad2463965e643037398d27b8ea.zip
Moved the very long description to metadata.xml and cleaned up the ebuild.
(Portage version: 2.1.2_rc3-r6)
Diffstat (limited to 'dev-java/tagsoup')
-rw-r--r--dev-java/tagsoup/ChangeLog6
-rw-r--r--dev-java/tagsoup/metadata.xml6
-rw-r--r--dev-java/tagsoup/tagsoup-0.10.2-r1.ebuild14
3 files changed, 18 insertions, 8 deletions
diff --git a/dev-java/tagsoup/ChangeLog b/dev-java/tagsoup/ChangeLog
index bf736f14fc6a..484b9529a28a 100644
--- a/dev-java/tagsoup/ChangeLog
+++ b/dev-java/tagsoup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/tagsoup
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tagsoup/ChangeLog,v 1.11 2006/12/09 09:25:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tagsoup/ChangeLog,v 1.12 2006/12/20 21:11:53 betelgeuse Exp $
+
+ 20 Dec 2006; Petteri Räty <betelgeuse@gentoo.org> metadata.xml,
+ tagsoup-0.10.2-r1.ebuild:
+ Moved the very long description to metadata.xml and cleaned up the ebuild.
09 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
tagsoup-0.10.2-r1.ebuild:
diff --git a/dev-java/tagsoup/metadata.xml b/dev-java/tagsoup/metadata.xml
index 7303cef96964..4618b26cc2d8 100644
--- a/dev-java/tagsoup/metadata.xml
+++ b/dev-java/tagsoup/metadata.xml
@@ -2,4 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>java</herd>
+ <longdescription>
+ This is the home page of TagSoup, a SAX-compliant parser written
+ in Java that, instead of parsing well-formed or valid XML, parses
+ HTML as it is found in the wild: nasty and brutish, though quite
+ often far from short.
+ </longdescription>
</pkgmetadata>
diff --git a/dev-java/tagsoup/tagsoup-0.10.2-r1.ebuild b/dev-java/tagsoup/tagsoup-0.10.2-r1.ebuild
index 78ed2a5fb4ff..a5d7fd1f8501 100644
--- a/dev-java/tagsoup/tagsoup-0.10.2-r1.ebuild
+++ b/dev-java/tagsoup/tagsoup-0.10.2-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tagsoup/tagsoup-0.10.2-r1.ebuild,v 1.3 2006/12/09 09:25:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tagsoup/tagsoup-0.10.2-r1.ebuild,v 1.4 2006/12/20 21:11:53 betelgeuse Exp $
inherit java-pkg-2 java-ant-2
-DESCRIPTION="This is the home page of TagSoup, a SAX-compliant parser written in Java that, instead of parsing well-formed or valid XML, parses HTML as it is found in the wild: nasty and brutish, though quite often far from short."
+DESCRIPTION="A SAX-compliant parser written in Java."
HOMEPAGE="http://mercury.ccil.org/~cowan/XML/tagsoup/"
SRC_URI="http://mercury.ccil.org/~cowan/XML/tagsoup/${P}-src.zip"
@@ -12,6 +12,8 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
IUSE="doc source"
+
+# Needs the xslt task so full ant here
DEPEND=">=virtual/jdk-1.4
app-arch/unzip
dev-java/ant
@@ -19,15 +21,13 @@ DEPEND=">=virtual/jdk-1.4
RDEPEND=">=virtual/jre-1.4"
src_compile() {
- local antflags="dist"
- use doc && antflags="${antflags} docs-api"
- eant ${antflags} || die "compile failed"
+ eant $(use_doc docs-api) dist
}
src_install() {
java-pkg_newjar dist/lib/${P}.jar ${PN}.jar
dodoc CHANGES README TODO
- use doc && java-pkg_dohtml -r docs/*
- use source && java-pkg_dosrc src/java/*
+ use doc && java-pkg_dojavadoc docs/api
+ use source && java-pkg_dosrc src/{java,templates}/*
}