summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-03-17 00:07:53 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-03-17 00:07:53 +0000
commit07e145c3199bb97b565bfb4e3fafcc3c26a8119d (patch)
treedf322b7e99e0500ea0854e3c505604f3cbe510ca /dev-java/velocity
parentPowerbook integrated usb modem drivers (diff)
downloadgentoo-2-07e145c3199bb97b565bfb4e3fafcc3c26a8119d.tar.gz
gentoo-2-07e145c3199bb97b565bfb4e3fafcc3c26a8119d.tar.bz2
gentoo-2-07e145c3199bb97b565bfb4e3fafcc3c26a8119d.zip
Initial import.
Diffstat (limited to 'dev-java/velocity')
-rw-r--r--dev-java/velocity/ChangeLog16
-rw-r--r--dev-java/velocity/files/digest-velocity-1.31
-rw-r--r--dev-java/velocity/velocity-1.3.ebuild50
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-java/velocity/ChangeLog b/dev-java/velocity/ChangeLog
new file mode 100644
index 000000000000..c69336bfe107
--- /dev/null
+++ b/dev-java/velocity/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for dev-java/velocity
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/velocity/ChangeLog,v 1.1 2003/03/17 00:07:53 absinthe Exp $
+
+*velocity-1.3 (16 Mar 2003)
+
+ 16 Mar 2003; Dylan Carlson <absinthe@gentoo.org> velocity-1.3.ebuild:
+ Initial import.
+
+ Velocity is a Java-based template engine, a simple and powerful development
+ tool that allows you to easily create and render documents that format and
+ present your data, focusing on two main areas of usage:
+
+ * servlet-based WWW development
+ * general application use
+
diff --git a/dev-java/velocity/files/digest-velocity-1.3 b/dev-java/velocity/files/digest-velocity-1.3
new file mode 100644
index 000000000000..9e9462d20082
--- /dev/null
+++ b/dev-java/velocity/files/digest-velocity-1.3
@@ -0,0 +1 @@
+MD5 92df23ed5883f338d62420c14d0f7223 velocity-1.3.tar.gz 4480210
diff --git a/dev-java/velocity/velocity-1.3.ebuild b/dev-java/velocity/velocity-1.3.ebuild
new file mode 100644
index 000000000000..a212be057b75
--- /dev/null
+++ b/dev-java/velocity/velocity-1.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/velocity/velocity-1.3.ebuild,v 1.1 2003/03/17 00:07:53 absinthe Exp $
+
+DESCRIPTION="A Java-based template engine that allows easy creation/rendering of documents that format and present data."
+HOMEPAGE="http://jakarta.apache.org/velocity/"
+SRC_URI="http://jakarta.apache.org/builds/jakarta-${PN}/release/v${PV}/${PN}-${PV}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="jikes j2ee doc"
+
+DEPEND=">=dev-java/sun-jdk-1.3.1"
+RDEPEND=">=dev-java/sun-jdk-1.3.1
+ >=dev-java/ant-1.5.1
+ >=dev-java/avalon-logkit-1.2
+ >=dev-java/oro-2.0.6
+ j2ee? ( =dev-java/sun-j2ee-1.3.1 )
+ jikes? ( >=dev-java/jikes-1.17 )"
+
+src_compile () {
+ cd ${S}/build
+ local myc
+ if [ -n "`use jikes`" ] ; then
+ myc="${myc} -Dbuild.compiler=jikes"
+ fi
+
+ if [ -n "`use j2ee`" ] ; then
+ cp /opt/sun-j2ee-1.3.1/lib/j2ee.jar ${S}/build/lib
+ ANT_OPTS=${myc} ant jar-J2EE || die "Java compile failed."
+ else
+ ANT_OPTS=${myc} ant jar || die "Java compile failed"
+ fi
+
+ if [ -n "`use doc`" ] ; then
+ ant javadocs || die "Document compile failed"
+ fi
+}
+
+src_install () {
+ cd ${S}
+ if [ -n "`use j2ee`" ] ; then
+ dojar bin/${PN}-J2EE-${PV}.jar
+ else
+ dojar bin/${PN}-${PV}.jar
+ fi
+ dodoc LICENSE.txt README.txt
+ use doc && dohtml -r docs/*
+}