summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Almenar <strider@gentoo.org>2002-12-02 22:41:32 +0000
committerAdrian Almenar <strider@gentoo.org>2002-12-02 22:41:32 +0000
commit1a185fdd5b4a3ee2927ee7bb4d89e366516a774d (patch)
treea1d0f9fc46052163f60d197e233df7487c9e82c2 /dev-java/xalan
parentUnmask x86 (diff)
downloadgentoo-2-1a185fdd5b4a3ee2927ee7bb4d89e366516a774d.tar.gz
gentoo-2-1a185fdd5b4a3ee2927ee7bb4d89e366516a774d.tar.bz2
gentoo-2-1a185fdd5b4a3ee2927ee7bb4d89e366516a774d.zip
- Changed Detection of jdk if >=virtual/jdk-1.4 It doesnt build
javadocs. - Added pkg_postinst() with the URL to API for users with last line problem. - Reordered the ebuild so it can be read better. - Added code for jars that come with xalan can get into build classpath. - Removed all jikes code.
Diffstat (limited to 'dev-java/xalan')
-rw-r--r--dev-java/xalan/ChangeLog8
-rw-r--r--dev-java/xalan/xalan-2.4.1.ebuild29
2 files changed, 22 insertions, 15 deletions
diff --git a/dev-java/xalan/ChangeLog b/dev-java/xalan/ChangeLog
index 60ff3468418c..c75648c01d97 100644
--- a/dev-java/xalan/ChangeLog
+++ b/dev-java/xalan/ChangeLog
@@ -1,9 +1,15 @@
# ChangeLog for dev-java/xalan
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xalan/ChangeLog,v 1.6 2002/11/26 04:30:22 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xalan/ChangeLog,v 1.7 2002/12/02 22:41:32 strider Exp $
*xalan-2.4.1 (01 Nov 2002)
+ 02 Dec 2002; Adrian Almenar <strider@gentoo.org> xalan-2.4.1.ebuild:
+ Changed Detection of jdk if >=virtual/jdk-1.4 It doesnt build javadocs.
+ Added pkg_postinst() with the URL to API for users with last line problem.
+ Reordered the ebuild so it can be read better. Added code for jars that
+ come with xalan can get into build classpath. Removed all jikes code.
+
26 Nov 2002; Adrian Almenar <strider@gentoo.org> xalan-2.4.1.ebuild:
This ebuild doesnt compile well with jikes. Also to create xdocs i needed to
use virtualx.class cause needs to connect to xserver. Removed generation
diff --git a/dev-java/xalan/xalan-2.4.1.ebuild b/dev-java/xalan/xalan-2.4.1.ebuild
index 4c953a1a67fb..19ddd071d639 100644
--- a/dev-java/xalan/xalan-2.4.1.ebuild
+++ b/dev-java/xalan/xalan-2.4.1.ebuild
@@ -1,35 +1,32 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xalan/xalan-2.4.1.ebuild,v 1.2 2002/11/26 04:30:22 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xalan/xalan-2.4.1.ebuild,v 1.3 2002/12/02 22:41:32 strider Exp $
inherit virtualx
+S=${WORKDIR}/${PN}-j_2_4_1
DESCRIPTION="XSLT processor"
HOMEPAGE="http://xml.apache.org/xalan-j/index.html"
+SRC_URI="http://xml.apache.org/dist/xalan-j/${PN}-j_2_4_1-src.tar.gz"
LICENSE="Apache-1.1"
-DEPEND=">=virtual/jdk-1.4
+DEPEND=">=virtual/jdk-1.3
>=dev-java/ant-1.4.1
- >=dev-java/xerces-2.2.0
- jikes? ( >=dev-java/jikes-1.16 )"
+ >=dev-java/xerces-2.2.0"
RDEPEND="$DEPEND"
-SRC_URI="http://xml.apache.org/dist/xalan-j/${PN}-j_2_4_1-src.tar.gz"
-S=${WORKDIR}/${PN}-j_2_4_1
-LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~x86"
-#IUSE="jikes"
IUSE=""
src_compile() {
-# local myc
export maketype="ant"
-
-# FIXME: Compiling with Jikes does not work properly yet.
-# use jikes && \
-# myc="${myc} -Dbuild.compiler=jikes" ||
-# myc="${myc} -Dbuild.compiler=classic"
+ CP=`echo bin/*.jar | tr " " ":"`
+ export CLASSPATH=$CLASSPATH:$CP
virtualmake jar docs ${myc} || die "build failed"
+
+ if [ `java-config --java-version 2>&1 | grep "1\.4\." | wc -l` -lt 1 ] ; then
+ virtualmake javadocs || die "Build Javadocs Failed"
+ fi
}
src_install () {
@@ -37,3 +34,7 @@ src_install () {
dohtml readme.html
dohtml -r build/docs/*
}
+
+pkg_postinst() {
+ einfo "API Docs: http://xml.apache.org/xalan-j/apidocs/index.html"
+}