summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2005-08-06 18:03:31 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2005-08-06 18:03:31 +0000
commit188405379d3d50936c6e1a22f0d0da285b0d4ee0 (patch)
tree3ceb1a564552eae8589067f2f8c9092db75a0d12 /dev-java
parentcleanup (diff)
downloadgentoo-2-188405379d3d50936c6e1a22f0d0da285b0d4ee0.tar.gz
gentoo-2-188405379d3d50936c6e1a22f0d0da285b0d4ee0.tar.bz2
gentoo-2-188405379d3d50936c6e1a22f0d0da285b0d4ee0.zip
Fixing the way we find the library path for Gecko. Fixes bug 100015
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/swt/ChangeLog8
-rw-r--r--dev-java/swt/Manifest12
-rw-r--r--dev-java/swt/files/digest-swt-3.1-r13
-rw-r--r--dev-java/swt/swt-3.1-r1.ebuild173
4 files changed, 185 insertions, 11 deletions
diff --git a/dev-java/swt/ChangeLog b/dev-java/swt/ChangeLog
index 3462012453d5..aed8c218f91a 100644
--- a/dev-java/swt/ChangeLog
+++ b/dev-java/swt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/swt
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/ChangeLog,v 1.21 2005/07/06 03:19:17 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/ChangeLog,v 1.22 2005/08/06 18:03:31 compnerd Exp $
+
+*swt-3.1-r1 (06 Aug 2005)
+
+ 06 Aug 2005; Saleem Abdulrasool <compnerd@gentoo.org> +swt-3.1-r1.ebuild:
+ Fix dependencies, change the way the Gecko libraries are found so as to
+ prevent future breaking when changes occur.
05 Jul 2005; Saleem Abdulrasool <compnerd@gentoo.org> swt-3.1_pre7.ebuild:
Backporting IBM JDK fix to _pre7
diff --git a/dev-java/swt/Manifest b/dev-java/swt/Manifest
index 4bcc859c986a..2e64bf5e0648 100644
--- a/dev-java/swt/Manifest
+++ b/dev-java/swt/Manifest
@@ -1,19 +1,11 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 a3746d6afa6525ff0c3da076122f93b4 swt-3.1-r1.ebuild 5293
MD5 ef2bafc13ebd43092f673c3c44907785 ChangeLog 3843
MD5 4dcb6dd494f5e369aed5a367e303aef4 metadata.xml 433
MD5 76eb2c89532870f7e90b064d8f26d739 swt-3.1.ebuild 5202
MD5 c964f0ff0b83afdfd76d872821540574 files/build-3.1_pre7.xml 476
MD5 ad4aa305806513ab198281b6e485fbbc files/SWTMessages.properties 2085
MD5 bb61f479853836959ad766e10161e80a files/build.xml 2106
+MD5 4d4ba9daee2ceef312b8e18be3ab70ed files/digest-swt-3.1-r1 216
MD5 c964f0ff0b83afdfd76d872821540574 files/build-3.1.xml 476
MD5 f33d8fd0bacf2ed4f835b70f6f7836b4 files/cairo.patch 302
MD5 4d4ba9daee2ceef312b8e18be3ab70ed files/digest-swt-3.1 216
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFC2+zg/rLF9B432nYRArigAJ9J354DscqUYAr9S/fuOolbs7NumACgpkO5
-ahRmsv82xmZ/zH+F6TjQaj0=
-=6gSB
------END PGP SIGNATURE-----
diff --git a/dev-java/swt/files/digest-swt-3.1-r1 b/dev-java/swt/files/digest-swt-3.1-r1
new file mode 100644
index 000000000000..21e67436fa42
--- /dev/null
+++ b/dev-java/swt/files/digest-swt-3.1-r1
@@ -0,0 +1,3 @@
+MD5 a7d5f5f593e423f9aec7713c548f3817 swt-3.1-gtk-linux-x86.zip 2643472
+MD5 37907f265059d9853911fc9538743280 swt-3.1-gtk-linux-x86_64.zip 2702033
+MD5 6fa2922701a0e360e0035fd0363fcae8 swt-3.1-gtk-linux-ppc.zip 2525054
diff --git a/dev-java/swt/swt-3.1-r1.ebuild b/dev-java/swt/swt-3.1-r1.ebuild
new file mode 100644
index 000000000000..c9fc9fc99f9e
--- /dev/null
+++ b/dev-java/swt/swt-3.1-r1.ebuild
@@ -0,0 +1,173 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.1-r1.ebuild,v 1.1 2005/08/06 18:03:31 compnerd Exp $
+
+inherit eutils java-pkg
+
+MY_DMF="R-3.1-200506271435"
+MY_VERSION="3.1"
+
+DESCRIPTION="GTK based SWT Library"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="x86? ( http://download.eclipse.org/downloads/drops/${MY_DMF}/swt-${MY_VERSION}-gtk-linux-x86.zip )
+ amd64? ( http://download.eclipse.org/downloads/drops/${MY_DMF}/swt-${MY_VERSION}-gtk-linux-x86_64.zip )
+ ppc? ( http://download.eclipse.org/downloads/drops/${MY_DMF}/swt-${MY_VERSION}-gtk-linux-ppc.zip )"
+
+SLOT="3"
+LICENSE="CPL-1.0 LGPL-2.1 MPL-1.1"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+IUSE="accessibility cairo firefox gnome mozilla"
+RDEPEND=">=virtual/jre-1.4
+ mozilla? (
+ firefox? ( >=www-client/mozilla-firefox-1.0.3 )
+ !firefox? ( >=www-client/mozilla-1.4 )
+ )
+ gnome? ( =gnome-base/gnome-vfs-2* =gnome-base/libgnomeui-2* )
+ cairo? ( >=x11-libs/cairo-0.3.0 )"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}
+ dev-util/pkgconfig
+ dev-java/ant-core
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ if use firefox ; then
+ if ! use mozilla ; then
+ echo
+ ewarn "You must enable the mozilla useflag to build the browser"
+ ewarn "component. The firefox flag is used only to determine"
+ ewarn "what to build against."
+
+ die "Firefox useflag enabled without mozilla support"
+ fi
+ fi
+}
+
+src_unpack() {
+ # Extract based on architecture
+ if [[ ${ARCH} == 'amd64' ]] ; then
+ unpack swt-${MY_VERSION}-gtk-linux-x86_64.zip || die "Unable to unpack sources"
+ elif [[ ${ARCH} == 'ppc' ]] ; then
+ unpack swt-${MY_VERSION}-gtk-linux-ppc.zip || die "Unable to unpack sources"
+ else
+ unpack swt-${MY_VERSION}-gtk-linux-x86.zip || die "Unable to unpack sources"
+ fi
+
+ # Clean up the directory structure
+ for f in $(ls); do
+ if [[ "${f}" != "src.zip" ]] ; then
+ rm -rf ${f}
+ fi
+ done
+
+ # Unpack the sources
+ echo "Unpacking src.zip to ${S}"
+ unzip src.zip &> /dev/null || die "Unable to extract sources"
+
+ # Cleanup the redirtied directory structure
+ rm -rf about_files/
+ rm -f .classpath .project
+
+ # Replace the build.xml to allow compilation without Eclipse tasks
+ cp ${FILESDIR}/build-${PV}.xml ${S}/build.xml || die "Unable to update build.xml"
+ mkdir ${S}/src && mv ${S}/org ${S}/src || die "Unable to restructure SWT sources"
+}
+
+src_compile() {
+ JAVA_HOME=$(java-config -O)
+
+ # Identify the AWT path
+ if [[ ! -z "$(java-config --java-version | grep 'IBM')" ]] ; then
+ export AWT_LIB_PATH=$JAVA_HOME/jre/bin
+ else
+ if [[ ${ARCH} == 'x86' ]] ; then
+ export AWT_LIB_PATH=$JAVA_HOME/jre/lib/i386
+ elif [[ ${ARCH} == 'ppc' ]] ; then
+ export AWT_LIB_PATH=$JAVA_HOME/jre/lib/ppc
+ else
+ export AWT_LIB_PATH=$JAVA_HOME/jre/lib/amd64
+ fi
+ fi
+
+ # Identity the XTEST library location
+ export XTEST_LIB_PATH=/usr/X11R6/lib
+
+ # Fix the pointer size for AMD64
+ [[ ${ARCH} == 'amd64' ]] && export SWT_PTR_CFLAGS=-DSWT_PTR_SIZE_64
+
+ einfo "Building AWT library"
+ emake -f make_linux.mak make_awt || die "Failed to build AWT support"
+
+ einfo "Building SWT library"
+ emake -f make_linux.mak make_swt || die "Failed to build SWT support"
+
+ if use accessibility ; then
+ einfo "Building JAVA-AT-SPI bridge"
+ emake -f make_linux.mak make_atk || die "Failed to build ATK support"
+ fi
+
+ if use gnome ; then
+ einfo "Building GNOME VFS support"
+ emake -f make_linux.mak make_gnome || die "Failed to build GNOME VFS support"
+ fi
+
+ if use mozilla ; then
+ if use firefox ; then
+ GECKO_SDK="$(pkg-config firefox-xpcom --variable=libdir)"
+ else
+ GECKO_SDK="$(pkg-config mozilla-xpcom --variable=libdir)"
+ fi
+
+ export GECKO_INCLUDES="-include ${GECKO_SDK}/include/mozilla-config.h \
+ -I${GECKO_SDK}/include \
+ -I${GECKO_SDK}/include/java \
+ -I${GECKO_SDK}/include/nspr -I${GECKO_SDK}/include/nspr/include \
+ -I${GECKO_SDK}/include/xpcom -I${GECKO_SDK}/include/xpcom/include \
+ -I${GECKO_SDK}/include/string -I${GECKO_SDK}/include/string/include \
+ -I${GECKO_SDK}/include/embed_base -I${GECKO_SDK}/include/embed_base/include \
+ -I${GECKO_SDK}/include/embedstring -I${GECKO_SDK}/include/embedstring/include"
+ export GECKO_LIBS="-L${GECKO_SDK} -lgtkembedmoz"
+
+ einfo "Building the Mozilla component"
+ emake -f make_linux.mak make_mozilla || die "Failed to build Mozilla support"
+ fi
+
+ if use cairo ; then
+ einfo "Building CAIRO support"
+ emake -f make_linux.mak make_cairo || die "Unable to build CAIRO support"
+ fi
+
+ einfo "Building JNI libraries"
+ ant compile || die "Failed to compile JNI interfaces"
+
+ einfo "Creating missing files"
+ echo "version 3.138" > ${S}/build/version.txt
+ cp ${FILESDIR}/SWTMessages.properties ${S}/build/org/eclipse/swt/internal/
+
+ einfo "Packing JNI libraries"
+ ant jar || die "Failed to create JNI jar"
+}
+
+src_install() {
+ java-pkg_dojar swt.jar
+
+ java-pkg_sointo /usr/lib
+ java-pkg_doso *.so
+
+ dohtml about.html
+}
+
+pkg_postinst() {
+ if use cairo; then
+ ewarn
+ ewarn "CAIRO Support is experimental! We are not responsible if"
+ ewarn "enabling support for CAIRO corrupts your Gentoo install,"
+ ewarn "if it blows up your computer, or if it becoming sentient"
+ ewarn "and chases you down the street yelling random binary!"
+ ewarn
+ ebeep 5
+ fi
+}