summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-05-19 12:35:12 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-05-19 12:35:12 +0000
commit2c085dd1e4022f6dc1dc11411fec42b707c77e13 (patch)
treefcbd32a267ab646d1f109b4007a392ac2ef4fcc2 /dev-java
parentVersion bump (diff)
downloadgentoo-2-2c085dd1e4022f6dc1dc11411fec42b707c77e13.tar.gz
gentoo-2-2c085dd1e4022f6dc1dc11411fec42b707c77e13.tar.bz2
gentoo-2-2c085dd1e4022f6dc1dc11411fec42b707c77e13.zip
New ebuild for dev-java/netty-common, async event-driven framework for rapid development of high performance network applications; requested by Arfrever, needed for new Jython versions.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/netty-common/ChangeLog12
-rw-r--r--dev-java/netty-common/files/netty-common-4.0.19-build.xml231
-rw-r--r--dev-java/netty-common/metadata.xml5
-rw-r--r--dev-java/netty-common/netty-common-4.0.19.ebuild66
4 files changed, 314 insertions, 0 deletions
diff --git a/dev-java/netty-common/ChangeLog b/dev-java/netty-common/ChangeLog
new file mode 100644
index 000000000000..0269f9618702
--- /dev/null
+++ b/dev-java/netty-common/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-java/netty-common
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/netty-common/ChangeLog,v 1.1 2014/05/19 12:35:12 tomwij Exp $
+
+*netty-common-4.0.19 (19 May 2014)
+
+ 19 May 2014; Tom Wijsman <TomWij@gentoo.org>
+ +files/netty-common-4.0.19-build.xml, +metadata.xml,
+ +netty-common-4.0.19.ebuild:
+ New ebuild for dev-java/netty-common, async event-driven framework for rapid
+ development of high performance network applications; requested by Arfrever,
+ needed for new Jython versions.
diff --git a/dev-java/netty-common/files/netty-common-4.0.19-build.xml b/dev-java/netty-common/files/netty-common-4.0.19-build.xml
new file mode 100644
index 000000000000..5b25fa9970a4
--- /dev/null
+++ b/dev-java/netty-common/files/netty-common-4.0.19-build.xml
@@ -0,0 +1,231 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 5/15/14 7:11 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="netty-common-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="netty-common-4.0.19.Final"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ </path>
+ <path id="build.test.classpath">
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="true"
+ debug="true"
+ optimize="true"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="true"
+ memoryMaximumSize="256m"
+ memoryInitialSize="1024m"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="true"
+ debug="true"
+ optimize="true"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="true"
+ memoryMaximumSize="256m"
+ memoryInitialSize="1024m"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/*Test*.java"/>
+ <include name="**/*Benchmark*.java"/>
+ <exclude name="**/Abstract*"/>
+ <exclude name="**/TestUtil*"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/Abstract*"/>
+ <exclude name="**/TestUtil*"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="false"
+ use="true"
+ author="false"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="true"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+</project>
diff --git a/dev-java/netty-common/metadata.xml b/dev-java/netty-common/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/netty-common/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/netty-common/netty-common-4.0.19.ebuild b/dev-java/netty-common/netty-common-4.0.19.ebuild
new file mode 100644
index 000000000000..29947d34bc4e
--- /dev/null
+++ b/dev-java/netty-common/netty-common-4.0.19.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/netty-common/netty-common-4.0.19.ebuild,v 1.1 2014/05/19 12:35:12 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="netty"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Async event-driven framework for rapid development of high performance network applications"
+HOMEPAGE="http://netty.io/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/${MY_P}.Final.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=virtual/jre-1.6"
+
+DEPEND=">=virtual/jdk-1.6
+ dev-java/commons-logging:0
+ dev-java/javassist:3
+ dev-java/log4j:0
+ dev-java/slf4j-api:0
+ test? (
+ dev-java/ant-core:0
+ dev-java/easymock:3.2
+ dev-java/junit:4
+ )"
+
+S="${WORKDIR}/${MY_PN}-${MY_P}.Final/${PN/${MY_PN}-}"
+
+EANT_BUILD_TARGET="package"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_TEST_EXTRA_ARGS+=" -Djunit.present=true"
+
+# Tests fail as they might need logging to be properly set up and/or compatible.
+#
+# junit.framework.AssertionFailedError: expected:<[foo]> but was:<[NOP]>
+# at io.netty.util.internal.logging.Slf4JLoggerFactoryTest.testCreation
+RESTRICT="test"
+
+java_prepare() {
+ EANT_EXTRA_ARGS="-Dgentoo.classpath=$(java-pkg_getjars --build-only commons-logging,log4j,javassist-3,slf4j-api)"
+
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+
+ # Remove the odd memory restriction in the generated build files.
+ sed -i 's/memoryMaximumSize="256m"//' build.xml || die
+}
+
+src_test() {
+ EANT_EXTRA_ARGS="${EANT_EXTRA_ARGS}:$(java-pkg_getjars --build-only ant-core,easymock-3.2,junit-4)"
+
+ ANT_TASKS="ant-junit" java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${MY_PN}-*.jar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java
+}